FEDORA-2017-6e056b68bf created by adamwill 4 years ago for Fedora 25
stable

This update includes a proposed fix by upstream libdb developers for a bug which has been reported to cause upgrades to Fedora 26 to hang on some architectures. Note that for the fix to work fully, the updated libdb for the original release must be installed prior to the upgrade process starting, and if the upgrade process must not update to a non-patched libdb (i.e. either libdb must not be in the upgrade package set at all, or the libdb package that is upgraded to must also have the fix applied).

For Fedora 24 and Fedora 25, the update also applies some other bug fixes which have already appeared in Fedora 26. On both Fedora 24 and Fedora 25, the update additionally includes the fix for bug #1423842. On Fedora 24, the update further includes the fix for bug #1272680 (that fix has already appeared in Fedora 25).

How to install

sudo dnf upgrade --advisory=FEDORA-2017-6e056b68bf

This update has been submitted for testing by adamwill.

4 years ago

pkubat edited this update.

New build(s):

  • libdb-5.3.28-19.fc25

Removed build(s):

  • libdb-5.3.28-18.fc25

Karma has been reset.

4 years ago

besser82 edited this update.

New build(s):

  • libdb-5.3.28-21.fc25

Removed build(s):

  • libdb-5.3.28-19.fc25

Karma has been reset.

4 years ago

This update has been submitted for testing by besser82.

4 years ago

This update has been submitted for testing by adamwill.

4 years ago
User Icon besser82 commented & provided feedback 4 years ago
karma

Works great! LGTM! =)

BZ#1443415 [TRACKING] Upgrade f25 to f26 get stuck in Cleanup
BZ#1394862 libdb: Assumes that internal condition variable layout never changes
User Icon chr77 commented & provided feedback 4 years ago
karma

Works for me. No regressions noted compared to previous version.

User Icon juml commented & provided feedback 4 years ago
karma

success with upgrade from f25 to f26.

I did update libdb-5.3.28-21.fc25 from koji before running: sudo dnf --enablerepo=updates-testing system-upgrade download --refresh --releasever=26 sudo dnf system-upgrade reboot

This update has been pushed to testing.

4 years ago

This update has been submitted for stable by bodhi.

4 years ago

adamwill edited this update.

4 years ago
User Icon bojan commented & provided feedback 4 years ago

Just an FYI, got a whole bunch of these, on multiple systems:

error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch error: cannot open Packages index using db5 - (-30969) error: cannot open Packages database in /var/lib/rpm

The dnf run did finish successfully though.

User Icon alciregi commented & provided feedback 4 years ago

I had tried to upgrade from F25 to F26 a RPi3 following QA:Testcase_upgrade_dnf_current_server and without installing this update: the upgrade process got stuck on cleaning up some package.

I did a fresh install of F25 on such device. Before performing the system upgrade I installed this package update: the system upgrade was successful.

This update has been pushed to stable.

4 years ago
User Icon kparal commented & provided feedback 4 years ago
karma

Installed fresh F25 Workstation from Live, updated libdb, fully updated using gnome-software, used dnf system-upgrade to upgrade to F26, tested dnf and gnome-software. Seems to work.

User Icon kparal commented & provided feedback 4 years ago

Hmm, I updated libdb on my production F25 together with some other packages, and there's still something fishy:

  Upgrading   : java-1.8.0-openjdk-headless-1:1.8.0.131-3.b12.fc25.x86_64                                       17/44 
warning: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.131-3.b12.fc25.x86_64/jre/lib/security/java.security created as /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.131-3.b12.fc25.x86_64/jre/lib/security/java.security.rpmnew
error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /var/lib/rpm
error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /var/lib/rpm
error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /var/lib/rpm
error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /var/lib/rpm
restored /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.131-3.b12.fc25.x86_64/jre/lib/security/java.security.rpmnew to /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.131-3.b12.fc25.x86_64/jre/lib/security/java.security

But the update finished fine.

User Icon pkubat commented & provided feedback 4 years ago

DB_VERSION_MISMATCH errors are expected as libdb refuses to access its environment when there differences between the old and new environment (due to libdb upgrade) and it cannot safely rebuild it (as is the case with accessing rpmdb from scriplets)

User Icon rathann commented & provided feedback 4 years ago
karma

Causes dnf to segfault twice during "dnf upgrade". Unfortunately abrt is able to open a bug report only for one of them (first backtrace is unusable). I had to run rpm --rebuilddb to fix this. Filed https://bugzilla.redhat.com/show_bug.cgi?id=1460303 .

Also, @besser82 , giving karma to your own submissions (you edited and added packages, then upvoted them) is gaming the karma system.

User Icon rathann commented & provided feedback 4 years ago

Clarification: dnf segfaults each time until rpm --rebuilddb is invoked after this update.

User Icon tenk commented & provided feedback 4 years ago
karma

Work for me! Have to do rebuild the rpm database

User Icon chkr commented & provided feedback 4 years ago
karma

I also stumbled over the segfault issue after updating F25: - neither "dnf" nor "rpm" were able to use the rpm database - error messages as described in: https://bugzilla.redhat.com/show_bug.cgi?id=1394862#c43 - recovery via "rpm --rebuilddb" worked


Please login to add feedback.

Metadata
Type
bugfix
Severity
high
Karma
3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
modified
4 years ago
BZ#1394862 libdb: Assumes that internal condition variable layout never changes
0
1
BZ#1397087 Rpm hangs after updating to glibc >= 2.25
0
0

Automated Test Results