obsolete
FEDORA-2017-7745476dbd created by rathann 4 years ago for Fedora 26

This is the first pure WebExtension release, compatible with Firefox 57+ only.

Notable changes since 5.1.4:

  • CSP-based first-party script script blocking
  • Active content blocking with DEFAULT, TRUSTED, UNTRUSTED and CUSTOM (per site) presets
  • Extremely responsive XSS filter leveraging the webRequest asynchronous API
  • On-the-fly cross-site requests whitelisting
  • Next to come: ClearClick and ABE (in the next few weeks).
  • Fixed content process cross-framescript leak (thanks dorando for patch)

This update has been submitted for testing by rathann.

4 years ago

This update has been pushed to testing.

4 years ago

This update has been obsoleted by mozilla-noscript-10.1.2-1.fc26.

4 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
urgent
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-2
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago

Automated Test Results