FEDORA-2017-a1468ad1ae created by rohara 4 years ago for Fedora 26
stable

Use KillMode=mixed in systemd service file to avoid incorrect exist code when stopping haproxy service.

How to install

sudo dnf upgrade --advisory=FEDORA-2017-a1468ad1ae

This update has been submitted for testing by rohara.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon alciregi commented & provided feedback 4 years ago
karma

With this update I'm unable to start haproxy via systemd, see bug #1447800 Running the service from command line seems to work

# /usr/sbin/haproxy -f /etc/haproxy/haproxy.cfg -p /run/haproxy.pid -Ds

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

4 years ago

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

4 years ago
User Icon rohara commented & provided feedback 4 years ago

OK. I went back and tested the older haproxy build (haproxy-1.7.3-1.fc26.x86_64) and it also fails to start due to SELinux AVC, so this bug is not caused by this update.

User Icon rohara provided feedback 4 years ago
BZ#1447085 Use KillMode=mixed in systemd service file

This update has been submitted for stable by rohara.

4 years ago

This update has been pushed to stable.

4 years ago
User Icon anonymous commented & provided feedback 4 years ago

#1447800 is still a thing


Please login to add feedback.

Metadata
Type
bugfix
Severity
high
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
BZ#1447085 Use KillMode=mixed in systemd service file
0
1

Automated Test Results