obsolete
FEDORA-2018-1267f17424 created by pwalter 4 years ago for Fedora 28

Obsolete old caribou versions

caribou was retired in F28 GA, and then subsequently added back in updates. This commit adds obsoletes on old caribou versions, so that they get correctly uninstalled on upgrades for Workstation users. Cinnamon that now uses caribou will pull new caribou (with higher version number than what's obsoleted here) in through dependencies.

This update has been submitted for testing by pwalter.

4 years ago
User Icon tibbs commented & provided feedback 4 years ago
karma

This makes no sense at all. You need updates when updating the OS in order to see this update, but then you will also see newer caribou packages and the obsoletes added to fedora-obsolete-packages make no difference. And if you don't have updates, then you will not have this update either, and so it makes no difference.

In addition, the obsoletes were not added to the package description.

This update has been pushed to testing.

4 years ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

4 years ago

Thanks @tibbs. You are partially right: this of course didn't fix anything for existing F28 users (it wasn't even trying to). This was a fix to make F27-F28 upgrades do the correct thing and remove caribou for Workstation users. I thought about this for a bit and I think there's a way to make this do the right thing for existing F28 users as well. Fix coming up.

This update has been obsoleted by fedora-obsolete-packages-28-6.

4 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago

Automated Test Results