FEDORA-2018-12b934e224 created by smani 2 years ago for Fedora 28
stable

This update fixes CVE-2017-18267, CVE-2018-13988, CVE-2018-16646, CVE-2018-19058, CVE-2018-19059, CVE-2018-19060, CVE-2018-19149

How to install

sudo dnf upgrade --advisory=FEDORA-2018-12b934e224

This update has been submitted for testing by smani.

2 years ago

This update has been pushed to testing.

2 years ago

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago

This update has been submitted for batched by smani.

2 years ago

This update has been submitted for stable by bodhi.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
security
Severity
low
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
BZ#1578777 CVE-2017-18267 poppler: Infinite recursion in fofi/FoFiType1C.cc:FoFiType1C::cvtGlyph() function allows denial of service
0
0
BZ#1578781 CVE-2017-18267 mingw-poppler: poppler: Infinite recursion in fofi/FoFiType1C.cc:FoFiType1C::cvtGlyph() function allows denial of service [fedora-all]
0
0
BZ#1602838 CVE-2018-13988 poppler: out of bounds read in pdfunite
0
0
BZ#1607462 CVE-2018-13988 mingw-poppler: poppler: buffer overflow in pdfunite [fedora-all]
0
0
BZ#1626618 CVE-2018-16646 poppler: infinite recursion in Parser::getObj function in Parser.cc
0
0
BZ#1626621 CVE-2018-16646 mingw-poppler: poppler: infinite recursion in Parser::getObj function in Parser.cc [fedora-all]
0
0
BZ#1646546 CVE-2018-18897 poppler: memory leak in GfxColorSpace::setDisplayProfile in GfxState.cc
0
0
BZ#1646550 CVE-2018-18897 mingw-poppler: poppler: memory leak in GfxColorSpace::setDisplayProfile in GfxState.cc [fedora-all]
0
0
BZ#1649435 CVE-2018-19058 poppler: reachable abort in Object.h
0
0
BZ#1649437 CVE-2018-19058 mingw-poppler: poppler: reachable abort in Object.h [fedora-all]
0
0
BZ#1649440 CVE-2018-19059 poppler: out-of-bounds read in EmbFile::save2 in FileSpec.cc
0
0
BZ#1649442 CVE-2018-19059 mingw-poppler: poppler: out-of-bounds read in EmbFile::save2 in FileSpec.cc [fedora-all]
0
0
BZ#1649450 CVE-2018-19060 poppler: pdfdetach utility does not validate save paths
0
0
BZ#1649452 CVE-2018-19060 mingw-poppler: poppler: pdfdetach utility does not validate save paths [fedora-all]
0
0
BZ#1649457 CVE-2018-19149 poppler: NULL pointer dereference in _poppler_attachment_new
0
0
BZ#1649459 CVE-2018-19149 mingw-poppler: poppler: NULL pointer dereference in _poppler_attachment_new [fedora-all]
0
0

Automated Test Results