FEDORA-2018-264d881a62 created by fweimer 3 years ago for Fedora 28
stable

This updates contains various updates from the upstream glibc 2.27 release branch, including minor fixes for the realpath function and the i386 memmove implementation. Python helper scripts in the glibc-benchtests subpackage now use /usr/bin/python3 as the script interpreter (#1577223).

Starting with this update, glibc will no longer re-exec systemd during glibc updates (#1579225).

Reboot Required
After installing this update it is required that you reboot your system to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-264d881a62

This update has been submitted for testing by fweimer.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon besser82 commented & provided feedback 3 years ago
karma

Works great! LGTM! =)

It's giving me some dependencies problems:

Problem 1: package glibc-headers-2.27-8.fc28.i686 requires glibc = 2.27-8.fc28, but none of the providers can be installed - cannot install both glibc-2.27-14.fc28.i686 and glibc-2.27-8.fc28.i686 - cannot install both glibc-2.27-8.fc28.i686 and glibc-2.27-14.fc28.i686 - cannot install both glibc-2.27-14.fc28.x86_64 and glibc-2.27-8.fc28.x86_64 - cannot install both glibc-2.27-8.fc28.x86_64 and glibc-2.27-14.fc28.x86_64 - cannot install the best update candidate for package glibc-headers-2.27-8.fc28.i686 - cannot install the best update candidate for package glibc-2.27-8.fc28.i686 - cannot install the best update candidate for package glibc-2.27-8.fc28.x86_64 Problem 2: package libxcrypt-devel-4.0.1-1.fc28.i686 requires glibc-headers(x86-32) >= 2.26.9000-46, but none of the providers can be installed - glibc-headers-2.27-8.fc28.i686 has inferior architecture - cannot install both glibc-headers-2.27-14.fc28.x86_64 and glibc-headers-2.27-8.fc28.x86_64 - cannot install both glibc-headers-2.27-8.fc28.x86_64 and glibc-headers-2.27-14.fc28.x86_64 - cannot install the best update candidate for package libxcrypt-devel-4.0.1-1.fc28.i686 - cannot install the best update candidate for package glibc-headers-2.27-8.fc28.x86_64 Problem 3: problem with installed package glibc-headers-2.27-8.fc28.i686 - package glibc-headers-2.27-8.fc28.i686 requires glibc = 2.27-8.fc28, but none of the providers can be installed - package glibc-2.27-8.fc28.x86_64 requires glibc-common = 2.27-8.fc28, but none of the providers can be installed - package glibc-2.27-8.fc28.i686 requires glibc-common = 2.27-8.fc28, but none of the providers can be installed - cannot install both glibc-common-2.27-14.fc28.x86_64 and glibc-common-2.27-8.fc28.x86_64 - cannot install both glibc-common-2.27-8.fc28.x86_64 and glibc-common-2.27-14.fc28.x86_64 - cannot install the best update candidate for package glibc-common-2.27-8.fc28.x86_64 Problem 4: package glibc-devel-2.27-14.fc28.i686 requires libxcrypt-devel(x86-32) >= 4.0.0, but none of the providers can be installed - package libxcrypt-devel-4.0.1-1.fc28.i686 requires glibc-headers(x86-32) >= 2.26.9000-46, but none of the providers can be installed - package glibc-headers-2.27-8.fc28.i686 requires glibc = 2.27-8.fc28, but none of the providers can be installed - package glibc-2.27-8.fc28.i686 requires glibc-common = 2.27-8.fc28, but none of the providers can be installed - package libxcrypt-devel-4.0.0-5.fc28.i686 requires libxcrypt(x86-32) = 4.0.0-5.fc28, but none of the providers can be installed - cannot install both glibc-2.27-14.fc28.x86_64 and glibc-2.27-8.fc28.x86_64 - cannot install both glibc-2.27-8.fc28.x86_64 and glibc-2.27-14.fc28.x86_64 - cannot install both glibc-common-2.27-14.fc28.x86_64 and glibc-common-2.27-8.fc28.x86_64 - cannot install both glibc-common-2.27-8.fc28.x86_64 and glibc-common-2.27-14.fc28.x86_64 - cannot install both libxcrypt-4.0.0-5.fc28.i686 and libxcrypt-4.0.1-1.fc28.i686 - package libnsl-2.27-14.fc28.x86_64 requires glibc(x86-64) = 2.27-14.fc28, but none of the providers can be installed - package glibc-all-langpacks-2.27-14.fc28.x86_64 requires glibc-common = 2.27-14.fc28, but none of the providers can be installed - cannot install the best update candidate for package libxcrypt-4.0.1-1.fc28.i686 - cannot install the best update candidate for package libnsl-2.27-8.fc28.x86_64 - cannot install the best update candidate for package glibc-devel-2.27-8.fc28.i686 - cannot install the best update candidate for package glibc-all-langpacks-2.27-8.fc28.x86_64 Problem 5: package glibc-devel-2.27-14.fc28.i686 requires libxcrypt-devel(x86-32) >= 4.0.0, but none of the providers can be installed - package libxcrypt-devel-4.0.1-1.fc28.i686 requires glibc-headers(x86-32) >= 2.26.9000-46, but none of the providers can be installed - package glibc-headers-2.27-8.fc28.i686 requires glibc = 2.27-8.fc28, but none of the providers can be installed - package glibc-2.27-8.fc28.x86_64 requires glibc-common = 2.27-8.fc28, but none of the providers can be installed - package glibc-2.27-8.fc28.i686 requires glibc-common = 2.27-8.fc28, but none of the providers can be installed - problem with installed package glibc-devel-2.27-8.fc28.i686 - libxcrypt-devel-4.0.0-5.fc28.i686 has inferior architecture - cannot install both glibc-common-2.27-14.fc28.x86_64 and glibc-common-2.27-8.fc28.x86_64 - cannot install both glibc-common-2.27-8.fc28.x86_64 and glibc-common-2.27-14.fc28.x86_64 - glibc-devel-2.27-8.fc28.i686 has inferior architecture - cannot install both libxcrypt-devel-4.0.0-5.fc28.x86_64 and libxcrypt-devel-4.0.1-1.fc28.x86_64 - package glibc-langpack-en-2.27-14.fc28.x86_64 requires glibc-common = 2.27-14.fc28, but none of the providers can be installed - cannot install both glibc-devel-2.27-14.fc28.x86_64 and glibc-devel-2.27-8.fc28.x86_64 - cannot install both glibc-devel-2.27-8.fc28.x86_64 and glibc-devel-2.27-14.fc28.x86_64 - cannot install the best update candidate for package libxcrypt-devel-4.0.1-1.fc28.x86_64 - cannot install the best update candidate for package glibc-langpack-en-2.27-8.fc28.x86_64 - cannot install the best update candidate for package glibc-devel-2.27-8.fc28.x86_64 Problem 6: package glibc-static-2.27-14.fc28.x86_64 requires glibc-devel = 2.27-14.fc28, but none of the providers can be installed - package glibc-devel-2.27-14.fc28.i686 requires glibc = 2.27-14.fc28, but none of the providers can be installed - package glibc-devel-2.27-14.fc28.x86_64 requires glibc = 2.27-14.fc28, but none of the providers can be installed - glibc-2.27-14.fc28.i686 has inferior architecture - problem with installed package libxcrypt-devel-4.0.1-1.fc28.i686 - package libxcrypt-devel-4.0.1-1.fc28.i686 requires glibc-headers(x86-32) >= 2.26.9000-46, but none of the providers can be installed - package glibc-headers-2.27-8.fc28.i686 requires glibc = 2.27-8.fc28, but none of the providers can be installed - glibc-2.27-8.fc28.i686 has inferior architecture - cannot install both glibc-2.27-14.fc28.x86_64 and glibc-2.27-8.fc28.x86_64 - cannot install both glibc-2.27-8.fc28.x86_64 and glibc-2.27-14.fc28.x86_64 - cannot install the best update candidate for package glibc-static-2.27-8.fc28.x86_64 ================================================================================================================================================================================================================================================================================== Package Arch Version Repository Size ================================================================================================================================================================================================================================================================================== Skipping packages with conflicts: (add '--best --allowerasing' to command line to force their upgrade): glibc i686 2.27-14.fc28 updates-testing 3.2 M glibc x86_64 2.27-14.fc28 updates-testing 3.4 M glibc-common x86_64 2.27-14.fc28 updates-testing 751 k glibc-devel x86_64 2.27-14.fc28 updates-testing 1.0 M glibc-headers x86_64 2.27-14.fc28 updates-testing 455 k libxcrypt i686 4.0.0-5.fc28 fedora 78 k libxcrypt-devel x86_64 4.0.0-5.fc28 fedora 15 k Skipping packages with broken dependencies: glibc-all-langpacks x86_64 2.27-14.fc28 updates-testing 24 M glibc-devel i686 2.27-14.fc28 updates-testing 1.0 M glibc-langpack-en x86_64 2.27-14.fc28 updates-testing 804 k glibc-static x86_64 2.27-14.fc28 updates-testing 1.5 M libnsl x86_64 2.27-14.fc28 updates-testing 69 k libxcrypt-devel i686 4.0.0-5.fc28 fedora 15 k

Transaction Summary

Skip 13 Packages

Nothing to do. Complete!

Oops! Sorry for the formating, pasted here: https://paste.fedoraproject.org/paste/PiDymr8plFBz9wAg1Lcpyg

@fcobos, this looks like this issue: https://pagure.io/releng/issue/7071

It hits the updates-testing composes sporadically. Unfortunately, there is nothing we can do on the glibc side.

User Icon fcobos commented & provided feedback 3 years ago
karma

@fweimer, thx for the info.

Updated via:

dnf upgrade https://kojipkgs.fedoraproject.org//packages/glibc/2.27/14.fc28/i686/glibc-headers-2.27-14.fc28.i686.rpm --enablerepo=updates-testing

Everithing is working fine.

karma

This update has been submitted for batched by bodhi.

3 years ago

This update has been submitted for stable by bodhi.

3 years ago

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
security
Severity
low
Karma
3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
BZ#1577223 glibc: Use /usr/bin/python3 for benchmarks scripts
0
0
BZ#1579225 glibc: Do not run telinit u on upgrades
0
0

Automated Test Results