Update notebook to 5.5.0. See the upstream changelog.

Also ipykernel 4.8.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-3a88ea58d2

This update has been submitted for testing by churchyard.

2 years ago

churchyard edited this update.

2 years ago

dnf install ./python3-notebook-5.5.0-2.fc28.noarch.rpm

Last metadata expiration check: 0:07:38 ago on Thu 24 May 2018 08:45:46 BST. Error: Problem: conflicting requests - nothing provides python3.6dist(pyzmq) >= 17 needed by python3-notebook-5.5.0-2.fc28.noarch

That one is on it's way to stable. FEDORA-2018-30dc9a799a

Use dnf --refresh --enablerepo=updates-testing ./python3-notebook-5.5.0-2.fc28.noarch.rpm ./python-ipykernel-4.8.2-1.fc28.noarch.rpm

This update has been pushed to testing.

2 years ago

This one can't be installed. Fails with : Error: Transaction check error: file /usr/lib/python3.6/site-packages/notebook/static/components/MathJax/MathJax.js from install of python3-notebook-5.5.0-2.fc28.noarch conflicts with file from package mathjax-2.7.1-2.fc27.noarch file /usr/lib/python3.6/site-packages/notebook/static/components/MathJax/config/Safe.js from install of python3-notebook-5.5.0-2.fc28.noarch conflicts with file from package mathjax-2.7.1-2.fc27.noarch

..... and many more.

User Icon ankursinha commented & provided feedback 2 years ago
karma

Seeing the same issue as @akurtakov here - the package cannot be installed. Conflicts with an older version, and also with mathjax.

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago

Fixes 1581899. But has file conflicts with mathjax-, so I had to first remove mathjax before installing it.

User Icon lupinix commented & provided feedback 2 years ago
karma

Same for me, conflict with mathjax files.

This update has been obsoleted.

2 years ago

Oh god. The symbolic link form the previous version makes this almost unchangable :(

Let's unpush this and go with the proper fix.

churchyard edited this update.

New build(s):

  • python-notebook-5.5.0-3.fc28

Removed build(s):

  • python-notebook-5.5.0-2.fc28

Karma has been reset.

2 years ago

This update has been submitted for testing by churchyard.

2 years ago

This update has been pushed to testing.

2 years ago

@akurtakov @ankursinha @lupinix any news here? was it fixed?

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago
User Icon lupinix commented & provided feedback 2 years ago
karma

Fixed, yes. Sorry, missed to give feedback again.

This update has been submitted for batched by churchyard.

2 years ago

Thank you!

This update has been submitted for stable by bodhi.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#1438785 python-ipykernel-4.8.2 is available
0
0
BZ#1557990 python-notebook-5.5.0 is available
0
0
BZ#1580129 Failure to get Mathjax fonts
0
0
BZ#1581723 python-notebook FTBFS with pyzmq 17
0
0

Automated Test Results