Update to Blender 2.79b with several fixes

How to install

sudo dnf upgrade --advisory=FEDORA-2018-480728188f

This update has been submitted for testing by luya.

2 years ago
User Icon sobek commented & provided feedback 2 years ago
karma

The updated blender package requires updated blender-fonts package:

$ sudo dnf install ./blender-2.79b-2.fc28.x86_64.rpm
...
Error: 
 Problem: conflicting requests
  - nothing provides blender-fonts = 1:2.79b-2.fc28 needed by blender-1:2.79b-2.fc28.x86_64

$ sudo dnf list blender-fonts
...
Available Packages
blender-fonts.noarch                  1:2.79-6.fc28

Hence, updated YafaRay-blender package fails installation too because it uses the broken old blender package:

$ sudo dnf localinstall YafaRay-3.3.0-9.fc28.x86_64.rpm YafaRay-blender-3.3.0-9.fc28.x86_64.rpm YafaRay-lib-3.3.0-9.fc28.x86_64.rpm
...
Problem: package YafaRay-blender-3.3.0-9.fc28.x86_64 requires blender, but none of the providers can be installed
  - conflicting requests
  - nothing provides libboost_system.so.1.64.0()(64bit) needed by blender-1:2.79-6.fc28.x86_64

The other openvdb, alembic, and YafaRay packages install without problems and seem to be OK.

This update has been pushed to testing.

2 years ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago

hello luya, is this really a security update? regarding the release notes of versions 2.79b [https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.79/b] I cannot see any.

muench

Hello @muench, I will obsolete this test as I rebuild YafaRay to properly depend on the version of Blender and then drop the security update status.

@sobek Make sure to also download blender-fonts when you do a local update.

luya edited this update.

New build(s):

  • YafaRay-3.3.0-10.fc28

Removed build(s):

  • YafaRay-3.3.0-9.fc28

Karma has been reset.

2 years ago

This update has been submitted for testing by luya.

2 years ago

@sokek and @muench Disregarding my other comments, I replaced the broken version of YafaRay so it should properly depend on Blender 2.79b and I set the severity as bug fix. Please test and give karma, Thanks.

User Icon sobek commented & provided feedback 2 years ago
karma

@luya my bad; I could not find the blender-fonts package as a separate package; I did not realize it is provided alongside the Blender package

I noticed two minor typing mistakes in YafaRay's changelog. From my point of view "blender 2.78b" should be replaced with "Blender 2.79b"

All packages are good from my point of view. Thank you very much.

This update has been pushed to testing.

2 years ago

@sobek No problem. I will fix YafaRay's changelog in the future.

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago

This update has been submitted for batched by luya.

2 years ago

This update has been submitted for stable by bodhi.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
low
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#1504342 alembic-1.7.7 is available
0
0
BZ#1516972 [abrt] blender: ghash_keyhash(): blender killed by SIGSEGV
0
0
BZ#1548812 Broken dependencies while upgrading to rawhide/28 from 27
0
0
BZ#1548814 Broken dependencies while upgrading to rawhide/28 from 27
0
0
BZ#1549875 blender-2.79b is available
0
0
BZ#1553704 Blender will not install in Fedora 28
0
0
BZ#1556601 openvdb: FTBFS in F28
0
0
BZ#1556606 blender: FTBFS in F28
0
0

Automated Test Results