FEDORA-2018-4a56319e68

bugfix update in Fedora 29 for gnutls

Status: unpushed

Fix issue with rehandshake affecting glib-networking (#1634736)

Comments 8

This update has been submitted for testing by nmav.

This update has been pushed to testing.

Running sudo dnf upgrade --refresh I got the following errors

Problem 1: cannot install both unbound-libs-1.7.3-9.fc29.i686 and unbound-libs-1.8.1-1.fc29.i686 - package gnutls-dane-3.6.4-3.fc29.i686 requires libunbound.so.2, but none of the providers can be installed - cannot install the best update candidate for package unbound-libs-1.8.1-1.fc29.i686 - cannot install the best update candidate for package gnutls-dane-3.6.4-2.fc29.i686 Problem 2: package unbound-1.8.1-1.fc29.i686 requires libunbound.so.8, but none of the providers can be installed - package unbound-1.8.1-1.fc29.i686 requires unbound-libs(x86-32) = 1.8.1-1.fc29, but none of the providers can be installed - cannot install both unbound-libs-1.7.3-9.fc29.i686 and unbound-libs-1.8.1-1.fc29.i686 - package gnutls-dane-3.6.4-3.fc29.i686 requires libunbound.so.2, but none of the providers can be installed - package gnutls-devel-3.6.4-3.fc29.i686 requires gnutls-dane(x86-32) = 3.6.4-3.fc29, but none of the providers can be installed - cannot install the best update candidate for package unbound-1.8.1-1.fc29.i686 - cannot install the best update candidate for package gnutls-devel-3.6.4-2.fc29.i686 Problem 3: package python3-unbound-1.8.1-1.fc29.i686 requires libunbound.so.8, but none of the providers can be installed - package python3-unbound-1.8.1-1.fc29.i686 requires unbound-libs(x86-32) = 1.8.1-1.fc29, but none of the providers can be installed - cannot install both unbound-libs-1.7.3-9.fc29.i686 and unbound-libs-1.8.1-1.fc29.i686 - package gnutls-dane-3.6.4-3.fc29.i686 requires libunbound.so.2, but none of the providers can be installed - package gnutls-utils-3.6.4-3.fc29.i686 requires gnutls-dane(x86-32) = 3.6.4-3.fc29, but none of the providers can be installed - cannot install the best update candidate for package python3-unbound-1.8.1-1.fc29.i686 - cannot install the best update candidate for package gnutls-utils-3.6.4-2.fc29.i686 Problem 4: package python2-unbound-1.8.1-1.fc29.i686 requires libunbound.so.8, but none of the providers can be installed - package python2-unbound-1.8.1-1.fc29.i686 requires unbound-libs(x86-32) = 1.8.1-1.fc29, but none of the providers can be installed - cannot install both unbound-libs-1.7.3-9.fc29.i686 and unbound-libs-1.8.1-1.fc29.i686 - package gnutls-dane-3.6.4-3.fc29.i686 requires libunbound.so.2, but none of the providers can be installed - package gnutls-utils-3.6.4-3.fc29.i686 requires libgnutls-dane.so.0, but none of the providers can be installed - package gnutls-utils-3.6.4-3.fc29.i686 requires libgnutls-dane.so.0(DANE_0_0), but none of the providers can be installed - package libvirt-client-4.7.0-1.fc29.i686 requires gnutls-utils, but none of the providers can be installed - package gnutls-dane-3.6.4-2.fc29.i686 requires gnutls(x86-32) = 3.6.4-2.fc29, but none of the providers can be installed - package gnutls-utils-3.6.4-2.fc29.i686 requires gnutls(x86-32) = 3.6.4-2.fc29, but none of the providers can be installed - package gnutls-dane-3.6.4-1.fc29.i686 requires gnutls(x86-32) = 3.6.4-1.fc29, but none of the providers can be installed - package gnutls-utils-3.6.4-1.fc29.i686 requires gnutls(x86-32) = 3.6.4-1.fc29, but none of the providers can be installed - cannot install both gnutls-3.6.4-3.fc29.i686 and gnutls-3.6.4-2.fc29.i686 - cannot install both gnutls-3.6.4-1.fc29.i686 and gnutls-3.6.4-3.fc29.i686 - cannot install the best update candidate for package python2-unbound-1.8.1-1.fc29.i686 - cannot install the best update candidate for package libvirt-client-4.7.0-1.fc29.i686 - cannot install the best update candidate for package gnutls-3.6.4-2.fc29.i686 Problem 5: package libreswan-3.27-1.fc29.i686 requires libunbound.so.8, but none of the providers can be installed - cannot install both unbound-libs-1.7.3-9.fc29.i686 and unbound-libs-1.8.1-1.fc29.i686 - package gnutls-dane-3.6.4-3.fc29.i686 requires libunbound.so.2, but none of the providers can be installed - package gnutls-devel-3.6.4-3.fc29.i686 requires gnutls-dane(x86-32) = 3.6.4-3.fc29, but none of the providers can be installed - package openvas-libraries-devel-9.0.2-3.fc29.i686 requires pkgconfig(gnutls) >= 2.12, but none of the providers can be installed - package gnutls-devel-3.6.4-2.fc29.i686 requires gnutls-c++(x86-32) = 3.6.4-2.fc29, but none of the providers can be installed - package gnutls-devel-3.6.4-1.fc29.i686 requires gnutls-c++(x86-32) = 3.6.4-1.fc29, but none of the providers can be installed - cannot install both gnutls-c++-3.6.4-3.fc29.i686 and gnutls-c++-3.6.4-2.fc29.i686 - cannot install both gnutls-c++-3.6.4-1.fc29.i686 and gnutls-c++-3.6.4-3.fc29.i686 - cannot install the best update candidate for package openvas-libraries-devel-9.0.2-3.fc29.i686 - cannot install the best update candidate for package libreswan-3.27-1.fc29.i686 - cannot install the best update candidate for package gnutls-c++-3.6.4-2.fc29.i686 ...

Skipping packages with conflicts: (add '--best --allowerasing' to command line to force their upgrade): gnutls i686 3.6.4-1.fc29 fedora 870 k gnutls i686 3.6.4-3.fc29 updates-testing 871 k gnutls-c++ i686 3.6.4-1.fc29 fedora 27 k gnutls-c++ i686 3.6.4-3.fc29 updates-testing 27 k unbound-libs i686 1.7.3-9.fc29 fedora 489 k Skipping packages with broken dependencies: gnutls-dane i686 3.6.4-1.fc29 fedora 25 k gnutls-dane i686 3.6.4-3.fc29 updates-testing 25 k gnutls-devel i686 3.6.4-1.fc29 fedora 2.1 M gnutls-devel i686 3.6.4-3.fc29 updates-testing 2.1 M gnutls-utils i686 3.6.4-1.fc29 fedora 299 k gnutls-utils i686 3.6.4-3.fc29 updates-testing 299 k

gnutls-dane-3.6.4-3 requires libunbound.so.2 but unbound-libs-1.8.1-1 in updates-testing provides libunbound.so.8 Rebuilding gnutls to use libunbound.so.8 from unbound-libs-1.8.1-1 as was done in gnutls-3.6.4-2.fc29 at https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8 and adding it to that update might resolve at least some of the errors.

NACK.

It wants to remove:

Package Arch Version Repository Size

Upgrading: gnutls x86_64 3.6.4-3.fc29 updates-testing 849 k gnutls-c++ x86_64 3.6.4-3.fc29 updates-testing 26 k Removing: gnutls-dane x86_64 3.6.4-2.fc29 @System 43 k gnutls-devel x86_64 3.6.4-2.fc29 @System 4.6 M gnutls-utils x86_64 3.6.4-2.fc29 @System 1.4 M Removing dependent packages: cups-devel x86_64 1:2.2.8-5.fc29 @System 182 k libvirt-client x86_64 4.7.0-1.fc29 @System 880 k

karma: -1 critpath: -1

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

This update has been unpushed.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
unpushed
Test Gating
Submitted by
Update Type
bugfix
Update Severity
unspecified
Karma
-1
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Disabled
Autopush (time)
Disabled
Dates
submitted 10 months ago
in testing 10 months ago

Related Bugs 1

00 #1634736 Crash in libsoup get while getting https://tracker.debian.org/pkg/acpi-support/rss

Automated Test Results