stable

FEDORA-2018-4ed9ddeead created by jakub 4 years ago for Fedora 28

Upstream bugs fixed (http://gcc.gnu.org/PRNNNNN): 30792, 32957, 46921, 51434, 52991, 56540, 56667, 58150, 59781, 61135, 61358, 61775, 64089, 64107, 64124, 66128, 67370, 68256, 69395, 70409, 70468, 70875, 71085, 71169, 71464, 71546, 71569, 71784, 71832, 78090, 78238, 78420, 78741, 79085, 79410, 79937, 80227, 80551, 80598, 80965, 81236, 81572, 81611, 81812, 82005, 82022, 82336, 82410, 82411, 82484, 82565, 82813, 82851, 83148, 83149, 83193, 83327, 83335, 83392, 83399, 83451, 83456, 83496, 83503, 83519, 83633, 83662, 83692, 83712, 83871, 83901, 83911, 83916, 83917, 83937, 83939, 83969, 83983, 84015, 84039, 84076, 84114, 84171, 84176, 84178, 84207, 84219, 84222, 84231, 84264, 84277, 84288, 84294, 84325, 84346, 84355, 84404, 84408, 84424, 84426, 84427, 84434, 84441, 84447, 84456, 84466, 84468, 84480, 84486, 84489, 84492, 84493, 84497, 84506, 84509, 84511, 84512, 84517, 84519, 84520, 84521, 84523, 84524, 84526, 84528, 84530, 84532, 84533, 84534, 84537, 84538, 84540, 84545, 84546, 84548, 84551, 84552, 84556, 84557, 84558, 84559, 84560, 84564, 84565, 84574, 84575, 84578, 84582, 84584, 84590, 84593, 84596, 84597, 84601, 84602, 84607, 84609, 84614, 84617, 84618, 84620, 84625, 84628, 84634, 84639, 84645, 84650, 84658, 84662, 84663, 84664, 84670, 84671, 84682, 84683, 84684, 84686, 84687, 84694, 84697, 84700, 84702, 84704, 84707, 84708, 84710, 84711, 84720, 84721, 84722, 84723, 84724, 84725, 84726, 84733, 84734, 84735, 84739, 84740, 84742, 84743, 84746, 84748, 84752, 84763, 84767, 84769, 84770, 84772, 84773, 84775, 84777, 84780, 84785, 84786, 84798, 84801, 84802, 84803, 84805, 84807, 84808, 84813, 84820, 84827, 84828, 84830, 84831, 84833, 84834, 84839, 84841, 84843, 84844, 84852, 84853, 84860, 84873, 84874, 84876, 84880, 84899, 84902, 84906, 84909, 84910

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2018-4ed9ddeead

This update has been submitted for testing by jakub.

4 years ago

This update has been pushed to testing.

4 years ago

Sources from www.kernel.org do not compile since gcc-8.0.1-0.18.fc28 version with:

../lib/str_error_r.c: In function ‘str_error_r’:
../lib/str_error_r.c:25:3: error: passing argument 1 to restrict-qualified parameter aliases with argument 5 [-Werror=restrict]
   snprintf(buf, buflen, "INTERNAL ERROR: strerror_r(%d, %p, %zd)=%d", errnum, buf, buflen, err);
   ^~~~~~~~
cc1: all warnings being treated as errors
mv: cannot stat '/../kernels/linux-master/tools/objtool/.str_error_r.o.tmp': No such file or directory
make[3]: *** [Build:22: /../kernels/linux-master/tools/objtool/str_error_r.o] Error 1
make[2]: *** [Makefile:46: /../kernels/linux-master/tools/objtool/objtool-in.o] Error 2
make[1]: *** [Makefile:63: objtool] Error 2
make: *** [Makefile:1687: tools/objtool] Error 2
User Icon cserpentis commented & provided feedback 4 years ago
karma

works for me

User Icon sergiomb commented & provided feedback 4 years ago
karma

we need it in buildroot to test it properly

This update has been submitted for batched by jakub.

4 years ago

This update has been submitted for stable by jakub.

4 years ago
User Icon akurtakov commented & provided feedback 4 years ago
karma

works for me

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
BZ#1546743 gfortran internal compiler error when compiling cp2k-5.1 on ppc64le
0
0

Automated Test Results