Rebuilt behave for Python 3.7. Drop Python 2.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-707171340f

This update has been submitted for testing by churchyard.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon lruzicka commented & provided feedback 2 years ago
karma

I can install this update with dnf install python3-behave. If I install as python-behave, my Fedora 29 with updates-testing on offers to install python2-behave.

BZ#1605614 python-behave: FTBFS in Fedora rawhide

This update has been submitted for batched by bodhi.

2 years ago

This update has been submitted for stable by churchyard.

2 years ago

churchyard edited this update.

New build(s):

  • fedora-obsolete-packages-29-21

Karma has been reset.

2 years ago

This update has been submitted for testing by churchyard.

2 years ago
User Icon churchyard commented & provided feedback 2 years ago

Added fedora-obsolete-packages-29-21 - that obsoletes python2-behave.

User Icon lruzicka commented & provided feedback 2 years ago
karma

The fedora obsolete package works ok.

BZ#1605614 python-behave: FTBFS in Fedora rawhide
BZ#1624838 package python3-behave-1.2.6-1.fc29.noarch conflicts with python2-behave < 1.2.6 provided by python2-behave-1.2.5-23.fc28.noarch

This update has been pushed to testing.

2 years ago

This update has been submitted for batched by bodhi.

2 years ago

This update has been submitted for stable by churchyard.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
1
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#1605614 python-behave: FTBFS in Fedora rawhide
0
1
BZ#1624838 package python3-behave-1.2.6-1.fc29.noarch conflicts with python2-behave < 1.2.6 provided by python2-behave-1.2.5-23.fc28.noarch
0
1

Automated Test Results