Update LLVM to 5.0

How to install

sudo dnf upgrade --advisory=FEDORA-2018-8014b75c0d

This update has been submitted for testing by ignatenkobrain.

2 years ago

ignatenkobrain edited this update.

New build(s):

  • iwyu-0.9-0.1.20171001git576e80f.fc27
  • ispc-1.9.1-17.git.20171023.6dc0ccc.fc27
  • beignet-1.3.2-2.fc27

Karma has been reset.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon cserpentis commented & provided feedback 2 years ago
karma

works for me

User Icon dandim commented & provided feedback 2 years ago
karma

Looks good

karma: +1

User Icon greg18 provided feedback 2 years ago
karma
Test Case lldb script
User Icon filiperosset commented & provided feedback 2 years ago
karma

no regressions noted

User Icon renault commented & provided feedback 2 years ago
karma

No regression found

User Icon ozeszty commented & provided feedback 2 years ago
karma

No regressions spotted.

User Icon pwalter commented & provided feedback 2 years ago
karma

Works

This update has reached the stable karma threshold and can be pushed to stable now if the maintainer wishes.

2 years ago

This update has been submitted for batched by ignatenkobrain.

2 years ago

This update has been submitted for stable by ignatenkobrain.

2 years ago

This update has been pushed to stable.

2 years ago

The qt-creator in this update appear to have been linked with qbs-1.9.0 [Requires libqbscore.so.1.9()(64bit)], rather than the qbs-1.10.0 [Requires: libqbscore.so.1.10()(64bit)] that the previous qt-creator-4.5.0-1.fc27.x86_64 was linked with. This is creating an unresolvable conflict on my system, where qbs-1.10 is installed and required by other qt5 packages on the system. Attempting to upgrade qt-creator, clang, or beignet results in: - cannot install both qbs-1:1.9.0-1.fc27.x86_64 and qbs-1:1.10.0-1.fc27.x86_64 - package qt-creator-4.5.0-2.fc27.x86_64 requires libqbscore.so.1.9()(64bit), but none of the providers can be installed Attempting to downgrade qbs to qbs-1:1.9.0-1.fc27.x86_64 would require a large-scale downgrade of 60 updated packages (including gammaray, poppler, and all installed qt5-*) to the outdated Fedora 27 release versions.

User Icon danniel commented & provided feedback 2 years ago
karma

works

Test Case lldb script

I solved the conflict (in my "anonymous" comment above) by performing a two-stage update: dnf upgrade --best --allowerasing forced the uninstall of qt-creator-4.5.0-1.fc27 in order to update everything else. Then a manual dnf install qt-creator downgraded qbs from 1.10.0 to 1.9.0 to successfully install qt-creator-4.5.0-2.fc27. Odd that dnf couldn't automatically solve this on its own, though.

There's as update for qt-creator now: FEDORA-2018-26a5d78a58


Please login to add feedback.

Automated Test Results

Test Cases

0 2 Test Case lldb script