FEDORA-2018-80e5f21aad

enhancement update in Fedora 28 for unbound

Status: unpushed

Updated to 1.8.2, deny-ANY and serve-stale enabled

Comments 8

This update has been submitted for testing by pwouters.

This update has been pushed to testing.

 Problem: problem with installed package gnutls-dane-3.6.4-1.fc28.x86_64
  - package gnutls-dane-3.6.4-1.fc28.x86_64 requires libunbound.so.2()(64bit), but none of the providers can be installed
  - cannot install both unbound-libs-1.8.2-1.fc28.x86_64 and unbound-libs-1.7.3-10.fc28.x86_64
  - cannot install both unbound-libs-1.7.3-10.fc28.x86_64 and unbound-libs-1.8.2-1.fc28.x86_64
  - cannot install both unbound-libs-1.7.0-4.fc28.x86_64 and unbound-libs-1.8.2-1.fc28.x86_64
  - package unbound-1.8.2-1.fc28.x86_64 requires libunbound.so.8()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package unbound-1.7.3-10.fc28.x86_64
karma: -1

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

unbound-libs-0:1.8.2-1.fc28.x86_64 breaks ABI. It changes soname from libunbound.so.2 to libunbound.so.8. This is fobidden in stable releases. Please revert the upgrade.

karma: -1

It's not forbidden, but is discouraged without advanced coordination.

I'll see what depends on it and see if we can do a group update on those packages. It is a bit unfotunate. They broke one minor API issue. The bump for 2 to 8 is odd, but there arent any versions in between those.

This update has been unpushed.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
unpushed
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
-2
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Disabled
Autopush (time)
Disabled
Dates
submitted 8 months ago
in testing 8 months ago

Automated Test Results