FEDORA-2018-86feda64e9 created by pbrobinson a year ago for Fedora 29
stable

Revert aarch64 neon inflate optimisation

How to install

sudo dnf upgrade --advisory=FEDORA-2018-86feda64e9

This update has been submitted for testing by pbrobinson.

a year ago

This update has been pushed to testing.

a year ago
User Icon adamwill commented & provided feedback a year ago
karma

Not @pbrobinson 's fault, but a previous change that's included in this update breaks updates if minizip is installed - it was renamed, but @praiskup didn't do all the right things to make the rename work smoothly. I'll try and fix this up.

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

a year ago
User Icon adamwill commented & provided feedback a year ago

Ah, OK. I see the problem.

So in Rawhide, @praiskup created a new minizip source package, which provides a much newer minizip and minizip-devel. On Rawhide, if you have minizip installed and do 'dnf update', you'll get that minizip - no problem.

But that new package isn't in F29. So if you have minizip installed on F29 and run 'dnf update', you do have a problem.

To make this update sane, either it needs to include the new minizip as well, or the rename should be reverted.

User Icon churchyard commented & provided feedback a year ago
karma

` Problem 1: package minizip-1.2.11-10.fc29.x86_64 requires zlib(x86-64) = 1.2.11-10.fc29, but none of the providers can be installed - cannot install both zlib-1.2.11-13.fc29.x86_64 and zlib-1.2.11-10.fc29.x86_64 - cannot install both zlib-1.2.11-10.fc29.x86_64 and zlib-1.2.11-13.fc29.x86_64 - cannot install the best update candidate for package zlib-1.2.11-10.fc29.x86_64 - cannot install the best update candidate for package minizip-1.2.11-10.fc29.x86_64 Problem 2: package chromium-common-69.0.3497.92-1.fc29.x86_64 requires minizip(x86-64), but none of the providers can be installed - package minizip-1.2.11-10.fc29.x86_64 requires zlib(x86-64) = 1.2.11-10.fc29, but none of the providers can be installed - cannot install both zlib-1.2.11-13.fc29.x86_64 and zlib-1.2.11-10.fc29.x86_64 - cannot install both zlib-1.2.11-10.fc29.x86_64 and zlib-1.2.11-13.fc29.x86_64 - zlib-1.2.11-13.fc29.i686 has inferior architecture - cannot install the best update candidate for package zlib-1.2.11-10.fc29.i686 - cannot install the best update candidate for package chromium-common-69.0.3497.92-1.fc29.x86_64

This update has been unpushed.

User Icon pbrobinson commented & provided feedback a year ago

Will fix

pbrobinson edited this update.

New build(s):

  • zlib-1.2.11-14.fc29

Removed build(s):

  • zlib-1.2.11-13.fc29

Karma has been reset.

a year ago

This update has been submitted for testing by pbrobinson.

a year ago

pbrobinson edited this update.

a year ago

This update has been pushed to testing.

a year ago
User Icon besser82 commented & provided feedback a year ago
karma

Works great! LGTM! =)

User Icon cserpentis commented & provided feedback a year ago
karma

works for me

User Icon pwalter commented & provided feedback a year ago
karma

Works

This update has been submitted for batched by bodhi.

a year ago

This update has been submitted for stable by pbrobinson.

a year ago

This update has been pushed to stable.

a year ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
a year ago
in testing
a year ago
in stable
a year ago
modified
a year ago
BZ#1622474 readChar on gzfile returns garbage on aarch64
0
0
BZ#1626587 zlib patches, 1.11.2 → 1.11.5 breaks libgit2 as used by pygit2 on aarch64
0
0

Automated Test Results