FEDORA-2018-92b1ba0130 created by eclipseo 3 years ago for Fedora 28
unpushed

Update to 18.4.0

This update has been submitted for testing by eclipseo.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon lnie commented & provided feedback 3 years ago
karma

works

User Icon churchyard commented & provided feedback 3 years ago
karma
$ dnf install python2-twisted
$ dnf install --enablerepo=updates-testing python3-twisted  # or update
Error: Transaction check error:
  file /usr/bin/cftp from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/ckeygen from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/conch from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/mailmail from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/pyhtmlizer from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/tkconch from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/trial from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/twist from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/twistd from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/share/man/man1/conch.1.gz from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  1. you need to add explicit conflicts when you switch executables form py2 to py3 package
  2. you shouldn't switch executables form py2 to py3 like this in a stable Fedora release

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

3 years ago
User Icon acaringi commented & provided feedback 3 years ago
karma

Same conflict here...

Error: Transaction check error:
  file /usr/bin/cftp from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/ckeygen from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/conch from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/mailmail from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/pyhtmlizer from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/tkconch from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/trial from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/twist from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/bin/twistd from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64
  file /usr/share/man/man1/conch.1.gz from install of python3-twisted-18.4.0-1.fc28.x86_64 conflicts with file from package python2-twisted-16.4.1-9.fc28.x86_64

conflicts with sagemath-8.0-2.fc28.x86_64 when trying to update python2-twisted from 16.4.1-6.fc28 to 18.4.0-1.fc28

 Problem: package sagemath-8.0-2.fc28.x86_64 requires python-twisted-mail, but none of the providers can be installed
  - cannot install both python2-twisted-18.4.0-1.fc28.x86_64 and python2-twisted-16.4.1-9.fc28.x86_64
  - cannot install both python2-twisted-16.4.1-9.fc28.x86_64 and python2-twisted-18.4.0-1.fc28.x86_64
  - cannot install both python2-twisted-16.4.1-6.fc28.x86_64 and python2-twisted-18.4.0-1.fc28.x86_64
  - cannot install the best update candidate for package sagemath-8.0-2.fc28.x86_64
  - cannot install the best update candidate for package python2-twisted-16.4.1-9.fc28.x86_64

sagemath should not require python-twisted-mail, it was removed 4 years ago, I'll try to fix that.

This update has been unpushed.


Please login to add feedback.

Metadata
Type
enhancement
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
BZ#1563037 kajongg won't install because it is missing a dependency for python3-twisted
0
0

Automated Test Results