FEDORA-2018-93017c1b88 created by fab a year ago for Fedora 28
obsolete

Switch to PyPDF2 (#1592820)

This update has been submitted for testing by fab.

a year ago

This update has been pushed to testing.

a year ago
User Icon bowlofeggs commented & provided feedback a year ago
karma

I tested this by editing a PDF that had wrongly rotated pages and fixing them. Seemed to work just fine.

User Icon dreua commented & provided feedback a year ago
karma

@bowlofeggs: please test again after you removed the pyPdf package. It didn't work for me on F27 and F28.

See my bodhi comment on the F27 version of this

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

a year ago

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

a year ago
User Icon bowlofeggs commented & provided feedback a year ago
karma

Indeed, if I remove pyPdf, pdfshuffler will not start:

$ sudo dnf remove pyPdf
Dependencies resolved.
======================================================================================================================
 Package                  Arch                      Version                         Repository                   Size
======================================================================================================================
Removing:
 pyPdf                    noarch                    1.13-15.fc28                    @rawhide                    317 k

Transaction Summary
======================================================================================================================
Remove  1 Package

Freed space: 317 k
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                              1/1 
  Erasing          : pyPdf-1.13-15.fc28.noarch                                                                    1/1 
  Running scriptlet: pyPdf-1.13-15.fc28.noarch                                                                    1/1 
  Verifying        : pyPdf-1.13-15.fc28.noarch                                                                    1/1 

Removed:
  pyPdf.noarch 1.13-15.fc28                                                                                           

Complete!
$ pdfshuffler 
Error: Could not import pdfshuffler
Cause: No module named pyPdf
BZ#1592820 Pdfshuffler suffers from bugs in pyPdf, update to PyPDF2 recommended
User Icon besser82 commented & provided feedback a year ago
karma

Same finding as @bowlofeggs. Does NOT work with pyPdf removed.

This update has been obsoleted.

a year ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
-3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Dates
submitted
a year ago
in testing
a year ago
BZ#1592820 Pdfshuffler suffers from bugs in pyPdf, update to PyPDF2 recommended
-1
0

Automated Test Results