FEDORA-2018-aff51f5e62 created by pghmcfc 3 years ago for Fedora 27
stable

Python Paramiko versions 2.3.2 and 2.4.1 are vulnerable to an authentication bypass in paramiko/auth_handler.py. A remote attacker could exploit this vulnerability in Paramiko SSH servers to execute arbitrary code. Note that applications using Paramiko only as a client (such as ansible) are not affected by this.

There is also an additional fix preventing MSG_UNIMPLEMENTED feedback loops that could manifest when both ends of a connection are Paramiko-based.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-aff51f5e62

This update has been submitted for testing by pghmcfc.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon filiperosset commented & provided feedback 3 years ago
karma

no regressions noted

User Icon pwalter commented & provided feedback 3 years ago
karma

Works

This update has been submitted for batched by bodhi.

3 years ago

This update has been submitted for stable by bodhi.

3 years ago

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
security
Severity
medium
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
2
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
BZ#1637263 CVE-2018-1000805 python-paramiko: Authentication bypass in auth_handler.py
0
0
BZ#1637264 CVE-2018-1000805 python-paramiko: Authentication bypass in auth_handler.py [fedora-all]
0
0

Automated Test Results