FEDORA-2018-e4152e83b1

enhancement update in Fedora 29 for cinnamon, cinnamon-control-center, & 14 more

Status: stable 11 months ago
  • Initial cinnamon-4.0.0 release.
  • First bug fix release.
  • Switch to blue theme.
  • Second bug fix release.

  • Add Recommends onboard for fedora (#1644816)

How to install

sudo dnf upgrade --advisory=FEDORA-2018-e4152e83b1

Comments 44

This update has been submitted for testing by leigh123linux.

This update has been pushed to testing.

python3-xapps-overrides should probably obsolete python2-xapps-overrides:

Problem 2: package python2-xapps-overrides-1.2.2-1.fc29.x86_64 requires xapps(x86-64) = 1.2.2-1.fc29, but none of the providers can be installed - cannot install both xapps-1.4.0-1.fc29.x86_64 and xapps-1.2.2-1.fc29.x86_64 - cannot install both xapps-1.2.2-1.fc29.x86_64 and xapps-1.4.0-1.fc29.x86_64 - cannot install the best update candidate for package xapps-1.2.2-1.fc29.x86_64 - cannot install the best update candidate for package python2-xapps-overrides-1.2.2-1.fc29.x86_64 Problem 3: problem with installed package python2-xapps-overrides-1.2.2-1.fc29.x86_64 - package python2-xapps-overrides-1.2.2-1.fc29.x86_64 requires xapps(x86-64) = 1.2.2-1.fc29, but none of the providers can be installed - package xapps-1.2.2-1.fc29.x86_64 requires python3-xapps-overrides(x86-64) = 1.2.2-1.fc29, but none of the providers can be installed - cannot install both python3-xapps-overrides-1.4.0-1.fc29.x86_64 and python3-xapps-overrides-1.2.2-1.fc29.x86_64 - cannot install both python3-xapps-overrides-1.2.2-1.fc29.x86_64 and python3-xapps-overrides-1.4.0-1.fc29.x86_64 - cannot install the best update candidate for package python3-xapps-overrides-1.2.2-1.fc29.x86_64

@ozeszty python2-xapps-overrides can be safely removed, I will push a fixed xapp package shortly. Thanks for testing.

https://src.fedoraproject.org/rpms/xapps/c/7f3de0637baebbef3d73c0729dfdbfd99874528e?branch=master

leigh123linux edited this update.

New build(s):

  • xapps-1.4.0-2.fc29

Removed build(s):

  • xapps-1.4.0-1.fc29

Karma has been reset.

This update has been submitted for testing by leigh123linux.

leigh123linux edited this update.

New build(s):

  • mint-themes-1.7.4-0.1.20181103gitcc5ba69.fc29

Karma has been reset.

This update has been pushed to testing.

$ sudo dnf --enablerepo=*testing update nemo*

-> packages with conflicts :

Dependencies resolved.

Problem 1: package python2-xapps-overrides-1.2.2-1.fc29.x86_64 requires xapps(x86-64) = 1.2.2-1.fc29, but none of the providers can be installed - cannot install both xapps-1.4.0-1.fc29.x86_64 and xapps-1.2.2-1.fc29.x86_64 - cannot install both xapps-1.2.2-1.fc29.x86_64 and xapps-1.4.0-1.fc29.x86_64 - cannot install the best update candidate for package xapps-1.2.2-1.fc29.x86_64 - cannot install the best update candidate for package python2-xapps-overrides-1.2.2-1.fc29.x86_64 Problem 2: problem with installed package python2-xapps-overrides-1.2.2-1.fc29.x86_64 - package python2-xapps-overrides-1.2.2-1.fc29.x86_64 requires xapps(x86-64) = 1.2.2-1.fc29, but none of the providers can be installed - package xapps-1.2.2-1.fc29.x86_64 requires python3-xapps-overrides(x86-64) = 1.2.2-1.fc29, but none of the providers can be installed - cannot install both python3-xapps-overrides-1.4.0-1.fc29.x86_64 and python3-xapps-overrides-1.2.2-1.fc29.x86_64 - cannot install both python3-xapps-overrides-1.2.2-1.fc29.x86_64 and python3-xapps-overrides-1.4.0-1.fc29.x86_64 - cannot install the best update candidate for package python3-xapps-overrides-1.2.2-1.fc29.x86_64

$ nemo

nemo: symbol lookup error: nemo: undefined symbol: xapp_icon_chooser_dialog_get_type

$ sudo dnf --enablerepo=*testing update xapps python3-xapps-overrides

$ nemo

-> OK

karma: +1

Works great! LGTM! =)

karma: +1

No regressions noted.

karma: +1

Add karma.

karma: +1

Left panel zone icons are squashed when panel is set to a smaller height (also with icons set to 'scale optimally'), in other places icons scale keeping aspect ratio. I also noticed that if I use 'switch user' function and right away log back in the same user (there's no other account with previously started session), it's session is discarded and new one is being started. I could not reproduce it on other computer.

Apart from that, update to 4 looks good.

karma: +1

leigh123linux edited this update.

New build(s):

  • nemo-4.0.1-1.fc29
  • xapps-1.4.1-1.fc29
  • muffin-4.0.1-1.fc29
  • cinnamon-settings-daemon-4.0.1-1.fc29
  • cinnamon-screensaver-4.0.1-1.fc29
  • cinnamon-desktop-4.0.1-1.fc29

Removed build(s):

  • cinnamon-desktop-4.0.0-1.fc29
  • cinnamon-screensaver-4.0.0-1.fc29
  • cinnamon-settings-daemon-4.0.0-1.fc29
  • muffin-4.0.0-1.fc29
  • nemo-4.0.0-1.fc29
  • xapps-1.4.0-2.fc29

Karma has been reset.

This update has been submitted for testing by leigh123linux.

leigh123linux edited this update.

New build(s):

  • cinnamon-4.0.1-1.fc29

Removed build(s):

  • cinnamon-4.0.0-1.fc29

Karma has been reset.

This update has been pushed to testing.

Works great! LGTM! =)

karma: +1

leigh123linux edited this update.

New build(s):

  • cinnamon-4.0.1-2.fc29
  • slick-greeter-1.2.2-4.fc29
  • mint-themes-1.7.4-0.2.20181112gitb94b890.fc29

Removed build(s):

  • cinnamon-4.0.1-1.fc29
  • mint-themes-1.7.4-0.1.20181103gitcc5ba69.fc29

Karma has been reset.

This update has been submitted for testing by leigh123linux.

This update has obsoleted slick-greeter-1.2.2-3.fc29, and has inherited its bugs and notes.

leigh123linux edited this update.

New build(s):

  • nemo-extensions-4.0.0-2.fc29

Removed build(s):

  • nemo-extensions-4.0.0-1.fc29

Karma has been reset.

This update has been pushed to testing.

No regressions noted on retest.

karma: +1

If the menu applet loses it's icon run 'rm ~/.cinnamon/configs/menu@cinnamon.org/1.json'

After updating nemo and nemo-extensions (only), running nemo-desktop results in:

nemo-desktop: symbol lookup error: nemo-desktop: undefined symbol: xapp_icon_chooser_dialog_get_type
karma: -1

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

Looking at ifas' comment, the previous means that I need to update xapps from updates-testing. So it sounds like nemo-4.0.1 should really Requires: xapps >= 1.4, due to the symbol present in xapps-1.4.1-1.fc29, that isn't in libxapp.so.1 from xapps-1.2.2-1.fc29?

@ferdnyc You can't cherry pick, it all or nothing.

leigh123linux edited this update.

leigh123linux edited this update.

Stable karma threshold reduced to 2, this update will be pushed to stable!

Reiterating my +1, let's get this Cinnamony goodness pushed.

karma: +1

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

@leigh123linux: I think @ferdnyc is right. If "nemo" does not work without xapps >= 1.4 you need to edit the requirements. Otherwise you are bound to create problems for Fedora users who do not update all packages at once (even though I understand that this is discouraged).

This is why we have packages dependencies in the first place.

leigh123linux edited this update.

New build(s):

  • cinnamon-settings-daemon-4.0.2-1.fc29
  • cinnamon-4.0.2-1.fc29
  • muffin-4.0.2-1.fc29
  • nemo-4.0.2-1.fc29
  • xapps-1.4.2-1.fc29

Removed build(s):

  • cinnamon-4.0.1-2.fc29
  • cinnamon-settings-daemon-4.0.1-1.fc29
  • muffin-4.0.1-1.fc29
  • nemo-4.0.1-1.fc29
  • xapps-1.4.1-1.fc29

Karma has been reset.

This update has been submitted for testing by leigh123linux.

leigh123linux edited this update.

This update has been pushed to testing.

This update has been submitted for batched by bodhi.

This update has been submitted for stable by leigh123linux.

This update has been pushed to stable.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
+1
stable threshold: 1
unstable threshold: -7
Autopush (karma)
Enabled
Autopush (time)
Disabled
Dates
submitted a year ago
in testing 11 months ago
in stable 11 months ago
modified 11 months ago

Related Bugs 1

0+1 #1644816 Onscreen keyboard does nothing in lightdm

Automated Test Results