Improvements

  • Support for GCC 8
  • Use -fdump-lang-class instead of -fdump-class-hierarchy
  • Use -fdump-lang-raw instead of -fdump-translation-unit
  • Enable internal mangling of C++ funcs for all future GCC versions
  • Added -keep-reserved option to report changes in reserved fields
  • Fixed license to LGPL 2.1

Bug Fixes

  • Fix detection of GCC 7 compiled with --with-gcc-major-version-only
  • Fixed internal mangling
  • Escape braces in regex for compatibility with future Perl 5 versions
  • Redirect stderr of objdump -f to null

  • Rebased patch from upstream commit for gcc 8 compatibility, fixes 1575520.
  • Add findutils as a package requirement, fixes 1576567.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-f38c8d8188

This update has been submitted for testing by hobbes1069.

2 years ago

This update has obsoleted abi-compliance-checker-2.2-3.fc28, and has inherited its bugs and notes.

2 years ago

This update has been pushed to testing.

2 years ago

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago

This update has been submitted for batched by hobbes1069.

2 years ago

This update has been submitted for stable by bodhi.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
low
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
BZ#1575520 abi-compliance-checker doesn't work under F28
0
0
BZ#1576567 abi-compliance-checker: misses find dependency
0
0
BZ#1578364 abi-compliance-checker-2.3 is available
0
0

Automated Test Results