This update provides new versions of 389-ds-base and FreeIPA, with various changes and bug fixes. See the FreeIPA 4.7.0 announcement (though note this is focused on changes from 4.6 stable, not the 4.7 pre-release Fedora 28 previously carried) and 1.4.0.12 and 1.4.0.13 announcements for more information.

How to install

sudo dnf upgrade --advisory=FEDORA-2018-f6a8f8036d

This update has been submitted for testing by mreynolds.

2 years ago

This update has obsoleted 389-ds-base-1.4.0.12-1.fc28, and has inherited its bugs and notes.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon abbra commented & provided feedback 2 years ago
karma

This update breaks FreeIPA completely -- since /usr/sbin/setup-ds.pl is not installed anymore, no installation can be performed. This is visible in autmated tests and also in a bug filed on Saturday: https://bugzilla.redhat.com/show_bug.cgi?id=1606541

Automated test: https://openqa.fedoraproject.org/tests/259042

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago

This is by design as I mentioned in 1606541. If you need the old perl scripts then you need to also install 389-ds-base-legacy-tools.

This update breaks existing configuration, so it is a bug in 389-ds-base update. You need to coordinate changes with freeipa package and submit a joint update in order to not break a released distribution.

adamwill edited this update.

New build(s):

  • freeipa-4.7.0-1.fc28

Karma has been reset.

2 years ago

This update has been submitted for testing by adamwill.

2 years ago

Now with freeipa-4.7.0-1.fc28, which adds the necessary dependency to freeipa-server, things should work.

User Icon abbra commented & provided feedback 2 years ago
karma

With 4.7.0-1.fc28 domain controller test passes as well as an upgrade.

This update has been pushed to testing.

2 years ago

adamwill edited this update.

2 years ago
User Icon twoerner commented & provided feedback 2 years ago
karma

The domain controller is configured fine using freeipa-4.7.0-1.fc28 also the package upgrade is working and also the setup-ds.pl test cases are passing.

This update has reached the stable karma threshold and can be pushed to stable now if the maintainer wishes.

2 years ago
User Icon mzink commented & provided feedback 2 years ago
karma

Works for me

Works for me too

User Icon lobocode commented & provided feedback 2 years ago
karma

works

@mreynolds, could you please push the update? It is sitting in updates-testing for 20 days already.

I don;t have permission to push this! Someone else needs to do it I'm assuming someone from IPA needs to do it.

Since I don't have rights to 389-ds-base, I cannot push either. ;)

Anyone know where we file a ticket to get this "deadlock" fixed? Fedora infrastructure?

Either we can find a proven packager to do that (@adamw, please help) or you can grant me commit rights to 389-ds-base (evil me!). ;)

This update has been submitted for batched by adamwill.

2 years ago

This update has been submitted for stable by adamwill.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#1606541 freeipa-server missing dependency on 389-ds-base-legacy-tools, results in "No such file or directory: '/usr/sbin/setup-ds.pl'" error during ipa-server-install with 389-ds-base 1.4.0.12+
0
0

Automated Test Results