FEDORA-2018-fc49e5d1dc

enhancement update in Fedora 28 for vim

Status: stable a year ago

The newest upstream commit


The newest upstream commit

How to install

sudo dnf upgrade --advisory=FEDORA-2018-fc49e5d1dc

Comments 14

This update has been submitted for testing by zdohnal.

This update has obsoleted vim-8.0.1787-1.fc28, and has inherited its bugs and notes.

This update has been pushed to testing.

Seems to work

karma: +1 critpath: +1

Works

karma: +1

Works great! LGTM! =)

karma: +1

This update has been submitted for batched by bodhi.

This update has been submitted for stable by bodhi.

This update has been pushed to stable.

It's probably a little late to fix it now, but this update has a requirement on perl-libs-5.26.2, which is still in testing.

karma: -1
Error: 
 Problem 1: cannot install the best update candidate for package vim-X11-2:8.0.1763-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-X11-2:8.0.1788-1.fc28.x86_64
 Problem 2: cannot install the best update candidate for package vim-enhanced-2:8.0.1763-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
 Problem 3: package vim-enhanced-2:8.0.1763-1.fc28.x86_64 requires vim-common = 2:8.0.1763-1.fc28, but none of the providers can be installed
  - cannot install both vim-common-2:8.0.1788-1.fc28.x86_64 and vim-common-2:8.0.1763-1.fc28.x86_64
  - problem with installed package vim-enhanced-2:8.0.1763-1.fc28.x86_64
  - cannot install the best update candidate for package vim-common-2:8.0.1763-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64

karma: -1

dnf update

Last metadata expiration check: -1 day, 20:38:26 ago on Mon 07 May 2018 06:59:52 PM EST. Dependencies resolved.

Problem 1: cannot install the best update candidate for package vim-enhanced-2:8.0.1704-1.fc28.x86_64 - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64 Problem 2: problem with installed package vim-enhanced-2:8.0.1704-1.fc28.x86_64 - package vim-enhanced-2:8.0.1704-1.fc28.x86_64 requires vim-common = 2:8.0.1704-1.fc28, but none of the providers can be installed - cannot install both vim-common-2:8.0.1788-1.fc28.x86_64 and vim-common-2:8.0.1704-1.fc28.x86_64 - cannot install both vim-common-2:8.0.1704-1.fc28.x86_64 and vim-common-2:8.0.1788-1.fc28.x86_64 - cannot install the best update candidate for package vim-common-2:8.0.1704-1.fc28.x86_64 - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64 =================================================================================================================================================================================================================== Package Arch Version Repository Size =================================================================================================================================================================================================================== Skipping packages with conflicts: (add '--best --allowerasing' to command line to force their upgrade): vim-common x86_64 2:8.0.1788-1.fc28 updates 6.4 M Skipping packages with broken dependencies: vim-enhanced x86_64 2:8.0.1788-1.fc28 updates 1.3 M

Transaction Summary

Skip 2 Packages

Nothing to do.

karma: -1 critpath: -1

Am experiencing the exact same issue as above when trying to upgrade vim.

karma: -1

critpath: -1

This should have been pushed to stable together with the perl update (which is still in testing)... NOT before. Please check the failed test at "Test Gating Status", there you already see the issue…

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
+1
stable threshold: 3
unstable threshold: -3
Autopush
Enabled
Dates
submitted a year ago
in testing a year ago
in stable a year ago

Automated Test Results