obsolete

FEDORA-2018-fce9586566 created by asn 3 years ago for Fedora 28

Update to version 0.8.1

This update has been submitted for testing by asn.

3 years ago
User Icon nonamedotc commented & provided feedback 3 years ago
karma

no issues noted here.

"Warning: ssh still initialized; probably ssh_init() was called more than once (init count: 1)" which occured after 0.8.0 is gone with this update.

User Icon mikedep333 commented & provided feedback 3 years ago
karma

You provide /usr/lib64/libssh_threads.so.4 now, but are not listing the package as providing it.

$ rpm --provides -qip libssh-0.8.1-1.fc28.x86_64.rpm libssh = 0.8.1-1.fc28 libssh(x86-64) = 0.8.1-1.fc28 libssh.so.4()(64bit) libssh.so.4(LIBSSH_4_5_0)(64bit) ...

$ rpm --provides -qi libssh-0.7.5-7.fc28 libssh = 0.7.5-7.fc28 libssh(x86-64) = 0.7.5-7.fc28 libssh.so.4()(64bit) libssh_threads.so.4()(64bit) ...

$ sudo dnf update ./libssh-0.8.1-1.fc28.x86_64.rpm ./libssh-devel-0.8.1-1.fc28.x86_64.rpm Last metadata expiration check: 0:16:05 ago on Mon 13 Aug 2018 07:56:25 PM EDT. Dependencies resolved.

Problem 1: package remmina-plugins-nx-1.2.31.2-1.x86_64 requires libssh_threads.so.4()(64bit), but none of the providers can be installed - cannot install both libssh-0.8.1-1.fc28.x86_64 and libssh-0.7.5-7.fc28.x86_64 - cannot install the best update candidate for package libssh-0.7.5-7.fc28.x86_64 - problem with installed package remmina-plugins-nx-1.2.31.2-1.x86_64 Problem 2: package remmina-1.2.31.2-1.x86_64 requires libssh_threads.so.4()(64bit), but none of the providers can be installed - cannot install both libssh-0.8.1-1.fc28.x86_64 and libssh-0.7.5-7.fc28.x86_64 - package libssh-devel-0.8.1-1.fc28.x86_64 requires libssh(x86-64) = 0.8.1-1.fc28, but none of the providers can be installed - cannot install the best update candidate for package libssh-devel-0.7.5-7.fc28.x86_64 - problem with installed package remmina-1.2.31.2-1.x86_64 ======================================================================================================================================== Package Arch Version Repository Size ======================================================================================================================================== Skipping packages with conflicts: (add '--best --allowerasing' to command line to force their upgrade): libssh x86_64 0.8.1-1.fc28 @commandline 214 k Skipping packages with broken dependencies: libssh-devel x86_64 0.8.1-1.fc28 @commandline 310 k

Transaction Summary

Skip 2 Packages

Nothing to do. Complete!

User Icon mikedep333 commented & provided feedback 3 years ago
karma

Sorry for the formatting of the previous comment:

rpm --provides -qip libssh-0.8.1-1.fc28.x86_64.rpm 
libssh = 0.8.1-1.fc28
libssh(x86-64) = 0.8.1-1.fc28
libssh.so.4()(64bit)
libssh.so.4(LIBSSH_4_5_0)(64bit)
...
rpm --provides -qi libssh-0.7.5-7.fc28
libssh = 0.7.5-7.fc28
libssh(x86-64) = 0.7.5-7.fc28
libssh.so.4()(64bit)
libssh_threads.so.4()(64bit)
...
$ sudo dnf update ./libssh-0.8.1-1.fc28.x86_64.rpm ./libssh-devel-0.8.1-1.fc28.x86_64.rpm       
Last metadata expiration check: 0:16:05 ago on Mon 13 Aug 2018 07:56:25 PM EDT.
Dependencies resolved.

 Problem 1: package remmina-plugins-nx-1.2.31.2-1.x86_64 requires libssh_threads.so.4()(64bit), but none of the providers can be installed
  - cannot install both libssh-0.8.1-1.fc28.x86_64 and libssh-0.7.5-7.fc28.x86_64
  - cannot install the best update candidate for package libssh-0.7.5-7.fc28.x86_64
  - problem with installed package remmina-plugins-nx-1.2.31.2-1.x86_64
 ...
User Icon imabug provided feedback 3 years ago
karma

Any idea how to fix the provides?

Can I just add:

Provides: libssh_threads.so.4()(64bit)

This update has been obsoleted by libssh-0.8.1-2.fc28.

3 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
3 years ago
BZ#1615132 libssh-0.8.0-1.fc28.x86_64 problem
0
0
BZ#1615248 'pkg-config --modversion libssh' prints nothing after upgrade of libssh-devel
0
0

Automated Test Results