FEDORA-2019-29c418b1d7 created by devrim 2 years ago for Fedora 31
unpushed

This is an update to 6.2.0

This update has been submitted for testing by devrim.

2 years ago

This update's test gating status has been changed to 'waiting'.

2 years ago

This update's test gating status has been changed to 'ignored'.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon churchyard commented & provided feedback 2 years ago
Problem: conflicting requests
- nothing provides libproj.so.13()(64bit) needed by python3-cartopy-0.17.0-6.fc31.x86_64
Problem: package python3-geopandas-0.5.1-1.fc31.noarch requires python3.7dist(pyproj), but none of the providers can be installed
- conflicting requests
- nothing provides libproj.so.13()(64bit) needed by python3-pyproj-1.9.6-3.fc31.x86_64
- nothing provides proj-epsg needed by python3-pyproj-1.9.6-3.fc31.x86_64
- nothing provides proj-nad needed by python3-pyproj-1.9.6-3.fc31.x86_64
  • python-fiona's dependencies failed to resolve in Fedora 31
  • python-rasterio's dependencies failed to resolve in Fedora 31
  • python-geoplot's dependencies failed to resolve in Fedora 31
  • simarrange's dependencies failed to resolve in Fedora 31
  • python-xarray's dependencies failed to resolve in Fedora 31
  • python-cartopy's dependencies failed to resolve in Fedora 31
  • python-geopandas's dependencies failed to resolve in Fedora 31
  • python-libpysal's dependencies failed to resolve in Fedora 31
User Icon ppisar commented & provided feedback 2 years ago

This breaks 23 packages https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/XBTDKLBFTO4ZEF4WRARIG3SMF36BPDR3/#XBTDKLBFTO4ZEF4WRARIG3SMF36BPDR3. It also changed API, thus a straightforward rebuild is not possible.

I recommend retracting this change from Fedora 31 until all the broken packages are ready for the change in Fedora 32. Then, if we manage it sooner that F31 release, we can attach the rebuilds to this erratum. Honestly I don't believe this manageable and this change should be implemented in F32 only.

User Icon qulogic commented & provided feedback 2 years ago
karma

As noted in the spec comments, the Obsoletes and Provides should be removed after Fedora 31. (Actually, I made a mistake, they should be there for 2 releases after the last possible existence of the old name, so they should be removed after Fedora 32.)

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago

This update has been unpushed.

User Icon devrim commented & provided feedback 2 years ago

I revoked all changes in F31.

User Icon churchyard commented & provided feedback 2 years ago

Thank You.


Please login to add feedback.

Metadata
Type
enhancement
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
BZ#1713856 pyproj needs proj to upgrade to version 6.x before it can be upgraded.
0
0

Automated Test Results