obsolete
FEDORA-2019-4b7e560598 created by baude 3 years ago for Fedora 29

v1.4.4 fixes rootless


New version with performance improves for loaded systems.

This update has been submitted for testing by baude.

3 years ago

This update test gating status has been changed to 'waiting'.

3 years ago

This update has obsoleted podman-1.4.3-1.fc29, and has inherited its bugs and notes.

3 years ago

This update test gating status has been changed to 'ignored'.

3 years ago
User Icon santiago commented & provided feedback 3 years ago
karma

As I mentioned in the 1.4.3-1, it doesn't work on some installs:

# podman ps
podman: symbol lookup error: podman: undefined symbol: seccomp_api_get

Could you please add Requires: libseccomp >= 2.4.1 to the specfile?

User Icon santiago commented & provided feedback 3 years ago
karma

While we're at it, could you perhaps package an older /etc/containers/storage.conf, without metacopy=on? Even with updated libseccomp, podman fails to run:

# podman ps
Error: error creating libpod runtime: failed to mount overlay for metacopy check: invalid argument

Hand-editing storage.conf and setting mountopt = "nodev" (without metacopy=on) gets me past this.

Aside from the above issues, and nonblockers #3302 and #3359, and new (nonblocking) regression #3492, LGTM.

This update has been pushed to testing.

3 years ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

3 years ago
User Icon jerboaa commented & provided feedback 3 years ago
karma

Same issue here on an non-up-to-date F29 with respect to libseccomp:

podman: symbol lookup error: podman: undefined symbol: seccomp_api_get

Also, with systemd.unified_cgroup_hierarchy=1 this fails rather spectacularly:

$ sudo podman run -ti --memory 1g --cpuset-cpus 0,1 fedora:30 /bin/bash
Error: time="2019-07-04T21:01:58+02:00" level=warning msg="signal: killed"
time="2019-07-04T21:01:58+02:00" level=error msg="container_linux.go:346: starting container process caused \"process_linux.go:297: applying cgroup configuration for process caused \\\"mountpoint for devices not found\\\"\"\n"
container_linux.go:346: starting container process caused "process_linux.go:297: applying cgroup configuration for process caused \"mountpoint for devices not found\""
: OCI runtime error
User Icon cyberpear commented & provided feedback 3 years ago
karma

podman version shows:

$ podman version
Version:            1.4.5-dev
RemoteAPI Version:  1
Go Version:         go1.11.11
OS/Arch:            linux/amd64

This update has been obsoleted.

3 years ago

other than the cosmetic issue above, it seems to be functional for me

User Icon cyberpear provided feedback 3 years ago
karma
User Icon tdudlak provided feedback 3 years ago
karma

Please login to add feedback.

Metadata
Type
enhancement
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago

Automated Test Results