This update moves normaliz to version 3.7.4. The polymake build is simply a rebuild due to the updated version of normaliz.

Version 3.7.3 of normaliz adds the computation goals Dynamic and Static and the libnormaliz function modifyCone. These are mainly interesting for the interactive use of libnormaliz. Version 3.7.4 additionally fixes a face lattice and f-vector bug.

IMPORTANT NOTE: This release contains part of the computation and exploitation of automorphism groups, using the nauty package. Automorphism groups are not an official part of this release. With improvements and extensions they will be released in version 3.8.0. With the exception of Appendix D they do not yet appear in the manual.

Attempt 2: actually update the polymake subpackage release numbers correctly.

Attempt 3: really, actually update the polymake subpackage release numbers correctly. Sheesh.

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2019-58360c55ec

This update has been submitted for testing by jjames.

3 years ago

This update test gating status has been changed to 'waiting'.

3 years ago

This update test gating status has been changed to 'ignored'.

3 years ago

This update has been pushed to testing.

3 years ago

Getting this error when updating

Problem 1: cannot install the best update candidate for package polymake-jupyter-0.16-3.fc30.noarch
  - nothing provides python3-JuPyMake = 0.8-4.fc30 needed by polymake-jupyter-0.16-4.fc30.1.noarch
 Problem 2: problem with installed package polymake-jupyter-0.16-3.fc30.noarch
  - package polymake-jupyter-0.16-3.fc30.noarch requires python3-JuPyMake = 0.8-3.fc30, but none of the providers can be installed
  - cannot install both python3-JuPyMake-0.8-4.fc30.1.x86_64 and python3-JuPyMake-0.8-3.fc30.x86_64
  - cannot install the best update candidate for package python3-JuPyMake-0.8-3.fc30.x86_64
  - nothing provides python3-JuPyMake = 0.8-4.fc30 needed by polymake-jupyter-0.16-4.fc30.1.noarch

This update can be pushed to stable now if the maintainer wishes

3 years ago

jjames edited this update.

New build(s):

  • polymake-3.4-5.fc30

Removed build(s):

  • polymake-3.4-4.fc30

Karma has been reset.

3 years ago

This update has been submitted for testing by jjames.

3 years ago

Removing polymake-jupyter allowed me to upgrade most of the polymake packages

Upgraded:
  polymake-3.4-5.fc30.x86_64       polymake-doc-3.4-5.fc30.x86_64       polymake-singular-3.4-5.fc30.x86_64       python3-JuPyMake-0.8-4.fc30.2.x86_64

Attempting to reinstall polymake-jupyter resulted in this error

 Problem: conflicting requests
  - nothing provides python3-JuPyMake = 0.8-4.fc30 needed by polymake-jupyter-0.16-4.fc30.2.noarch

even though the python3-JuPyMake package is installed. Maybe the .2 at the end of the python3-JuPyMake version string is causing problems?

This update has been pushed to testing.

3 years ago

jjames edited this update.

New build(s):

  • normaliz-3.7.4-1.fc30
  • polymake-3.4-6.fc30

Removed build(s):

  • normaliz-3.7.3-1.fc30
  • polymake-3.4-5.fc30

Karma has been reset.

3 years ago

This update has been submitted for testing by jjames.

3 years ago

yay, everything upgrades now

This update has been pushed to testing.

3 years ago

This update can be pushed to stable now if the maintainer wishes

3 years ago

Thanks for all the testing. Sorry it took so many tries to get it right...

This update has been submitted for stable by jjames.

3 years ago

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
modified
3 years ago

Automated Test Results