FEDORA-2019-74ad6b133a

enhancement update in Fedora 30 for analitza, appmenu-qt5, & 70 more

Status: stable 6 months ago

Qt 5.12.1 LTS release, see https://blog.qt.io/blog/2018/12/06/qt-5-12-lts-released/ and https://blog.qt.io/blog/2019/02/01/qt-5-12-1-released/


Pull in upstream fix for writing errant files/dirs under $HOME

Logout Required

After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2019-74ad6b133a

Comments 70

This update has been submitted for testing by rdieter.

This update has been pushed to testing.

There are some conflicts resisting in this update:

Fedora Pastebin

Please add deepin-editor-1.2.6.3-3.fc30 and deepin-clone-1.1.0-2.fc30

Upgrading with --best --allowerasing leads to SDDM black screen

karma: -1 critpath: -1

rdieter edited this update.

New build(s):

  • deepin-editor-1.2.6.3-3.fc30
  • deepin-clone-1.1.0-2.fc30

Karma has been reset.

This update has been submitted for testing by rdieter.

dnf skipping upgrade due to lack of python3-qt5-webengine package in this build.

rdieter edited this update.

New build(s):

  • python-qt5-5.11.3-6.fc30

Removed build(s):

  • python-qt5-5.11.3-5.fc30

Karma has been reset.

This update has been pushed to testing.

Still is not upgradable due to many unresolved issues. And after forced installation SDDM (currently 0.18.0-5) shows only ENTIRE black screen

karma: -1 critpath: -1

Please add dtkcore-2.0.9.17-2.fc30

rdieter edited this update.

rdieter edited this update.

New build(s):

  • dtkcore-2.0.9.17-2.fc30

Karma has been reset.

This update has been submitted for testing by rdieter.

rdieter edited this update.

New build(s):

  • sddm-0.18.0-6.fc30

Karma has been reset.

rdieter edited this update.

New build(s):

  • kf5-akonadi-server-18.12.2-2.fc30

Karma has been reset.

works for me in a VM

karma: +1

sddm-0.18.0-6 still shows BLACK SCREEN only with a cursor. And after logging through GDM, in general, we get a pretty working environment... except for a pair of broken widgets

critpath: -1

This update has been pushed to testing.

sddm issue is selinux-related, and is being tracked in bug https://bugzilla.redhat.com/show_bug.cgi?id=1686675
This update will not go stable until that is resolved.

akonadi and kdepim are broken deps and need to be rebuild against qt5.12 .

So far works very well .

Works fine

karma: +1

@rdieter I think we should consider unpushing this update, as updates-testing is enabled by default on Branched. That means anyone who installs the KDE Beta (once we ship it) would get this installed on their first update, and no longer be able to log into the system.

Good point, unpushing.

I'll push (pun intended) harder in the aforementioned bug to get selinux policy updated to remediate this.

This update has been unpushed.

hum , now qt5-5.12 is not in any repo (base , updates or updates-testing)

dnf distro-sync will downgrade to qt5-5.11

@adamwill

unpushing this updates made package be removed from updates-testing , branched is now with qt5-5.11 [1] and not with qt5-5.12 as you expect I think

https://kojipkgs.fedoraproject.org/compose/branched/latest-Fedora-30/compose/Everything/source/tree/Packages/q/qt5-5.11.3-2.fc30.src.rpm

Therefore please consider pushing this update again to testing , bodhi let you do that . Thanks

rdieter edited this update.

New build(s):

  • qt5-qtwebengine-5.12.2-2.fc30

Removed build(s):

  • qt5-qtwebengine-5.12.1-1.fc30

Karma has been reset.

This update has been submitted for testing by rdieter.

This update has obsoleted sddm-0.18.0-4.fc30, and has inherited its bugs and notes.

This update has been pushed to testing.

LGTM except Telegram.

karma: +1 critpath: +1

works for me

karma: +1

Problems while trying to update:

dnf update

Problem 1: package analitza-18.12.2-1.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.11.3, but none of the providers can be installed - cannot install both qt5-qtbase-5.12.1-2.fc30.x86_64 and qt5-qtbase-5.11.3-4.fc30.x86_64 - cannot install both qt5-qtbase-5.11.3-4.fc30.x86_64 and qt5-qtbase-5.12.1-2.fc30.x86_64 - cannot install the best update candidate for package qt5-qtbase-5.11.3-4.fc30.x86_64 - cannot install the best update candidate for package analitza-18.12.2-1.fc30.x86_64 Problem 2: package kalgebra-18.12.2-2.fc30.x86_64 requires libAnalitza.so.8()(64bit), but none of the providers can be installed - package kalgebra-18.12.2-2.fc30.x86_64 requires libAnalitzaGui.so.8()(64bit), but none of the providers can be installed - package kalgebra-18.12.2-2.fc30.x86_64 requires libAnalitzaPlot.so.8()(64bit), but none of the providers can be installed - package kalgebra-18.12.2-2.fc30.x86_64 requires libAnalitzaWidgets.so.8()(64bit), but none of the providers can be installed - package analitza-18.12.2-1.fc30.x86_64 requires libQt5Quick.so.5(Qt_5.11.3_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install both qt5-qtdeclarative-5.12.1-1.fc30.x86_64 and qt5-qtdeclarative-5.11.3-2.fc30.x86_64 - cannot install both qt5-qtdeclarative-5.11.3-2.fc30.x86_64 and qt5-qtdeclarative-5.12.1-1.fc30.x86_64 - cannot install the best update candidate for package qt5-qtdeclarative-5.11.3-2.fc30.x86_64 - cannot install the best update candidate for package kalgebra-18.12.2-2.fc30.x86_64 Problem 3: package cantor-libs-18.12.2-1.fc30.x86_64 requires libAnalitza.so.8()(64bit), but none of the providers can be installed - package cantor-libs-18.12.2-1.fc30.x86_64 requires libAnalitzaGui.so.8()(64bit), but none of the providers can be installed - package analitza-18.12.2-1.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.11.3, but none of the providers can be installed - cannot install both qt5-qtbase-5.12.1-2.fc30.x86_64 and qt5-qtbase-5.11.3-4.fc30.x86_64 - cannot install both qt5-qtbase-5.11.3-4.fc30.x86_64 and qt5-qtbase-5.12.1-2.fc30.x86_64 - package kf5-akonadi-server-18.12.2-2.fc30.x86_64 requires libQt5Core.so.5(Qt_5.12)(64bit), but none of the providers can be installed - package kf5-akonadi-server-18.12.2-2.fc30.x86_64 requires libQt5Core.so.5(Qt_5.12.1_PRIVATE_API)(64bit), but none of the providers can be installed - package kf5-akonadi-server-18.12.2-2.fc30.x86_64 requires libQt5Sql.so.5(Qt_5.12.1_PRIVATE_API)(64bit), but none of the providers can be installed - package kf5-akonadi-server-18.12.2-2.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.12.1, but none of the providers can be installed - cannot install the best update candidate for package kf5-akonadi-server-18.12.2-1.fc30.x86_64 - cannot install the best update candidate for package cantor-libs-18.12.2-1.fc30.x86_64 . . . .

Skipping packages with conflicts: (add '--best --allowerasing' to command line to force their upgrade): qt5-qtbase x86_64 5.12.1-2.fc30 updates-testing 3.3 M qt5-qtdeclarative x86_64 5.12.1-1.fc30 updates-testing 3.4 M Skipping packages with broken dependencies: kf5-akonadi-server x86_64 18.12.2-2.fc30 updates-testing 2.6 M kf5-frameworkintegration x86_64 5.55.0-2.fc30 updates-testing 1.6 M kf5-frameworkintegration-libs x86_64 5.55.0-2.fc30 updates-testing 29 k kf5-kdeclarative x86_64 5.55.0-2.fc30 updates-testing 252 k kf5-kwayland x86_64 5.55.0-2.fc30 updates-testing 429 k kf5-kxmlgui x86_64 5.55.0-2.fc30 updates-testing 757 k

Works for me. :-)

karma: +1 critpath: +1

Qt 5.12 in general works great

karma: +1 critpath: +1

rdieter edited this update.

New build(s):

  • analitza-18.12.3-1.fc30
  • gammaray-2.10.0-1.fc30

Karma has been reset.

This update has been submitted for testing by rdieter.

analitza wasn't yet in repos but I think cantor and kalgebra also need be rebuild

This update has been pushed to testing.

Cantor and kalgebra did not require rebuilding in my own testing (only analitza)

The update worked fine with analitza included. Thanks.

critpath: +1

Seems to work just fine

karma: +1

Works

karma: +1 critpath: +1

I ran dnf upgrade on the analitza-18.12.3-1, gammaray-2.10.0-1, cantor-18.12.3-1 rpms from koji yesterday, and dnf resolved the dependencies including this qt 5.12.1 update without the errors I reported in #1697330. Plasma and the KDE applications I've tried have run normally. Thanks.

karma: +1 critpath: +1

Let's send this stable to make sure it doesn't break composes ahead of the final freeze

Bodhi says "Cannot submit qt5ct ('0', '0.35', '8.fc30') to stable since it is older than ('0', '0.38', '1.fc30')"

Looks like qt5ct has gotten a version bump and rebuilt against older qt 5.11 in the mean time ...

OK, I'll pull in qt5ct-0.38-2.fc30 when the build finishes

rdieter edited this update.

New build(s):

  • qt5ct-0.38-2.fc30

Removed build(s):

  • qt5ct-0.35-8.fc30

Karma has been reset.

This update has been submitted for testing by rdieter.

Works good

karma: +1 critpath: +1

LGTM

karma: +1 critpath: +1

This update has been pushed to testing.

No problems noted. It's works.

karma: +1 critpath: +1

Another build is now blocking this, "Cannot submit yarock ('0', '1.3.1', '8.fc30') to stable since it is older than ('0', '1.4.0', '1.fc30')"

pwalter edited this update.

New build(s):

  • yarock-1.4.0-2.fc30

Removed build(s):

  • yarock-1.3.1-8.fc30

Karma has been reset.

This update has been submitted for testing by pwalter.

This update has been pushed to testing.

Please consult all those warnings and errors generated by taskotron.

Otherwise, LGTM

karma: +1 critpath: +1

This update has been submitted for batched by bodhi.

This update has been submitted for stable by pwalter.

This update has been pushed to stable.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
enhancement
Update Severity
high
Karma
+2
stable threshold: 2
unstable threshold: -7
Autopush (karma)
Enabled
Autopush (time)
Disabled
Dates
submitted 7 months ago
in testing 6 months ago
in stable 6 months ago
modified 6 months ago
analitza-18.12.3-1.fc30
appmenu-qt5-0.3.0+16.10.20160628.1-14.fc30
calibre-3.36.0-4.fc30
deepin-clone-1.1.0-2.fc30
deepin-editor-1.2.6.3-3.fc30
deepin-file-manager-4.7.7-2.fc30
deepin-launcher-4.6.6-2.fc30
deepin-qt5integration-0.3.7.2-2.fc30
deepin-topbar-0.6.2-2.fc30
dtkcore-2.0.9.17-2.fc30
dtkwidget-2.0.9.17-2.fc30
fcitx-qt5-1.2.3-6.fc30
gammaray-2.10.0-1.fc30
hedgewars-0.9.25-4.fc30
kf5-akonadi-server-18.12.2-2.fc30
kf5-frameworkintegration-5.55.0-2.fc30
kf5-kdeclarative-5.55.0-2.fc30
kf5-kwayland-5.55.0-2.fc30
kf5-kxmlgui-5.55.0-2.fc30
kwin-5.15.2-3.fc30
libfm-qt-0.14.0-3.fc30
libqtxdg-3.3.0-2.fc30
lxqt-qtplugin-0.14.0-2.fc30
plasma-integration-5.15.2-2.fc30
python-qt5-5.11.3-6.fc30
qgnomeplatform-0.5-8.fc30
qstardict-1.3-10.fc30
qt5-5.12.1-1.fc30
qt5ct-0.38-2.fc30
qt5-qt3d-5.12.1-1.fc30
qt5-qtbase-5.12.1-2.fc30
qt5-qtcanvas3d-5.12.1-1.fc30
qt5-qtcharts-5.12.1-1.fc30
qt5-qtconnectivity-5.12.1-1.fc30
qt5-qtdatavis3d-5.12.1-1.fc30
qt5-qtdeclarative-5.12.1-1.fc30
qt5-qtdoc-5.12.1-1.fc30
qt5-qtenginio-1.6.2-22.fc30
qt5-qtgamepad-5.12.1-1.fc30
qt5-qtgraphicaleffects-5.12.1-1.fc30
qt5-qtimageformats-5.12.1-1.fc30
qt5-qtlocation-5.12.1-1.fc30
qt5-qtmultimedia-5.12.1-1.fc30
qt5-qtnetworkauth-5.12.1-1.fc30
qt5-qtquickcontrols2-5.12.1-1.fc30
qt5-qtquickcontrols-5.12.1-1.fc30
qt5-qtremoteobjects-5.12.1-1.fc30
qt5-qtscript-5.12.1-1.fc30
qt5-qtscxml-5.12.1-1.fc30
qt5-qtsensors-5.12.1-1.fc30
qt5-qtserialbus-5.12.1-1.fc30
qt5-qtserialport-5.12.1-1.fc30
qt5-qtspeech-5.12.1-1.fc30
qt5-qtstyleplugins-5.0.0-32.fc30
qt5-qtsvg-5.12.1-1.fc30
qt5-qttools-5.12.1-1.fc30
qt5-qttranslations-5.12.1-1.fc30
qt5-qtvirtualkeyboard-5.12.1-1.fc30
qt5-qtwayland-5.12.1-1.fc30
qt5-qtwebchannel-5.12.1-1.fc30
qt5-qtwebengine-5.12.2-2.fc30
qt5-qtwebkit-5.212.0-0.34.alpha2.fc30
qt5-qtwebsockets-5.12.1-1.fc30
qt5-qtwebview-5.12.1-1.fc30
qt5-qtx11extras-5.12.1-1.fc30
qt5-qtxmlpatterns-5.12.1-2.fc30
qtcurve-1.9.1-4.fc30
sddm-0.18.0-6.fc30
texmaker-5.0.3-3.fc30
ugene-1.31.1-4.fc30
xdg-desktop-portal-kde-5.15.2-2.fc30
yarock-1.4.0-2.fc30

Automated Test Results