Update to urllib3-1.25.7 and requests-2.22.0

How to install

sudo dnf upgrade --advisory=FEDORA-2019-9ca3bd3d44

This update has been submitted for testing by jcline.

5 months ago

This update's test gating status has been changed to 'waiting'.

5 months ago

This update's test gating status has been changed to 'ignored'.

5 months ago

jcline edited this update.

5 months ago

This update has been pushed to testing.

5 months ago
User Icon lslebodn commented & provided feedback 5 months ago
karma
 Problem 1: package python2-requests-2.21.0-2.fc30.noarch requires python2.7dist(urllib3) < 1.25, but none of the providers can be installed                                               
  - cannot install both python2-urllib3-1.25.7-1.fc30.noarch and python2-urllib3-1.24.3-2.fc30.noarch                                                                                      
  - cannot install both python2-urllib3-1.24.3-2.fc30.noarch and python2-urllib3-1.25.7-1.fc30.noarch                                                                                      
  - cannot install both python2-urllib3-1.24.1-3.fc30.noarch and python2-urllib3-1.25.7-1.fc30.noarch                                                                                      
  - cannot install the best update candidate for package python2-urllib3-1.24.3-2.fc30.noarch                                                                                              
  - cannot install the best update candidate for package python2-requests-2.21.0-2.fc30.noarch                                                                                             
 Problem 2: package python3-requests-2.21.0-2.fc30.noarch requires python3.7dist(urllib3) < 1.25, but none of the providers can be installed                                               
  - cannot install both python3-urllib3-1.25.7-1.fc30.noarch and python3-urllib3-1.24.3-2.fc30.noarch                                                                                      
  - cannot install both python3-urllib3-1.24.3-2.fc30.noarch and python3-urllib3-1.25.7-1.fc30.noarch                                                                                      
  - cannot install both python3-urllib3-1.24.1-3.fc30.noarch and python3-urllib3-1.25.7-1.fc30.noarch                                                                                      
  - cannot install the best update candidate for package python3-urllib3-1.24.3-2.fc30.noarch                                                                                              
  - cannot install the best update candidate for package python3-requests-2.21.0-2.fc30.noarch                                                                                             
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

5 months ago
User Icon adamwill commented & provided feedback 5 months ago
karma

yep, openQA runs into the same problem:

 Problem: package python3-requests-2.21.0-2.fc30.noarch requires python3.7dist(urllib3) < 1.25, but none of the providers can be installed
  - cannot install both python3-urllib3-1.25.7-1.fc30.noarch and python3-urllib3-1.24.3-2.fc30.noarch
  - cannot install both python3-urllib3-1.24.3-2.fc30.noarch and python3-urllib3-1.25.7-1.fc30.noarch
  - cannot install both python3-urllib3-1.24.1-3.fc30.noarch and python3-urllib3-1.25.7-1.fc30.noarch
  - cannot install the best update candidate for package python3-urllib3-1.24.3-2.fc30.noarch
  - cannot install the best update candidate for package python3-requests-2.21.0-2.fc30.noarch

The problem has been fixed by python-request 2.22 package. The Fedora distgit has been updated but the update was never build and pushed to stable. F30 is still stuck on python3-requests-2.21.0-2.fc30.

F31 is fine, though.

@jcline could you either unpush python3-urrlinb from f30 updates testing or do the combined update with python-request?

This update has been unpushed.

jcline edited this update.

New build(s):

  • python-requests-2.22.0-2.fc30

Karma has been reset.

5 months ago

This update has been submitted for testing by jcline.

5 months ago

This update has been pushed to testing.

5 months ago
User Icon pwalter commented & provided feedback 5 months ago
karma

Works

User Icon cheimes commented & provided feedback 5 months ago
karma

Works for me

This update can be pushed to stable now if the maintainer wishes

5 months ago
User Icon cairo provided feedback 5 months ago
karma

This update has been submitted for stable by jcline.

5 months ago
User Icon churchyard commented & provided feedback 5 months ago
karma

python-rasterio and python-fiona fail to build:

Problem: package python3-boto3-1.9.101-1.fc30.noarch requires python3.7dist(botocore) >= 1.12.101, but none of the providers can be installed
- package python3-boto3-1.9.101-1.fc30.noarch requires python3.7dist(botocore) < 1.13.0, but none of the providers can be installed
- conflicting requests
- nothing provides python3.7dist(urllib3) < 1.25 needed by python3-botocore-1.12.101-1.fc30.noarch

This update has been pushed to stable.

5 months ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Dates
submitted
5 months ago
in testing
5 months ago
in stable
5 months ago
modified
5 months ago

Automated Test Results