FEDORA-2019-e8db3bef68 created by amatej 10 months ago for Fedora 30
stable

dnf-plugins-extras

  • [system-upgrade] Reset libgit2 module when on F31 (RhBug: 1747408)

dnf-plugins-extras

  • [system-upgrade] Use --system-upgrade plymouth mode (RhBug:1681584)
  • [system-upgrade] Fix traceback caused by setting gpgcheck options (RhBug:1751103,1746346)
  • Fix kickstart plugin (RhBug:1649093)
  • [system-upgrade] Ensure identical transaction in download and update steps (RhBug:1758588)
  • [system-upgrade] Provide distro specific url for help with system-upgrade

How to install

sudo dnf upgrade --advisory=FEDORA-2019-e8db3bef68

This update has been submitted for testing by amatej.

10 months ago

This update's test gating status has been changed to 'waiting'.

10 months ago

This update has obsoleted dnf-plugins-extras-4.0.7-1.fc30, and has inherited its bugs and notes.

10 months ago

This update's test gating status has been changed to 'ignored'.

10 months ago
User Icon churchyard commented & provided feedback 10 months ago
karma
$ dnf system-upgrade download --release=31
...
Resetting modules:
 libgit2
BZ#1747408 Cannot upgrade to Fedora 31: package exa-0.9.0-2.module_f31+5365+04413d87.x86_64 requires libgit2.so.28()(64bit), but none of the providers can be installed

This update has been pushed to testing.

10 months ago
User Icon egreshko commented & provided feedback 10 months ago

Still failing for me with

2019-10-18T23:28:00Z CRITICAL Error opening file for checksum: /var/lib/dnf/system-upgrade/rpmfusion-free-058b175644bc1430/packages/rpmfusion-free-appstream-data-30-1.20181021.fc30.noarch.rpm 2019-10-18T23:28:00Z CRITICAL Package "rpmfusion-free-appstream-data-30-1.20181021.fc30.noarch" from repository "rpmfusion-free" has incorrect checksum 2019-10-18T23:28:00Z CRITICAL Error opening file for checksum: /var/lib/dnf/system-upgrade/rpmfusion-nonfree-c253272f7b309f17/packages/rpmfusion-nonfree-appstream-data-30-1.20181021.fc30.noarch.rpm 2019-10-18T23:28:00Z CRITICAL Package "rpmfusion-nonfree-appstream-data-30-1.20181021.fc30.noarch" from repository "rpmfusion-nonfree" has incorrect checksum

BZ#1758588 dnf system-upgrade reboot fails due to depresolv difference with download
User Icon frantisekz commented & provided feedback 10 months ago
karma

system-upgrade to f31 works fine.

This update can be pushed to stable now if the maintainer wishes

10 months ago
User Icon mhayden commented & provided feedback 10 months ago
karma

No issues noted.

This update has been submitted for stable by bodhi.

10 months ago
User Icon adamwill commented & provided feedback 10 months ago
karma

Looks good to me, I tested and was able to confirm this seems to address both #1747408 and #1758588.

@egreshko, this update is not intended to address your specific case here.

BZ#1747408 Cannot upgrade to Fedora 31: package exa-0.9.0-2.module_f31+5365+04413d87.x86_64 requires libgit2.so.28()(64bit), but none of the providers can be installed
BZ#1758588 dnf system-upgrade reboot fails due to depresolv difference with download
User Icon rgessner commented & provided feedback 10 months ago

works

BZ#1747408 Cannot upgrade to Fedora 31: package exa-0.9.0-2.module_f31+5365+04413d87.x86_64 requires libgit2.so.28()(64bit), but none of the providers can be installed
BZ#1758588 dnf system-upgrade reboot fails due to depresolv difference with download

This update has been pushed to stable.

10 months ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
10 months ago
in testing
10 months ago
in stable
10 months ago
BZ#1681584 RFE: Use "plymouth change-mode --system-upgrade" on systems upgrades
0
0
BZ#1747408 Cannot upgrade to Fedora 31: package exa-0.9.0-2.module_f31+5365+04413d87.x86_64 requires libgit2.so.28()(64bit), but none of the providers can be installed
0
3
BZ#1758588 dnf system-upgrade reboot fails due to depresolv difference with download
-1
2

Automated Test Results