Rebase xz to version 5.2.5. perl-Compress-Raw-Lzma has to be rebuilt when xz is updated, so it is included here also. man-pages-de has a file conflict with xz-lzma-compat, added here as well.

How to install

sudo dnf upgrade --advisory=FEDORA-2020-565a21aedb

This update has been submitted for testing by odubaj.

10 months ago

This update's test gating status has been changed to 'waiting'.

10 months ago

This update's test gating status has been changed to 'ignored'.

10 months ago

odubaj edited this update.

10 months ago
User Icon adamwill commented & provided feedback 10 months ago
karma

There's some kind of dependency issue here which the openQA tests are catching: something in the FreeIPA tests does not want to have xz 5.2.5, for some reason. It's getting stuck at 5.2.4. There doesn't seem to be a library soname bump in the package, or anything, I can only assume something has a "< 5.2.5" dependency or something like that. I'm currently poking through the package collection trying to find out what, but until I can figure it out, leaving -1.

User Icon adamwill commented & provided feedback 10 months ago

Ah, OK, so, it seems:

freeipa-server requires 389-ds-base 389-ds-base requires perl-Archive-Tar perl-Archive-Tar requires perl(IO::Compress::Xz) and perl(IO::Uncompress::UnXz) perl-IO-Compress-Lzma provides those, and requires perl(Compress::Raw::Lzma) perl-Compress-Raw-Lzma provides that, and requires xz-libs(x86-64) = 5.2.4

and so we have solved our mystery! It seems perl-Compress-Raw-Lzma will need to be rebuilt and added to this update. If that's straightforward I can do it, I'll have a look. Pinging @pghmcfc for info.

adamwill edited this update.

New build(s):

  • perl-Compress-Raw-Lzma-2.093-4.fc32

Karma has been reset.

10 months ago

This update has been pushed to testing.

9 months ago
User Icon pghmcfc commented & provided feedback 9 months ago

perl-Compress-Raw-Lzma records the version of the LZMA library it was built against and there can be issues if the run-time version is different, hence the versioned dependency. Rebuilding it against the new xz and having a single update for both is exactly the right thing to do.

User Icon pbrobinson commented & provided feedback 9 months ago
karma

Seems OK with basic testing

BZ#1818418 xz-5.2.5 is available
User Icon pwalter commented & provided feedback 9 months ago
karma

Works

This update can be pushed to stable now if the maintainer wishes

9 months ago
User Icon besser82 commented & provided feedback 9 months ago
karma

This update introduces file conflicts:

Error: Transaction test error:
  file /usr/share/man/de/man1/xzdiff.1.gz from install of xz-lzma-compat-5.2.5-1.fc32.x86_64 conflicts with file from package man-pages-de-1.22-8.fc32.noarch
  file /usr/share/man/de/man1/xzgrep.1.gz from install of xz-lzma-compat-5.2.5-1.fc32.x86_64 conflicts with file from package man-pages-de-1.22-8.fc32.noarch
  file /usr/share/man/de/man1/xzless.1.gz from install of xz-lzma-compat-5.2.5-1.fc32.x86_64 conflicts with file from package man-pages-de-1.22-8.fc32.noarch
  file /usr/share/man/de/man1/xzmore.1.gz from install of xz-lzma-compat-5.2.5-1.fc32.x86_64 conflicts with file from package man-pages-de-1.22-8.fc32.noarch

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

9 months ago

besser82 edited this update.

New build(s):

  • man-pages-de-1.22-9.fc32

Karma has been reset.

9 months ago

This update has been submitted for testing by besser82.

9 months ago
User Icon besser82 commented & provided feedback 9 months ago
karma

LGTM, now. =)

BZ#1818418 xz-5.2.5 is available
BZ#1819815 xz-lzma-compat has file conflicts with man-pages-de

This update has been pushed to testing.

9 months ago

pwalter edited this update.

9 months ago
User Icon pwalter commented & provided feedback 9 months ago
karma

Works

This update can be pushed to stable now if the maintainer wishes

9 months ago

besser82 edited this update.

9 months ago
User Icon kuosmanen commented & provided feedback 9 months ago
karma

Installs and seems to be working well

This update has been submitted for stable by bodhi.

9 months ago

This update has been pushed to stable.

9 months ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
medium
Karma
3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
10 months ago
in testing
9 months ago
in stable
9 months ago
modified
9 months ago
BZ#1818418 xz-5.2.5 is available
0
1
BZ#1819815 xz-lzma-compat has file conflicts with man-pages-de
0
1

Automated Test Results