The 5.5.5 kernel rebase contains additional hardware support, new features, and a number of bug fixes across the tree.

Reboot Required
After installing this update it is required that you reboot your system to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2020-cf2eacc932

This update has been submitted for testing by jforbes.

3 months ago

This update's test gating status has been changed to 'waiting'.

3 months ago

This update's test gating status has been changed to 'ignored'.

3 months ago
User Icon markec commented & provided feedback 3 months ago
karma

Nice +1

User Icon imabug provided feedback 3 months ago
karma
User Icon arcivanov commented & provided feedback 3 months ago
karma

5.5.x are missing critical patches in drm/i915 which render Intel systems unusable (hanging X) with all 5.5 kernels. The patches into 5.5.x are pending but are not there yet.

https://gitlab.freedesktop.org/drm/intel/issues/1201 https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.5-Intel-Missed-Graphics

Are you recycling Phoronix or actually hitting an issue?

Hm, running 5.5.3 here on T490s and seems okay...

@jforbes, I hit it immediately trying your kernel build with 5.5.2 from Koji installed manually. I was one of the first reporters too: https://gitlab.freedesktop.org/drm/intel/issues/1179

Dell Precision 5540 (Coffeelake)

Right, I have brought in the patch bbca083de291, but the other needs a backport. I had expected Chris to do the backport, but it hasn't shown yet.

User Icon ibims commented & provided feedback 3 months ago
karma

Seems ok. Works on baremetal (non UEFI) AMD Ryzen5 3600, Mainboard MSI B450M Mortar Max with prop. nvidia driver from rpmfusion.org (GTX980 card), VirtualBox 6.1.4 from Oracle and Gnome-Desktop. Regression test passed (paxtest, selinux-dac-controls and libhugetlbfs skipped)

User Icon g6avk commented & provided feedback 3 months ago
karma

Works for me...
I just updated the kernal test suite and see Paxtest is now skipped as well.
The enabled Default and the Performance tests pass OK. AMD 965, x86_64 work station, RAID-1, Plasma DE, X-server, nVidia GTX 650 (GK107) + nVidia RPM's from Negativo17 (440.59)

User Icon lmouillart commented & provided feedback 3 months ago
karma

Works for me (Dell Inspiron 5579 - i7-8550u / I620 IGP).

User Icon xvitaly commented & provided feedback 3 months ago
karma

Works for me. No regressions noted.

To everyone testing on Intel chipsets, make sure to also test with either LibreOffice or PyCharm/JetBrains IDE and manipulate (resize/move/type in the UI) to attempt to trigger the i915 VMA/list corruption bugs.

This update has been pushed to testing.

3 months ago

This update can be pushed to stable now if the maintainer wishes

3 months ago
User Icon dm0 provided feedback 3 months ago
karma
User Icon bojan commented & provided feedback 3 months ago
karma

Seems to work here on T450s and XS35GTv2.

User Icon atim provided feedback 3 months ago
karma
User Icon vascom commented & provided feedback 3 months ago
karma

Work good.

User Icon agurenko commented & provided feedback 3 months ago
karma

Works well on Lenovo T460p, actually 5.5.x performs better than all 5.4.x kernels.

User Icon decathorpe commented & provided feedback 3 months ago
karma

Works fine so far. Default and performance regression test suites also passed on both my systems:

  • ryzen 1700X + NVidia GTX 1070 w/ negativo17 drivers
  • dell XPS 13 9370 (2018)
karma
User Icon micmor commented & provided feedback 3 months ago
karma

Many errors with wifi firmware (iwlwifi) The wifi is not operational. Unable to activate it.

User Icon rgessner commented & provided feedback 3 months ago
karma

Works fine

User Icon gourlaysama commented & provided feedback 3 months ago
karma

Seems to work fine on both my systems: - Dell Precision M4800 - i7-4900MQ - Quadro K2100M (nvidia 418.113) - Dell Inspiron 7391 2n1 - i7-10510U - UHD620 i915

User Icon itrymybest80 commented & provided feedback 3 months ago
karma

Installed the update and rebooted my computer, allowed the testsuite to make their heap memory executable and ran the regression tests and both PASS, though "libhugetlbfs" and "paxtest" was skipped. Additionally my audio, video, applications, native & wine/proton games over dxvk and LUKS full disc encryption works. Tested on Fedora 31 (x86_64) with PRIME Z270-A, i5-7600K, 16GB DDR4, RX 580 8GB (with MESA 19.2.8) and 970 EVO M.2.

User Icon mhayden commented & provided feedback 3 months ago
karma

Working solidly on a Ryden 3700X + nvidia GeForce RTX 2060 (with nvidia 440.59 drivers).

User Icon frantisekz commented & provided feedback 3 months ago
karma

Looks OK on T470s/ Intel iGPU

User Icon sedrubal commented & provided feedback 3 months ago
karma

Works on Thinkpad P70, Intel GPU. Somehow the drm/i915 bug did not produce any crash since the update. But that could be a coincidence.

User Icon stklcode commented & provided feedback 3 months ago

Works for me overall. Tests passing, system running stable. Intel Skylake-X, nVidia TU116 GPU (440.59 drivers from RPM Fusion), NVMe, intel Ethernet.

Occasionally running into nv_drm_atomic_helper_disable_all warnings[1][2] during boot. However this does not seem to have any real impact on the system afterwards.

[1] https://devtalk.nvidia.com/default/topic/1071120/-bug-nvidia-440-59-kernel-5-5-1-stable-boot-trace/

[2] https://patchwork.freedesktop.org/patch/347647/

User Icon jbwillia commented & provided feedback 3 months ago
karma

wfm

User Icon mobicarte commented & provided feedback 3 months ago
karma

Fedora 31 with latest updates + 5.5.5-200.fc31, can't resume from sleep (had the same issue with Linux 5.3.x kernels). I'm not even sure it reaches S3 as my laptop spent the whole day draining its battery and keeping itself warm. Will do further testing to check if this issue can be reproduced easily and diagnose its origin.

This said, my mic is now functionnal under Linux thanks to Linux 5.5.

Hardware: Lenovo X1 Carbon 7th gen with 8th gen Intel CPU, no external peripherals, no LTE card, Bluetooth disabled in UEFI.

User Icon dimitrisk commented & provided feedback 3 months ago
karma

No regressions here. ThinkPad T495, Ryzen 3700U. Intel 9260 wifi works (WPA3 SAE network).

Follow up on my last comment: I can reproduce the issue and I think it's related to the audio subsystem.

I can suspend/resume if the "Cannon Point-LP High Definition Audio Controller" is set to its "Disabled" profile in pavucontrol (which means my speakers/mic/headphones aren't working). If I set it to "Play HiFi quality Music (unavailable)", the audio is working but I can't get out of suspend mode.

Some people are experiencing the same issues on this specific laptop: https://bugzilla.redhat.com/show_bug.cgi?id=1772498

This update has been submitted for stable by jforbes.

3 months ago
User Icon mharpau commented & provided feedback 3 months ago
karma

T480 + T480s no regressions.

This update has been pushed to stable.

3 months ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
19
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Dates
submitted
3 months ago
in testing
3 months ago
in stable
3 months ago

Automated Test Results

Test Cases

-1 12 Test Case kernel regression