This is a Bodhi feature and bugfix release which is needed to support new functionality deployed in Fedora infrastructure, along with an update for fedpkg accommodating the new version.

Users, especially of the Bodhi server components, are advised to acquaint themselves with incompatible changes and upgrade procedures documented in the version 5.0.0 release notes, as well as further changes for versions 5.1.0 and 5.1.1 before updating to this version.

How to install

sudo dnf upgrade --advisory=FEDORA-2020-fe8a66f4ed

This update has been submitted for testing by nphilipp.

3 months ago

This update's test gating status has been changed to 'waiting'.

3 months ago

This update's test gating status has been changed to 'failed'.

3 months ago

This update has been pushed to testing.

3 months ago
User Icon jayjayjazz commented & provided feedback 3 months ago
karma

LGTM

BZ#1743791 bodhi-5.1.1 is available
User Icon atim commented & provided feedback 3 months ago

When i am trying to fedpkg update i got

Could not execute update: This system has bodhi v5, which is unsupported.

User Icon gbcox commented & provided feedback 2 months ago
karma

I'm receiving the same message and opened a bug here:

Could not execute update: This system has bodhi v5, which is unsupported.

https://bugzilla.redhat.com/show_bug.cgi?id=1796972

Major fail. You need to immediate rollback this update or get it to work with the current processes.

User Icon cverna commented & provided feedback 2 months ago

We are checking with the fedpkg maintainers what needs to be done to have fedpkg support bodhi 5.

User Icon nphilipp commented & provided feedback 2 months ago

Major fail. You need to immediate rollback

Finding out issues like this is what the testing stage is for. I assume it's just a matter of upping the "allowed maximum Bodhi version" in fedpkg, though I can't say why this hard lock exists (without a corresponding package version conflict) in the first place.

User Icon gbcox commented & provided feedback 2 months ago

Finding out issues like this is what the testing stage is for. I assume it's just a matter of upping the "allowed maximum Bodhi version" in fedpkg, though I can't say why this hard lock exists (without a corresponding package version conflict) > in the first place.

To an extent, but you're not suppose to push something without ANY testing - and fedpkg is an important dependency - and this issue is exposed quite easily. In fact, this issue was first reported 3 days ago - almost immediately after the change was pushed. If you don't want to respond to messages over the weekend, then you should push your changes on a Monday.

User Icon onosek commented & provided feedback 2 months ago

Hi @nphilipp,

you can try adding this fedpkg build into your update. I think it is better to release both packages together.

fedpkg-1.37-13.fc31.noarch.rpm https://koji.fedoraproject.org/koji/buildinfo?buildID=1456050

I have already pushed fc32 version, but currently, I am not able to build fc30 version.

nphilipp edited this update.

2 months ago

nphilipp edited this update.

New build(s):

  • fedpkg-1.37-13.fc31

Karma has been reset.

2 months ago

This update has been submitted for testing by nphilipp.

2 months ago

This update has been pushed to testing.

2 months ago

This update's test gating status has been changed to 'waiting'.

2 months ago

This update's test gating status has been changed to 'passed'.

2 months ago

This update's test gating status has been changed to 'passed'.

2 months ago

nphilipp edited this update.

2 months ago
User Icon nphilipp commented & provided feedback 2 months ago

As discussed, the F30 build didn't work because of the even older Bodhi version available in the build roots. I've built the patched fedpkg for F30 with this version as a buildroot override.

User Icon atim commented & provided feedback 2 months ago
karma

Now LGTM.

BZ#1743791 bodhi-5.1.1 is available
User Icon pwalter commented & provided feedback 2 months ago
karma

Works

This update can be pushed to stable now if the maintainer wishes

2 months ago
User Icon decathorpe commented & provided feedback 2 months ago
karma

Works fine.

BZ#1779753 bodhi fails to build in Fedora 32
BZ#1743791 bodhi-5.1.1 is available
User Icon cairo provided feedback 2 months ago
karma
User Icon dridi commented & provided feedback 2 months ago
karma

I was interested in the man page update, I didn't look at the bugs or test cases, LGTM overall.

User Icon onosek commented & provided feedback 2 months ago

Hi @nphilipp, what is your plan with this (and f30 as well) update? It looks it reached enough karma to be pushed into the stable. And later I can use this build for new regular fedpkg release.

User Icon nphilipp commented & provided feedback 2 months ago

Hi @onosek, both updates look good enough to me to be pushed to stable.

This update has been submitted for stable by nphilipp.

2 months ago

This update has been pushed to stable.

2 months ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
5
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-30
Dates
submitted
3 months ago
in testing
2 months ago
in stable
2 months ago
modified
2 months ago
BZ#1743791 bodhi-5.1.1 is available
0
2
BZ#1779753 bodhi fails to build in Fedora 32
0
1

Automated Test Results

Test Cases

0 1 Test Case build from distgit with mock
0 1 Test Case clone distgit repository
0 1 Test Case download upstream sources
0 1 Test Case scratch build from distgit