Update to Vagrant 2.2.16 and vagrant-libvirt 0.4.1. Fixes several incompatibilities with Ruby 3.0.

How to install

sudo dnf upgrade --advisory=FEDORA-2021-17ded5c4ca

This update has been submitted for testing by pvalena.

a year ago

This update's test gating status has been changed to 'ignored'.

a year ago

This update's test gating status has been changed to 'waiting'.

a year ago

This update's test gating status has been changed to 'ignored'.

a year ago

This update has been pushed to testing.

a year ago
User Icon mattia commented & provided feedback a year ago
karma

still getting /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:intranslate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)` when trying to bring up machines

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

a year ago
User Icon mharpau commented & provided feedback a year ago
karma

No regressions for a configuration with 7 VMs on virtualbox and one with a VM on libvirt.

pvalena edited this update.

New build(s):

  • vagrant-libvirt-0.4.1-2.fc34

Removed build(s):

  • vagrant-libvirt-0.4.1-1.fc34

Karma has been reset.

a year ago

This update has been submitted for testing by pvalena.

a year ago
User Icon pvalena commented & provided feedback a year ago

@mattia Although unrelated to the update, I've added patch for vagrant-libvirt with upsteam fix.

Thanks for testing!

Rawhide test log: https://git.io/JsRQO

BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)
User Icon pvalena provided feedback a year ago
User Icon mattia commented & provided feedback a year ago
karma

Thanks, it's working now!

BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)
User Icon steve provided feedback a year ago
karma
BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)

This update has been pushed to testing.

a year ago

This update can be pushed to stable now if the maintainer wishes

a year ago
User Icon mohd-akram provided feedback a year ago
karma
BZ#1872307 vagrant-2.2.16 is available
BZ#1884945 vagrant-libvirt-0.4.1 is available
BZ#1915671 undefined method `request'
BZ#1945740 vagrant seems to be missing a dependency on rexml
BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)

This update has been submitted for stable by bodhi.

a year ago
User Icon renich commented & provided feedback a year ago
karma

Works flawlessly. Many thanks.

I've tested with:

Vagrant.configure('2') do |config|
  config.vm.box = 'centos-8-stream'
  config.vm.provision :shell, path: 'bootstrap.sh'

  config.vm.network :public_network,
    :dev => 'virbr1',
    :libvirt_network_name => 'private',
    :type => 'bridge'

  config.vm.provider :libvirt do |libvirt|
    libvirt.qemu_use_session = false
    libvirt.cpus = 4
    libvirt.driver = 'kvm'
    libvirt.graphics_type = 'spice'
    libvirt.id_ssh_key_file = "$HOME/.ssh/id_ed25519"
    libvirt.keymap = 'es'
    libvirt.machine_virtual_size = 50
    libvirt.memory = 4096
    libvirt.storage_pool_name = 'default'
  end

  (0..3).each do |i|
    config.vm.define "minio#{i}" do |node|
      node.vm.hostname = "minio#{i}.virt.g02.org"

      node.vm.provider :libvirt do |libvirt|
        libvirt.storage :file, size: '100G', path: "minio#{i}-vdb.qcow"
      end
    end
  end
end

# vim: set ft=ruby :
BZ#1835308 Vagrant is unable to install plugins
BZ#1872307 vagrant-2.2.16 is available
BZ#1884945 vagrant-libvirt-0.4.1 is available
BZ#1915671 undefined method `request'
BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)

This update has been pushed to stable.

a year ago
User Icon odilhao commented & provided feedback a year ago
karma

Installed this update earlier this week and forgot to give the feedback. It fixed my problem with vagrant + libvirt on F34

BZ#1835308 Vagrant is unable to install plugins
BZ#1872307 vagrant-2.2.16 is available
BZ#1915671 undefined method `request'
BZ#1945740 vagrant seems to be missing a dependency on rexml
BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)

Please login to add feedback.

Metadata
Type
enhancement
Karma
5
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
a year ago
in testing
a year ago
in stable
a year ago
modified
a year ago
BZ#1835308 Vagrant is unable to install plugins
0
2
BZ#1872307 vagrant-2.2.16 is available
0
3
BZ#1884945 vagrant-libvirt-0.4.1 is available
0
2
BZ#1915671 undefined method `request'
0
3
BZ#1945740 vagrant seems to be missing a dependency on rexml
0
2
BZ#1947885 /usr/share/gems/gems/i18n-1.8.7/lib/i18n.rb:195:in `translate': wrong number of arguments (given 2, expected 0..1) (ArgumentError)
0
5

Automated Test Results