FEDORA-2021-4d8b11e08a created by ngompa 6 months ago for Fedora 35
stable

Another attempt at fixing upgrades to F35 to enable WirePlumber...

Logout Required
After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2021-4d8b11e08a

This update has been submitted for testing by ngompa.

6 months ago

This update's test gating status has been changed to 'failed'.

6 months ago

This update's test gating status has been changed to 'waiting'.

6 months ago

This update's test gating status has been changed to 'failed'.

6 months ago

This update's test gating status has been changed to 'passed'.

6 months ago
User Icon imabug provided feedback 6 months ago
karma

This update has been pushed to testing.

6 months ago
User Icon bojan commented & provided feedback 6 months ago
karma

Runs.

This update can be pushed to stable now if the maintainer wishes

6 months ago

This update has been submitted for stable by ngompa.

6 months ago
User Icon fuller commented & provided feedback 6 months ago
karma

not working on KDE

User Icon atim provided feedback 6 months ago
karma
User Icon goeran commented & provided feedback 6 months ago
karma

Wireplumber remains disabled after this upgrade.

BZ#2016253 wireplumber not enabled automatically
User Icon ngompa commented & provided feedback 6 months ago

@fuller, @goeran: Are you upgrading from F34 to F35?

This update has been pushed to stable.

6 months ago
User Icon goeran commented & provided feedback 6 months ago

@ngompa: I updated from F34 to F35 first, and got a broken setup. Then I applied this update which I thought was meant to fix it, but it didn't. As I wrote in the bugzilla I now realise taking care of that case was out of scope.

User Icon fuller commented & provided feedback 6 months ago
karma

@ngompa I updated toF35 beta some time ago and have always had tp restart wireplumber on login

BZ#2016253 wireplumber not enabled automatically
User Icon tseewald commented & provided feedback 6 months ago
karma

Yeah wireplumber is pretty broken on KDE systems, no audio on boot unless I manual start the service.

BZ#2016253 wireplumber not enabled automatically
User Icon goeran commented & provided feedback 6 months ago

@fuller, @tseewald, if you read the bugzilla you'll realise it was never intended to fix systems that were broken before this release, only to prevent the problem on systems upgrading in the future. (No criticism from me for that, I too misunderstood it at first.) To fix your systems, do

systemctl preset --global wireplumber
User Icon tseewald commented & provided feedback 6 months ago

@goeran I had already enabled wireplumber, I applied this update to wireplumber, rebooted, and it had regressed again requiring me to yet again restart it.

Either way wireplumber is not meeting my expectations for audio reliability. It's a regression compared to pipewire-media-session as well as pulseaudio.

User Icon goeran commented & provided feedback 6 months ago

@tseewald how did you enable it? If you do it with the command I showed you, you should not have to do it again after the next login or boot.


Please login to add feedback.

Metadata
Type
bugfix
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
6 months ago
in testing
6 months ago
in stable
6 months ago
BZ#2016253 wireplumber not enabled automatically
-1
0

Automated Test Results