Fix GNOME 40 compatibility, source the unmerged upstream commit directly, require GNOME 40+ (the fix is incompatible with GNOME 3.38 and less).


  • Fix GNOME 40 incompatiblity

Logout Required
After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

This update has been submitted for testing by terrycloth.

9 months ago

This update's test gating status has been changed to 'ignored'.

9 months ago

This update's test gating status has been changed to 'waiting'.

9 months ago

This update has obsoleted gnome-shell-extension-topicons-plus-27-5.fc34, and has inherited its bugs and notes.

9 months ago
User Icon jwrdegoede commented & provided feedback 9 months ago
karma

I can confirm that this fixes the TopIcons extension with GNOME40.

BZ#1936207 gnome-shell-extension-topicons-plus incompatible with GNOME 40
BZ#1938441 F35FailsToInstall: gnome-shell-extension-topicons-plus
BZ#1941009 F34FailsToInstall: gnome-shell-extension-topicons-plus

This update's test gating status has been changed to 'ignored'.

9 months ago

This update has been pushed to testing.

9 months ago

This update can be pushed to stable now if the maintainer wishes

9 months ago
User Icon cairo provided feedback 9 months ago
karma

Please login to add feedback.

Metadata
Type
bugfix
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
3 days
Dates
submitted
9 months ago
in testing
9 months ago
BZ#1936207 gnome-shell-extension-topicons-plus incompatible with GNOME 40
0
1
BZ#1938441 F35FailsToInstall: gnome-shell-extension-topicons-plus
0
1
BZ#1941009 F34FailsToInstall: gnome-shell-extension-topicons-plus
0
1

Automated Test Results