The 5.10.19 stable kernel update contains a number of important fixes across the tree.

Reboot Required
After installing this update it is required that you reboot your system to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2021-79396b21b2

This update has been submitted for testing by jforbes.

a month ago

This update's test gating status has been changed to 'ignored'.

a month ago

This update's test gating status has been changed to 'waiting'.

a month ago

This update's test gating status has been changed to 'ignored'.

a month ago
User Icon markec provided feedback a month ago
karma
User Icon balay provided feedback a month ago
karma
BZ#1925346 Screen glitches after updating to Kernel 5.10.10
User Icon imabug provided feedback a month ago
karma
User Icon bretth commented & provided feedback a month ago
karma

Default and performance tests pass with KVM

User Icon g6avk commented & provided feedback a month ago
karma

Works for me..
The enabled Default and Performance tests pass OK.

This update has been pushed to testing.

a month ago

This update can be pushed to stable now if the maintainer wishes

a month ago
BZ#1925346 Screen glitches after updating to Kernel 5.10.10
User Icon bojan provided feedback a month ago
karma
User Icon plumchii commented & provided feedback a month ago
karma

1

User Icon ersen provided feedback a month ago
karma
User Icon rdieter commented & provided feedback a month ago
karma

Fixes bug #1925346 for me, yay

BZ#1925346 Screen glitches after updating to Kernel 5.10.10
User Icon tseewald provided feedback a month ago
karma
User Icon amandacavalcante commented & provided feedback a month ago
karma

All tests passed Fedora 33 Mate on NITRO AN515-54 V1.30 Intel i5-9300H (8) @4.100GHz GPU: Intel UHD Graphics 630 GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q

User Icon itrymybest80 commented & provided feedback a month ago
karma

Default & performance regression tests PASS, libhugetlbfs & paxtest was skipped. Tested on x86_64, PRIME Z270-A, i5-7600K, 16GB DDR4, AMD RX 580 8GB (MESA 20.3.4-2) & 970 EVO M.2.

User Icon geraldosimiao commented & provided feedback a month ago
karma

Works fine on Acer Aspire V3-571 v: V2.11 CPU: Quad Core Intel Core i7-3632QM GPU: Intel 3rd Gen Core processor Graphics Controller KDE Plasma. No regressions found

User Icon ibims commented & provided feedback a month ago
karma

Looks ok for me. Runs since it was ready in koji. Works on baremetal (non UEFI mode) AMD Ryzen5 3600, Mainboard MSI B450M Mortar Max with prop. nvidia driver from rpmfusion.org (GTX980 card), VirtualBox 6.1.18 from Oracle and Gnome-Desktop (Xorg). Regression test passed (paxtest, selinux-dac-controls and libhugetlbfs skipped).

User Icon jgu commented & provided feedback a month ago
karma

Seems to have fixed all the glitching I was seeing with intel graphics prior to this kernel (bug #1925346).

BZ#1925346 Screen glitches after updating to Kernel 5.10.10
User Icon renault commented & provided feedback a month ago
karma

No regressions found, kernel tests passed on Lenovo E560

User Icon masami commented & provided feedback a month ago
karma

i7-9700K(UHD Graphics 630): kernel regression test passed. Works fine for daily use.

User Icon frantisekz commented & provided feedback a month ago
karma

Works fine on P1 G2

User Icon steevemccauley commented & provided feedback a month ago
karma

So far so good with

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller]) DeviceName: Onboard IGD Subsystem: Dell Device 05a5 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+ Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx- Latency: 0 Interrupt: pin A routed to IRQ 29 Region 0: Memory at f7800000 (64-bit, non-prefetchable) [size=4M] Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M] Region 4: I/O ports at f000 [size=64] Expansion ROM at 000c0000 [virtual] [disabled] [size=128K] Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Address: fee00018 Data: 0000 Capabilities: [d0] Power Management version 2 Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-) Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME- Capabilities: [a4] PCI Advanced Features AFCap: TP+ FLR+ AFCtrl: FLR- AFStatus: TP- Kernel driver in use: i915 Kernel modules: i915

BZ#1925346 Screen glitches after updating to Kernel 5.10.10
User Icon device provided feedback a month ago
karma

This update has been submitted for stable by jforbes.

a month ago
User Icon thebiginfinity commented & provided feedback a month ago
karma

WLAN is completely broken with 5.10.19, booting with 5.10.18 makes it work again. There's no WLAN icon in the top-right GNOME-shell and a manual nmcli con up <SSID> fails too.

$ uname -r
5.10.18-200.fc33.x86_64
$ sudo dmidecode | grep "System Information" --after-context=2
System Information
    Manufacturer: Dell Inc.
    Product Name: Inspiron 3793
$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
$ sudo lspci -vv -s 02:00.0
02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
    Subsystem: Dell Device 1810
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 134
    Region 0: Memory at 91000000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: [40] Power Management version 3
        Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
        Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [50] MSI: Enable+ Count=1/8 Maskable+ 64bit-
        Address: fee003d8  Data: 0000
        Masking: 000000fe  Pending: 00000000
    Capabilities: [70] Express (v2) Endpoint, MSI 00
        DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
            ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 10.000W
        DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
            RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
            MaxPayload 256 bytes, MaxReadReq 512 bytes
        DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr+ TransPend-
        LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <4us, L1 <64us
            ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp+
        LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes, Disabled- CommClk+
            ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
        LnkSta: Speed 2.5GT/s (ok), Width x1 (ok)
            TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        DevCap2: Completion Timeout: Not Supported, TimeoutDis+ NROPrPrP- LTR+
             10BitTagComp- 10BitTagReq- OBFF Via message, ExtFmt- EETLPPrefix-
             EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
             FRS- TPHComp- ExtTPHComp-
             AtomicOpsCap: 32bit- 64bit- 128bitCAS-
        DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR+ OBFF Disabled,
             AtomicOpsCtl: ReqEn-
        LnkCap2: Supported Link Speeds: 2.5GT/s, Crosslink- Retimer- 2Retimers- DRS-
        LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
             Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
             Compliance De-emphasis: -6dB
        LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
             EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
             Retimer- 2Retimers- CrosslinkRes: unsupported
    Capabilities: [100 v2] Advanced Error Reporting
        UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
        UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
        UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
        CESta:  RxErr+ BadTLP- BadDLLP+ Rollover- Timeout- AdvNonFatalErr-
        CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
        AERCap: First Error Pointer: 00, ECRCGenCap- ECRCGenEn- ECRCChkCap- ECRCChkEn-
            MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
        HeaderLog: 00000000 00000000 00000000 00000000
    Capabilities: [148 v1] Virtual Channel
        Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
        Arb:    Fixed- WRR32- WRR64- WRR128-
        Ctrl:   ArbSelect=Fixed
        Status: InProgress-
        VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
            Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
            Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
            Status: NegoPending- InProgress-
    Capabilities: [168 v1] Device Serial Number 00-00-00-00-00-00-00-00
    Capabilities: [178 v1] Latency Tolerance Reporting
        Max snoop latency: 3145728ns
        Max no snoop latency: 3145728ns
    Capabilities: [180 v1] L1 PM Substates
        L1SubCap: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+ L1_PM_Substates+
              PortCommonModeRestoreTime=50us PortTPowerOnTime=10us
        L1SubCtl1: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+
               T_CommonMode=0us LTR1.2_Threshold=98304ns
        L1SubCtl2: T_PwrOn=44us
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
$ lspci -nn -s 02:00.0
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
$ cat /proc/cmdline
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.10.18-200.fc33.x86_64 root=/dev/mapper/fedora_localhost--live-root ro rd.lvm.lv=fedora_localhost-live/root rd.luks.uuid=luks-XXXX rhgb quiet lockdown=confidentiality mitigations=auto,nosmt nosmt=force spec_store_bypass_disable=on spectre_v2=on vsyscall=none slab_nomerge slub_debug=FZ init_on_alloc=1 init_on_free=1 page_alloc.shuffle=1 mem_sleep_default=s2idle
User Icon decathorpe commented & provided feedback a month ago
karma

Works fine. Default and performance regression tests also pass on all my systems:

  • Ryzen 1700X on ASUS PRIME X370-PRO with NVidia GTX 1070 running negativo17 drivers
  • dell XPS 13 9370 (Intel Core i7 8550U / UHD Graphics 620)
  • Jetson Nano B01
  • qemu / KVM (x86_64 on x86_64)

This update has been pushed to stable.

a month ago
User Icon harshmangal commented & provided feedback a month ago
karma

Works fine - HP (8th Gen)

Architecture: x86_64
Model name: Intel(R) Core(TM) i5-8250U CPU @ 1.60GH
Memory: 8 GiB of RAM
Graphics card: Intel UHD Graphics 620

Please login to add feedback.

Metadata
Type
bugfix
Karma
21
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
a month ago
in testing
a month ago
in stable
a month ago
BZ#1925346 Screen glitches after updating to Kernel 5.10.10
0
5

Automated Test Results

Test Cases

0 14 Test Case kernel regression