FEDORA-2021-b70755fdc3 created by wtaymans 2 months ago for Fedora 35
stable

wireplumber 0.4.3

Reboot Required
After installing this update it is required that you reboot your system to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2021-b70755fdc3

This update has been submitted for testing by wtaymans.

2 months ago

This update's test gating status has been changed to 'ignored'.

2 months ago

This update's test gating status has been changed to 'waiting'.

2 months ago

This update's test gating status has been changed to 'ignored'.

2 months ago

ngompa edited this update.

2 months ago

ngompa edited this update.

2 months ago

ngompa edited this update.

2 months ago
User Icon oturpe commented & provided feedback 2 months ago
karma

After installing this update, the Gnome sound settings show no output or input and I have no sound. Reverting back to 0.4.2 with dnf distro-sync wireplumber fixes this.

ngompa edited this update.

2 months ago
User Icon ngompa commented & provided feedback 2 months ago

@oturpe Did you try rebooting the system after installing the update?

User Icon oturpe commented & provided feedback 2 months ago

Yes, but reboot did not help.

User Icon oturpe commented & provided feedback 2 months ago

Unfortunately, I do not have a possibility to dig into logs or such today. So there is some small chance that I did something wrong when I downloaded the rpm from Koji and installed it. Or that there is a conflict because I earlier installed a version I built from upstream master. If nobody else sees the same, then such factors may explain this.

karma
BZ#1998455 [abrt] wireplumber: initial_sync_done(): wireplumber killed by SIGSEGV
BZ#2010683 sound card disappears after relogin
User Icon fmarcos commented & provided feedback 2 months ago
karma

LGTM ;D Recover after suspend is also working now!

BZ#2003403 Changing Gnome system sounds volume doesn't work with WirePlumber
BZ#2010683 sound card disappears after relogin
User Icon oturpe commented & provided feedback 2 months ago
karma

Ok, I looked at the logs. The error was this:

$ journalctl --user --unit wireplumber.service
Oct 08 19:28:14 ottovain wireplumber[3316]: Failed to open module /usr/lib64/wireplumber-0.4/libwireplumber-module-route-settings-api: /usr/lib64/wireplumber-0.4/libwireplumber-module-route-settings-api.so: cannot open shared object file: No such file or directory

That so comes from wireplumber-libs package, which I had forgot to update. After fixing that, everything works well.

BZ#2003403 Changing Gnome system sounds volume doesn't work with WirePlumber

This update has been submitted for stable by bodhi.

2 months ago
User Icon uraeus commented & provided feedback 2 months ago
karma

Just installed this wireplumber test build and it works fine for me. I even tested easyeffects as I saw people reporting issues with it, and it works perfectly for me.

User Icon ngompa provided feedback 2 months ago
karma
BZ#1998455 [abrt] wireplumber: initial_sync_done(): wireplumber killed by SIGSEGV
BZ#2003403 Changing Gnome system sounds volume doesn't work with WirePlumber
BZ#2010683 sound card disappears after relogin

This update has been pushed to stable.

2 months ago
User Icon vchernin commented & provided feedback 2 months ago
karma

Fixes issue where Flatpak apps weren't getting "Manager" permissions. This was important for EasyEffects and Pavucontrol Flatpak. https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/59

User Icon atim provided feedback 2 months ago
karma
User Icon kvolny commented & provided feedback 2 months ago
karma

looks like it fixes bug 2011737 for me ...


Please login to add feedback.

Metadata
Type
bugfix
Karma
10
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
2 months ago
in stable
2 months ago
modified
2 months ago
BZ#1998455 [abrt] wireplumber: initial_sync_done(): wireplumber killed by SIGSEGV
0
2
BZ#2003403 Changing Gnome system sounds volume doesn't work with WirePlumber
0
3
BZ#2010683 sound card disappears after relogin
0
3

Automated Test Results