Improve corner-case situations in %pyproject_buildrequires:

  • Improve handling of > operator, preventing post-release from satisfying most rpm requirements
  • Improve handling of < operator, preventing pre-release from satisfying rpm requirement
  • Improve handling of != operator with prefix matching, preventing pre-release from satisfying rpm requirements

How to install

sudo dnf upgrade --advisory=FEDORA-2021-b877063198

This update has been submitted for testing by churchyard.

2 months ago

This update's test gating status has been changed to 'ignored'.

2 months ago

This update has been pushed to testing.

2 months ago

This update has been submitted for stable by bodhi.

2 months ago

This update has been pushed to stable.

2 months ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-2
Stable by Karma
2
Stable by Time
7 days
Dates
submitted
2 months ago
in testing
2 months ago
in stable
2 months ago
BZ#2014616 Packages that require PyYAML < 6 were satifided with 6.0b1
0
0

Automated Test Results