stable

dleyna-0.8.2-1.fc38, gssdp-1.6.2-1.fc38, & 3 more

FEDORA-2022-05bc988aec created by amigadave a year ago for Fedora 38

Update GUPnP stack to 1.6

  • Merge split dleyna packages into new upstream package

Logout Required
After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2022-05bc988aec

This update's test gating status has been changed to 'waiting'.

a year ago

This update's test gating status has been changed to 'ignored'.

a year ago

This update has been submitted for stable by bodhi

a year ago
User Icon decathorpe commented & provided feedback a year ago
karma

This update bumps sonames of some libraries but didn't include rebuilds of dependent packages, and now anything that depends on gtk4 or gstreamer isn't installable in rawhide ...

User Icon adamwill commented & provided feedback a year ago

yeah, openQA shows a bunch of problems:

 Problem 1: package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgssdp-1.2.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.6.2-1.fc38.x86_64 and gssdp-1.4.0.1-3.fc37.x86_64
  - cannot install both gssdp-1.4.0.1-3.fc37.x86_64 and gssdp-1.6.2-1.fc38.x86_64
  - cannot install the best update candidate for package gupnp-igd-1.2.0-6.fc37.x86_64
  - cannot install the best update candidate for package gssdp-1.4.0.1-3.fc37.x86_64
 Problem 2: package libnice-0.1.19-2.fc37.x86_64 requires libgupnp-igd-1.0.so.4()(64bit), but none of the providers can be installed
  - package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgupnp-1.2.so.1()(64bit), but none of the providers can be installed
  - cannot install both gupnp-1.6.2-1.fc38.x86_64 and gupnp-1.4.3-3.fc37.x86_64
  - cannot install both gupnp-1.4.3-3.fc37.x86_64 and gupnp-1.6.2-1.fc38.x86_64
  - cannot install the best update candidate for package libnice-0.1.19-2.fc37.x86_64
  - cannot install the best update candidate for package gupnp-1.4.3-3.fc37.x86_64
 Problem 3: problem with installed package gupnp-igd-1.2.0-6.fc37.x86_64
  - package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgssdp-1.2.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.6.2-1.fc38.x86_64 and gssdp-1.4.0.1-3.fc37.x86_64
  - package rygel-0.42.0-1.fc38.x86_64 requires libgssdp-1.6.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.4.0.1-3.fc37.x86_64 and gssdp-1.6.2-1.fc38.x86_64
  - cannot install the best update candidate for package rygel-0.40.4-2.fc37.x86_64
 Problem 4: package gstreamer1-plugins-bad-free-1.20.4-2.fc38.x86_64 requires libnice.so.10()(64bit), but none of the providers can be installed
  - package libnice-0.1.19-2.fc37.x86_64 requires libgupnp-igd-1.0.so.4()(64bit), but none of the providers can be installed
  - package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgssdp-1.2.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.6.2-1.fc38.x86_64 and gssdp-1.4.0.1-3.fc37.x86_64
  - package dleyna-server-0.8.2-1.fc38.x86_64 requires libgssdp-1.6.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.4.0.1-3.fc37.x86_64 and gssdp-1.6.2-1.fc38.x86_64
  - cannot install the best update candidate for package gstreamer1-plugins-bad-free-1.20.4-2.fc38.x86_64
  - cannot install the best update candidate for package dleyna-server-0.6.0-14.fc37.x86_64
 Problem 5: problem with installed package libnice-0.1.19-2.fc37.x86_64
  - package libnice-0.1.19-2.fc37.x86_64 requires libgupnp-igd-1.0.so.4()(64bit), but none of the providers can be installed
  - package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgssdp-1.2.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.6.2-1.fc38.x86_64 and gssdp-1.4.0.1-3.fc37.x86_64
  - package dleyna-renderer-0.8.2-1.fc38.x86_64 requires libgssdp-1.6.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.4.0.1-3.fc37.x86_64 and gssdp-1.6.2-1.fc38.x86_64
  - cannot install the best update candidate for package dleyna-renderer-0.6.0-15.fc37.x86_64
 Problem 6: problem with installed package dleyna-renderer-0.6.0-15.fc37.x86_64
  - package dleyna-renderer-0.8.2-1.fc38.x86_64 requires libgssdp-1.6.so.0()(64bit), but none of the providers can be installed
  - package webkitgtk6.0-2.39.2-6.fc38.x86_64 requires libgsttranscoder-1.0.so.0()(64bit), but none of the providers can be installed
  - package gstreamer1-plugins-bad-free-1.20.4-2.fc38.x86_64 requires libnice.so.10()(64bit), but none of the providers can be installed
  - package libnice-0.1.19-2.fc37.x86_64 requires libgupnp-igd-1.0.so.4()(64bit), but none of the providers can be installed
  - package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgssdp-1.2.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.6.2-1.fc38.x86_64 and gssdp-1.4.0.1-3.fc37.x86_64
  - cannot install the best update candidate for package webkit2gtk5.0-2.38.2-1.fc38.x86_64
  - cannot install both gssdp-1.4.0.1-3.fc37.x86_64 and gssdp-1.6.2-1.fc38.x86_64
  - package dleyna-renderer-0.6.0-15.fc37.x86_64 requires libdleyna-core-1.0.so.5()(64bit), but none of the providers can be installed
  - package dleyna-0.8.2-1.fc38.x86_64 obsoletes dleyna-core < 0.8.2-1.fc38 provided by dleyna-core-0.6.0-14.fc37.x86_64
  - cannot install the best update candidate for package dleyna-core-0.6.0-14.fc37.x86_64
 Problem 7: package dleyna-connector-dbus-0.8.2-1.fc38.x86_64 requires dleyna(x86-64) = 0.8.2-1.fc38, but none of the providers can be installed
  - package dleyna-0.8.2-1.fc38.x86_64 requires libgupnp-1.6.so.0()(64bit), but none of the providers can be installed
  - package gupnp-1.6.2-1.fc38.x86_64 requires libgssdp-1.6.so.0()(64bit), but none of the providers can be installed
  - package gupnp-1.6.2-1.fc38.x86_64 requires gssdp(x86-64) >= 1.6.0, but none of the providers can be installed
  - package webkit2gtk4.1-2.39.2-6.fc38.x86_64 requires libgsttranscoder-1.0.so.0()(64bit), but none of the providers can be installed
  - package gstreamer1-plugins-bad-free-1.20.4-2.fc38.x86_64 requires libnice.so.10()(64bit), but none of the providers can be installed
  - package libnice-0.1.19-2.fc37.x86_64 requires libgupnp-igd-1.0.so.4()(64bit), but none of the providers can be installed
  - package gupnp-igd-1.2.0-6.fc37.x86_64 requires libgssdp-1.2.so.0()(64bit), but none of the providers can be installed
  - cannot install both gssdp-1.6.2-1.fc38.x86_64 and gssdp-1.4.0.1-3.fc37.x86_64
  - cannot install the best update candidate for package webkit2gtk4.1-2.38.2-1.fc38.x86_64
  - cannot install both gssdp-1.4.0.1-3.fc37.x86_64 and gssdp-1.6.2-1.fc38.x86_64
  - cannot install the best update candidate for package dleyna-connector-dbus-0.3.0-13.fc37.x86_64
User Icon adamwill commented & provided feedback a year ago

well, I think they all boil down to gupnp-igd in the end.

User Icon adamwill commented & provided feedback a year ago

Looks like https://koji.fedoraproject.org/koji/buildinfo?buildID=2098610 is a rebuild against this update, so hopefully that fixes it.

User Icon amigadave commented & provided feedback a year ago

Sorry, I had gupnp-igd ready to go, but it wasn't in the side tag. libnice also needed to be rebuilt, but hopefully this is done now.


Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
0 days
Dates
submitted
a year ago
in testing
a year ago
in stable
a year ago
BZ#2078238 gssdp-1.6.2 is available
0
0
BZ#2134653 Please update to 0.7.x or 0.8.0
0
0
BZ#2144849 Review Request: dleyna - Services and D-Bus APIs for UPnP access
0
0

Automated Test Results