stable

cockpit-275.1-1.fc35

FEDORA-2022-3527307c7f created by packit 4 months ago for Fedora 35
  • login: Use valid selectors when testing for :is() / :where() support (#2136876)

Logout Required
After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2022-3527307c7f

This update has been submitted for testing by packit.

4 months ago

This update's test gating status has been changed to 'ignored'.

4 months ago

martinpitt edited this update.

4 months ago

martinpitt edited this update.

4 months ago

This update has been pushed to testing.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago

This update's test gating status has been changed to 'passed'.

4 months ago
User Icon adamwill commented & provided feedback 4 months ago

This should have been edited into the Firefox update, not submitted separately :( Now we cannot push the Firefox update stable until this goes stable.

User Icon martinpitt commented & provided feedback 4 months ago

@adamwill: I suppose we could still do that? I can't edit the firefox bodhi update, but I suppose @stransky could add this cockpit build? I'll also validate that it fixes the bug, then we'll have at least one karma.

User Icon martinpitt commented & provided feedback 4 months ago
karma

I started a standard F35 cloud VM, installed the currently released cockpit 275-1. I get the "too old" login page with current Firefox 106. I then updated to 275.1-1.fc35 (with the above "how to install" command), refreshed the browser, and can log in normally again. All the pages work. This was a cherry-picked fix (essentially two characters) which only affected the login page, so I claim with high confidence that this works.

BZ#2136876 Firefox 106 breaks Cockpit on Fedora 35
User Icon martinpitt commented & provided feedback 4 months ago

Integration tests and OpenQA tests also succeeded, in particular the failed OpenQA test that broke the firefox bodhi update.

User Icon stransky commented & provided feedback 4 months ago

Sure, let's add it to Firefox. We really miss update dependencies here.

User Icon stransky commented & provided feedback 4 months ago

I'll add it when this update is deleted.

This update has been unpushed.

This update has been submitted for testing by martinpitt.

4 months ago

This update's test gating status has been changed to 'ignored'.

4 months ago
User Icon martinpitt commented & provided feedback 4 months ago

Meh, I can't actually delete this (probably because I didn't create it?), or remove the build. Unpushing didn't help either. I'll just ask another colleague today to check it, then it has enough Karma to land today, and then OpenQA tests can re-run in Firefox.

martinpitt edited this update.

4 months ago

This update has been pushed to testing.

4 months ago

This update has been submitted for stable by bodhi.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago

This update's test gating status has been changed to 'passed'.

4 months ago

This update has been pushed to stable.

4 months ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
urgent
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
1
Stable by Time
7 days
Dates
submitted
4 months ago
in testing
4 months ago
in stable
4 months ago
modified
4 months ago
BZ#2136876 Firefox 106 breaks Cockpit on Fedora 35
0
0

Automated Test Results

passed

Test Cases

0 0 Test Case realmd join cockpit