stable

vim-8.2.4068-1.fc34

FEDORA-2022-48b86d586f created by zdohnal 2 years ago for Fedora 34

Security fix for CVE-2021-46059, CVE-2022-0158, CVE-2022-0156


Security fix for CVE-2021-4136, CVE-2021-4166, CVE-2021-4173, CVE-2021-4186, CVE-2021-4192, CVE-2021-4193

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2022-48b86d586f

This update has been submitted for testing by zdohnal.

2 years ago

This update's test gating status has been changed to 'waiting'.

2 years ago

This update has obsoleted vim-8.2.4006-1.fc34, and has inherited its bugs and notes.

2 years ago

This update's test gating status has been changed to 'failed'.

2 years ago

This update has been pushed to testing.

2 years ago

This update's test gating status has been changed to 'passed'.

2 years ago
User Icon suve provided feedback 2 years ago
karma
User Icon ersen provided feedback 2 years ago
karma

This update can be pushed to stable now if the maintainer wishes

2 years ago
User Icon vtrefny provided feedback 2 years ago
karma

This update has been submitted for stable by bodhi.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
security
Severity
medium
Karma
3
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
BZ#2034720 CVE-2021-4136 vim: heap-based buffer overflow in eval_lambda() in src/eval.c
0
0
BZ#2034721 CVE-2021-4136 vim: heap-based buffer overflow in eval_lambda() in src/eval.c [fedora-all]
0
0
BZ#2035928 CVE-2021-4166 vim: out-of-bounds read in do_arg_all() in src/arglist.c
0
0
BZ#2035929 CVE-2021-4166 vim: out-of-bounds read in do_arg_all() in src/arglist.c [fedora-all]
0
0
BZ#2035930 CVE-2021-4173 vim: use-after-free with nested :def function
0
0
BZ#2035931 CVE-2021-4173 vim: use-after-free with nested :def function [fedora-all]
0
0
BZ#2036129 CVE-2021-4187 vim: use-after-free vulnerability
0
0
BZ#2036130 CVE-2021-4187 vim: use-after-free vulnerability [fedora-all]
0
0
BZ#2039843 CVE-2022-0156 vim: use-after-free while treating allocated lines in user functions
0
0
BZ#2039845 CVE-2022-0156 vim: vulnerable to Use After Free [fedora-all]
0
0
BZ#2039846 CVE-2022-0158 vim: heap-based read buffer overflow in compile_get_env()
0
0
BZ#2039848 CVE-2022-0158 vim: vulnerable to Heap-based Buffer Overflow [fedora-all]
0
0
BZ#2039850 CVE-2021-46059 vim: NULL pointer dereference vulnerability via the vim_regexec_multi function at regexp.c
0
0
BZ#2039851 CVE-2021-46059 vim: NULL pointer dereference vulnerability via the vim_regexec_multi function at regexp.c may lead to DoS [fedora-all]
0
0

Automated Test Results