stable

akonadi-calendar-tools-22.04.1-1.fc36, akonadiconsole-22.04.1-1.fc36, & 210 more

FEDORA-2022-5bcd51e205 created by justinz 2 years ago for Fedora 36

KDE Gear 22.04.1 Update.

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2022-5bcd51e205

This update's test gating status has been changed to 'waiting'.

2 years ago

This update's test gating status has been changed to 'ignored'.

2 years ago

This update has been submitted for testing by bodhi.

2 years ago

After reboot OSD (volume, brightness) moved from center to top left corner. Fix for diacritics in Okular forms and notes requires poppler 22.05 https://gitlab.freedesktop.org/poppler/poppler/-/issues/362#note_1372657

This update's test gating status has been changed to 'waiting'.

2 years ago

This update's test gating status has been changed to 'ignored'.

2 years ago
User Icon imabug provided feedback 2 years ago
karma

This update has been pushed to testing.

2 years ago

@ozeszty i randomly get the volume OSD in top-left corner even without this. Must be kf5.93 or plasma-5.24.5

User Icon thesourcehim commented & provided feedback 2 years ago
karma

Transaction check error: file /usr/share/config.kcfg/specialmailcollections.kcfg from package kf5-akonadi-mime-22.04.1-1.fc36.x86_64 conflicts with file from package kdepimlibs-4.14.10-39.fc36.x86_64

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago
User Icon ozeszty commented & provided feedback 2 years ago
karma

@aleasto it fixed itself after screen-locking ¯_(ツ)_/¯ Apart from that no regressions spotted (I don't have kdepimlibs installed). For poppler update, I'm afraid, we'll have to wait for fc37.

User Icon aleasto provided feedback 2 years ago
karma

This update can be pushed to stable now if the maintainer wishes

2 years ago
karma
User Icon gtwilliams commented & provided feedback 2 years ago
karma

I get this when installing:

Error: Transaction test error: file /usr/share/config.kcfg/specialmailcollections.kcfg from install of kf5-akonadi-mime-22.04.1-1.fc36.x86_64 conflicts with file from package kdepimlibs-4.14.10-39.fc36.x86_64

I was able to safely remove kdepimlibs and its dependencies (which are only libs), I guess those libs are obsolete and not used by kde apps. However, I think this update should properly obsolete kdepimlibs then.

$ dnf provides /usr/share/config.kcfg/specialmailcollections.kcfg
kf5-akonadi-mime-21.12.2-1.fc36.x86_64 : The Akonadi Mime Library
Repo        : fedora
Matched from:
Filename    : /usr/share/config.kcfg/specialmailcollections.kcfg

That's not a new file in 22.04

User Icon gbcox commented & provided feedback 2 years ago
karma

Error: Transaction test error: file /usr/share/config.kcfg/specialmailcollections.kcfg from install of kf5-akonadi-mime-22.04.1-1.fc36.x86_64 conflicts with file from package kdepimlibs-4.14.10-39.fc36.x86_64

Agree with @thesourcehim statement: "I was able to safely remove kdepimlibs and its dependencies (which are only libs), I guess those libs are obsolete and not used by kde apps. However, I think this update should properly obsolete kdepimlibs then."

@ozeszty it's caused by the kf5 update from some weeks ago, and the issue has been fixed by the KDE devs, so it will be gone with the next KDE Frameworks update :) (also getting this issue, and I haven't installed this testing update. Here is the fix commit: https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/509)

rdieter edited this update.

New build(s):

  • kdepimlibs-4.14.10-40.fc36
  • kf5-akonadi-mime-22.04.1-2.fc36

Removed build(s):

  • kf5-akonadi-mime-22.04.1-1.fc36

Karma has been reset.

2 years ago

This update has been submitted for testing by rdieter.

2 years ago
User Icon imabug provided feedback 2 years ago
karma
BZ#2088779 kdepimlibs has a filename conflict with kf5-akonadi-mime

This update has been pushed to testing.

2 years ago
User Icon marcdeop commented & provided feedback 2 years ago
karma

All good here

BZ#2088779 kdepimlibs has a filename conflict with kf5-akonadi-mime

This update can be pushed to stable now if the maintainer wishes

2 years ago
User Icon fuller commented & provided feedback 2 years ago
karma

working

User Icon nerijus commented & provided feedback 2 years ago
karma

Problem 4: problem with installed package calligra-okular-odtgenerator-3.2.1-16.fc36.x86_64 - package calligra-okular-odtgenerator-3.2.1-16.fc36.x86_64 requires libOkular5Core.so.9()(64bit), but none of the providers can be installed - cannot install both okular-libs-22.04.1-1.fc36.x86_64 and okular-libs-21.12.2-1.fc36.x86_64 - package okular-part-22.04.1-1.fc36.x86_64 requires okular-libs(x86-64) = 22.04.1-1.fc36, but none of the providers can be installed - package okular-part-22.04.1-1.fc36.x86_64 requires libOkular5Core.so.10()(64bit), but none of the providers can be installed - package okular-22.04.1-1.fc36.x86_64 requires okular-part(x86-64) = 22.04.1-1.fc36, but none of the providers can be installed - cannot install the best update candidate for package okular-21.12.2-1.fc36.x86_64

This update has been unpushed.

justinz edited this update.

New build(s):

  • calligra-3.2.1-17.fc36

Karma has been reset.

2 years ago

This update has been submitted for testing by justinz.

2 years ago
User Icon justinz commented & provided feedback 2 years ago

If everyone can please test again, thank you for all of your patience.

User Icon geraldosimiao commented & provided feedback 2 years ago
karma

It seems all is working fine. Tested the Calligra install too.

BZ#2088779 kdepimlibs has a filename conflict with kf5-akonadi-mime
User Icon justinz commented & provided feedback 2 years ago

@ngompa @thunderbirdtr would you like to help test as well?

This update has been pushed to testing.

2 years ago
User Icon t3rm1n4l commented & provided feedback 2 years ago
karma

wfm

This update can be pushed to stable now if the maintainer wishes

2 years ago
User Icon aleasto provided feedback 2 years ago
karma
BZ#2088779 kdepimlibs has a filename conflict with kf5-akonadi-mime
User Icon ozeszty commented & provided feedback 2 years ago
karma

Calligra installs and runs fine.

This update has been submitted for stable by justinz.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
medium
Karma
4
Signed
Content Type
RPM
Test Gating
Builds
212
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#2088779 kdepimlibs has a filename conflict with kf5-akonadi-mime
0
2

Automated Test Results