obsolete

krb5-1.20.1-1.fc38

FEDORA-2022-8050ab2c35 created by jrische 2 months ago for Fedora 38

Automatic update for krb5-1.20.1-1.fc38.

Changelog
* Wed Nov 23 2022 Julien Rische <jrische@redhat.com> - 1.20.1-1
- New upstream version (1.20.1)
- Resolves: rhbz#2124463
- Restore "supportedCMSTypes" attribute in PKINIT preauth requests
- Set SHA-512 or SHA-256 with RSA as preferred CMS signature algorithms
- Resolves: rhbz#2114766
- Update error checking for OpenSSL CMS_verify
- Resolves: rhbz#2119704
- Remove invalid password expiry warning
- Resolves: rhbz#2129113
* Wed Nov  9 2022 Julien Rische <jrische@redhat.com> - 1.19.2-13
- Fix integer overflows in PAC parsing (CVE-2022-42898)
- Resolves: rhbz#2143011
* Tue Aug  2 2022 Andreas Schneider <asn@redhat.com> - 1.19.2-12
- Use baserelease to set the release number
- Do not define netlib, but use autoconf detection for res_* functions
- Add missing BR for resolv_wrapper to run t_discover_uri.py

This update was automatically created

2 months ago

This update's test gating status has been changed to 'waiting'.

2 months ago
User Icon adamwill commented & provided feedback 2 months ago
karma

this wasn't meant to be on mainline yet, per @ab .

User Icon kalev provided feedback 2 months ago
karma
karma

This update has been obsoleted.

2 months ago
karma
User Icon abbra commented & provided feedback 2 months ago

A proper update is FEDORA-2022-311128dd7e which includes krb5, samba, and freeipa.

This update's test gating status has been changed to 'failed'.

2 months ago

Please login to add feedback.

Metadata
Type
security
Karma
-4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
0 days
Dates
submitted
2 months ago
in testing
2 months ago
BZ#2114766 MIT krb5 client does not set "supportedCMSTypes" for pkinit and therefore Heimdal KDC uses SHA1 for CMS signature [fedora-rawhide]
0
0
BZ#2119704 Mishandling of CMS_verify() errors in PKINIT plugin [fedora-all]
0
0
BZ#2124463 Rebase krb5 to latest upstream release 1.20 [fedora-rawhide]
0
0
BZ#2129113 Incorrect password expiration handling [fedora-rawhide]
0
0
BZ#2143011 CVE-2022-42898 krb5: integer overflow vulnerabilities in PAC parsing [fedora-37]
0
0

Automated Test Results

failed