stable

fedpkg-1.43-2.fc35 and rpkg-1.65-2.fc35

FEDORA-2022-861b7a4329 created by onosek 5 months ago for Fedora 35

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2022-861b7a4329

This update has been submitted for testing by onosek.

5 months ago

This update's test gating status has been changed to 'ignored'.

5 months ago

This update has been pushed to testing.

5 months ago

onosek edited this update.

New build(s):

  • rpkg-1.65-2.fc35

Removed build(s):

  • rpkg-1.65-1.fc35

Karma has been reset.

5 months ago

This update has been submitted for testing by onosek.

5 months ago

This update has been pushed to testing.

5 months ago
User Icon churchyard commented & provided feedback 5 months ago
karma

It is possible to update rpkg only and that breaks fedpkg:

$ fedpkg build --nowait --fail-fast 
rpm: --define '_sourcedir /home/churchyard/rpmbuild/fedora-scm/python3-docs': unknown option

Updating fedpkg as well fixes the issue. Please, version the dependency between the two packages.

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

5 months ago

onosek edited this update.

New build(s):

  • fedpkg-1.43-2.fc35

Removed build(s):

  • fedpkg-1.43-1.fc35

Karma has been reset.

5 months ago

This update has been submitted for testing by onosek.

5 months ago

@churchyard: I am sorry, I thought that with the change of the bodhi update the old rpkg won't be accessible, but probably I forgot the packages, that were already installed. I have updated the fedpkg's dependency.

I am not sure that helps. A change in fedpkg won't make it impossible to update rpkg only. I am not sure how severe is this is, probably not much :/

This update has been pushed to testing.

5 months ago

centpkg users also need FEDORA-2022-113a390dd5

This update can be pushed to stable now if the maintainer wishes

5 months ago

BTW centpkg should go first to stable because centpkg, should as fedpkg, requires rpkg-common and rpkg-common doesn't requires updates of centpkg

BTW centpkg should go first to stable because centpkg, should as fedpkg, requires rpkg-common >= 1.65 and rpkg-common doesn't requires updates of centpkg

sgallagh edited this update.

5 months ago

This update has been submitted for stable by churchyard.

5 months ago
User Icon msrb commented & provided feedback 5 months ago

New centpkg is broken as it needs the new rpkg. But the problem will be fixed once this update reaches stable: https://issues.redhat.com/browse/CS-1230

This update has been pushed to stable.

5 months ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
medium
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
5 months ago
in testing
5 months ago
in stable
5 months ago
modified
5 months ago
BZ#2127750 F35FailsToInstall: centpkg
0
0

Automated Test Results

ignored

Test Cases

0 0 Test Case build from distgit with mock
0 0 Test Case clone distgit repository
0 0 Test Case download upstream sources
0 0 Test Case scratch build from distgit