stable
FEDORA-2022-8ca0f56650 created by dsommers 2 months ago for Fedora 36

This update adds additional upstream changes to better handle deprecated ciphers. BF-CBC is now also deprecated completely in server configurations and it will no longer attempt to negotiate BF-CBC with clients.

These changes are a result of OpenSSL 3.0 being far more stricter on deprecated and weak ciphers than OpenSSL 1.1 and older.

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2022-8ca0f56650

This update has been submitted for testing by dsommers.

2 months ago

This update's test gating status has been changed to 'ignored'.

2 months ago
User Icon lucag73 provided feedback 2 months ago
karma
BZ#2092800 After upgrade openvpn from 2.5.6-1.fc37 to 2.5.7-1.fc37 version NM cant connect to working network.
User Icon dwrobel commented & provided feedback 2 months ago
karma

openvpn-server works again

BZ#2093069 openvpn 2.5.7 server won't start due to BF-CBC cipher option removed, but still referenced in systemd service

This update has been pushed to testing.

2 months ago

This update can be pushed to stable now if the maintainer wishes

2 months ago
User Icon mhjacks commented & provided feedback 2 months ago
karma

Confirmed to work with both client and server. The server no longer needs "legacy providers default" to start and I see BF-CBC is no longer included in the default data-ciphers option passed on the server command line.

BZ#2092800 After upgrade openvpn from 2.5.6-1.fc37 to 2.5.7-1.fc37 version NM cant connect to working network.
BZ#2093069 openvpn 2.5.7 server won't start due to BF-CBC cipher option removed, but still referenced in systemd service
User Icon dirkk commented & provided feedback 2 months ago
karma

Works for me on fc36. (2.5.7-1 did not.)

BZ#2092800 After upgrade openvpn from 2.5.6-1.fc37 to 2.5.7-1.fc37 version NM cant connect to working network.

This update has been submitted for stable by bodhi.

2 months ago

This update has been pushed to stable.

2 months ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
high
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
4
Stable by Time
14 days
Dates
submitted
2 months ago
in testing
2 months ago
in stable
2 months ago
BZ#2092800 After upgrade openvpn from 2.5.6-1.fc37 to 2.5.7-1.fc37 version NM cant connect to working network.
0
3
BZ#2093069 openvpn 2.5.7 server won't start due to BF-CBC cipher option removed, but still referenced in systemd service
0
2

Automated Test Results