FEDORA-2022-8df66cdbef created by zdohnal 2 weeks ago for Fedora 34
stable

patchlevel 4927

Security fixes for CVE-2022-1616, CVE-2022-1619, CVE-2022-1619, CVE-2022-1621, CVE-2022-1629

How to install

sudo dnf upgrade --advisory=FEDORA-2022-8df66cdbef

This update has been submitted for testing by zdohnal.

2 weeks ago

This update's test gating status has been changed to 'waiting'.

2 weeks ago

This update's test gating status has been changed to 'failed'.

2 weeks ago

This update has been pushed to testing.

2 weeks ago

This update's test gating status has been changed to 'passed'.

2 weeks ago
User Icon nixuser commented & provided feedback 2 weeks ago
karma

This is working for me OK in a Fedora 34 VM.

zdohnal edited this update.

2 weeks ago

zdohnal edited this update.

2 weeks ago

zdohnal edited this update.

2 weeks ago
karma

This update can be pushed to stable now if the maintainer wishes

a week ago

This update has been submitted for stable by zdohnal.

a week ago

This update has been pushed to stable.

a week ago

Please login to add feedback.

Metadata
Type
security
Severity
medium
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
2 weeks ago
in testing
2 weeks ago
in stable
a week ago
modified
2 weeks ago
BZ#2083017 CVE-2022-1616 vim: heap-buffer-overflow in append_command of src/ex_docmd.c
0
0
BZ#2083026 CVE-2022-1619 vim: heap-buffer-overflow in cmdline_erase_chars of ex_getln.c
0
0
BZ#2083029 CVE-2022-1620 vim: NULL Pointer Dereference in vim_regexec_string() of regexp.c
0
0
BZ#2083470 CVE-2022-1619 vim: heap-buffer-overflow in cmdline_erase_chars of ex_getln.c [fedora-all]
0
0
BZ#2083471 CVE-2022-1620 vim: NULL Pointer Dereference in vim_regexec_string() of regexp.c [fedora-all]
0
0
BZ#2083472 CVE-2022-1616 vim: heap-buffer-overflow in append_command of src/ex_docmd.c [fedora-all]
0
0
BZ#2083924 CVE-2022-1621 vim: heap buffer overflow
0
0
BZ#2083927 CVE-2022-1621 vim: heap buffer overflow [fedora-34]
0
0
BZ#2083931 CVE-2022-1629 vim: buffer over-read
0
0
BZ#2083932 CVE-2022-1629 vim: buffer over-read [fedora-34]
0
0

Automated Test Results