obsolete

FEDORA-2022-90ae058633 created by zdohnal 6 months ago for Fedora 35

Security fixes for CVE-2022-0213, CVE-2022-0261

This update has been submitted for testing by zdohnal.

6 months ago

This update's test gating status has been changed to 'waiting'.

6 months ago
User Icon imabug provided feedback 6 months ago
karma

This update's test gating status has been changed to 'failed'.

6 months ago

This update has been pushed to testing.

6 months ago

This update's test gating status has been changed to 'passed'.

6 months ago
User Icon bojan commented & provided feedback 6 months ago
karma

Works.

This update can be pushed to stable now if the maintainer wishes

6 months ago
karma

This update has been submitted for stable by bodhi.

6 months ago

zdohnal edited this update.

6 months ago
User Icon andilinux commented & provided feedback 6 months ago
karma

works for me

User Icon besser82 commented & provided feedback 6 months ago
karma

Works great! LGTM! =)

User Icon zdohnal commented & provided feedback 6 months ago

Fixes CVE-2022-0128, CVE-2022-0261 and CVE-2022-0318 as well - cannot add new bugs because the update is locked.

User Icon nixuser commented & provided feedback 6 months ago
karma

vim and gvim both seem to be working OK here.

User Icon ciupicri commented & provided feedback 6 months ago
karma

works fine

User Icon ersen provided feedback 6 months ago
karma

FEDORA-2022-90ae058633 ejected from the push because "Cannot find relevant tag for vim-8.2.4198-1.fc35. None of ['f35-updates', 'f35-updates-pending'] are in ['epel9-next-testing', 'epel7-testing', 'dist-5E-epel-testing', 'f27-modular-updates-testing', 'f34-container-updates-testing', 'eln-updates-testing', 'f30-modular-updates-testing', 'f28-modular-updates-testing', 'f28-container-updates-testing', 'f30-container-updates-testing', 'epel8-testing', 'f30-flatpak-updates-testing', 'f35-container-updates-testing', 'f32-modular-updates-testing', 'f29-modular-updates-testing', 'f29-container-updates-testing', 'f29-flatpak-updates-testing', 'f22-updates-testing', 'f21-updates-testing', 'f25-updates-testing', 'f24-updates-testing', 'f23-updates-testing', 'f26-updates-testing', 'f31-modular-updates-testing', 'dist-6E-epel-testing', 'f32-flatpak-updates-testing', 'f35-flatpak-updates-testing', 'f27-updates-testing', 'f28-updates-testing', 'f30-updates-testing', 'f29-updates-testing', 'epel8-modular-updates-testing', 'f32-updates-testing', 'epel9-testing', 'f31-updates-testing', 'f31-container-updates-testing', 'f31-flatpak-updates-testing', 'f34-updates-testing', 'f34-modular-updates-testing', 'f34-flatpak-updates-testing', 'f36-container-updates-testing', 'f32-container-updates-testing', 'epel8-next-testing', 'f35-updates-testing', 'f35-modular-updates-testing', 'f33-updates-testing', 'f36-updates-testing', 'f33-modular-updates-testing', 'f33-container-updates-testing', 'f33-flatpak-updates-testing']."

6 months ago
karma

This update has been submitted for stable by bodhi.

6 months ago

FEDORA-2022-90ae058633 ejected from the push because "Cannot find relevant tag for vim-8.2.4198-1.fc35. None of ['coreos-pool', 'f35-updates', 'f35-updates-pending'] are in ['epel9-next-testing', 'epel7-testing', 'dist-5E-epel-testing', 'f27-modular-updates-testing', 'f34-container-updates-testing', 'eln-updates-testing', 'f30-modular-updates-testing', 'f28-modular-updates-testing', 'f28-container-updates-testing', 'f30-container-updates-testing', 'epel8-testing', 'f30-flatpak-updates-testing', 'f35-container-updates-testing', 'f32-modular-updates-testing', 'f29-modular-updates-testing', 'f29-container-updates-testing', 'f29-flatpak-updates-testing', 'f22-updates-testing', 'f21-updates-testing', 'f25-updates-testing', 'f24-updates-testing', 'f23-updates-testing', 'f26-updates-testing', 'f31-modular-updates-testing', 'dist-6E-epel-testing', 'f32-flatpak-updates-testing', 'f35-flatpak-updates-testing', 'f27-updates-testing', 'f28-updates-testing', 'f30-updates-testing', 'f29-updates-testing', 'epel8-modular-updates-testing', 'f32-updates-testing', 'epel9-testing', 'f31-updates-testing', 'f31-container-updates-testing', 'f31-flatpak-updates-testing', 'f34-updates-testing', 'f34-modular-updates-testing', 'f34-flatpak-updates-testing', 'f36-container-updates-testing', 'f32-container-updates-testing', 'epel8-next-testing', 'f35-updates-testing', 'f35-modular-updates-testing', 'f33-updates-testing', 'f36-updates-testing', 'f33-modular-updates-testing', 'f33-container-updates-testing', 'f33-flatpak-updates-testing']."

6 months ago

This update has been obsoleted by vim-8.2.4232-1.fc35.

6 months ago

Please login to add feedback.

Metadata
Type
security
Severity
low
Karma
9
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
6 months ago
in testing
6 months ago
modified
6 months ago
BZ#2043779 CVE-2022-0213 vim: vim is vulnerable to out of bounds read
0
0
BZ#2044142 CVE-2022-0213 vim: vim is vulnerable to out of bounds read [fedora-all]
0
0
BZ#2044607 CVE-2022-0261 vim: Heap-based Buffer Overflow in block_insert() in src/ops.c
0
0
BZ#2044608 CVE-2022-0261 vim: Heap-based Buffer Overflow in block_insert() in src/ops.c [fedora-all]
0
0

Automated Test Results