The 5.15.15 stable kernel update contains a number of important fixes across the tree.

Reboot Required
After installing this update it is required that you reboot your system to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2022-a23dd56848

This update has been submitted for testing by jforbes.

4 months ago

This update's test gating status has been changed to 'waiting'.

4 months ago
User Icon markec provided feedback 4 months ago
karma
User Icon ibims commented & provided feedback 4 months ago
karma

Looks ok for me. Works on baremetal (non UEFI mode) AMD Ryzen5 3600, Mainboard MSI B450M Mortar Max with prop. nvidia driver (495.46) from rpmfusion.org (GTX980 card). Works with Gnome-Desktop (Xorg). Regression test passed.

User Icon nivag commented & provided feedback 4 months ago
karma

Works for me: all using the Mate Desktop Environment.

sirius: desktop 16GB Intel i7-3770 CPU desktop (SSD + 5 hard drives in RAID-6) \ real:10m12.169s user:4m38.013s sys:4m59.104

sedna: laptop 8GB Intel i5-2520M CPU Lenovo T420 (SSD only) real:14m20.262s user;6m42.051s sys:5m31.303s

mercury: laptop 32GB AMD Ryzen 7 5700U with Radeon 5500 Graphics (SSD only) rea1:9m11.816s user:3m44.511s sys:4m33.077s

*** I’m intensely curious as to the reason for why sedna seems to randomly fluctuate between short (under 11 minutes) & extremely long (over 100 minutes) elapsed times for the performance test!

User Icon bretth commented & provided feedback 4 months ago
karma

Default & performance tests pass (KVM)

User Icon nixuser commented & provided feedback 4 months ago
karma

Looks OK here on 3 systems.

Test set:

ASUS G750JS 1 x Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06) NVIDIA Corporation GK104M [GeForce GTX 870M] (rev a1)

Intel NUC i7 NUC11PAH 1 x 11th Gen Intel(R) Core(TM) i7-1165G7 @ 2.80GHz Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] (rev 01)

Dell Optiplex 3040 1 x Intel(R) Core(TM) i3-6100T CPU @ 3.20GHz Intel Corporation HD Graphics 530 (rev 06)

User Icon g6avk commented & provided feedback 4 months ago
karma

Works for me, it's been up for a couple of hours now with no issues noticed.
The regression tests pass OK. AMD 965, x86_64 work station, SSD's > RAID1. Plasma DE from Zawertun's COPR. Running Xorg, nVidia GT1030 card using nVidia RPM's from RPMFusion (495.46)

User Icon gre0 commented & provided feedback 4 months ago
karma

Bluetooth is working again with Intel(R) Dual Band Wireless AC 3165 (ID 8087:0a2a). Thanks :)

BZ#2027071 Rebooting kernel 5.15.4 fails to initialize certain Intel bluetooth devices

This update's test gating status has been changed to 'passed'.

4 months ago
karma
User Icon imabug provided feedback 4 months ago
karma

This update has been pushed to testing.

4 months ago

This update can be pushed to stable now if the maintainer wishes

4 months ago
User Icon amdgpu provided feedback 4 months ago
karma
User Icon tiberias_ provided feedback 4 months ago
karma
User Icon bojan commented & provided feedback 4 months ago
karma

Works.

User Icon rai510 provided feedback 4 months ago
karma
User Icon pawef9 commented & provided feedback 4 months ago
karma

It works

User Icon aalam commented & provided feedback 4 months ago
karma

kernel regression passed x570 and Ryzen 5700X Thinkpad x13 with AMD

User Icon wayne6001 commented & provided feedback 4 months ago
karma

NUC6i5syk, Fedora Linux 35, Intel® Core™ i5-6260U CPU @ 1.80GHz × 4, 15.5 GiB, 512GB, passed both tests.

User Icon nedal provided feedback 4 months ago
karma
User Icon geraldosimiao commented & provided feedback 4 months ago
karma

Works on Acer Aspire Intel® Core™ i7-3632QM CPU @ 2.20GHz Memory: 15.4 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4000 no regressions.

User Icon firemanxbr commented & provided feedback 4 months ago

I'm still having issues with my wifi chip. My chip is Intel(R) Wi-Fi 6 AX201 160MHz. Previous kernels of Fedora 35 are with the same issue.

What's the issue? Wifi is detected but the performance is so poor. Fedora didn't detect the correct wifi 6 chip and didn't use properly the frequencies by the wifi 6 router. My wifi router is Ubiquiti AmpliFi Alien Router that has support for wifi 6. When I use Windows my wifi works in higher performance that doesn't generate any lag or latency for common use.

lshw -C network

-network
description: Wireless interface product: Tiger Lake PCH CNVi WiFi vendor: Intel Corporation physical id: 14.3 bus info: pci@0000:00:14.3 logical name: wlp0s20f3 version: 11 serial: 4c:77:cb:0b:ac:ca width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=iwlwifi driverversion=5.15.15-200.fc35.x86_64 firmware=63.c04f3485.0 QuZ-a0-hr-b0-63.u ip=192.168.151.234 latency=0 link=yes multicast=yes wireless=IEEE 802.11 resources: iomemory:610-60f irq:16 memory:616529c000-616529ffff
-network description: Ethernet interface physical id: 4 bus info: usb@2:4.1 logical name: enp0s13f0u4u1i5 serial: 9c:eb:e8:62:51:d9 capabilities: ethernet physical configuration: autonegotiation=off broadcast=yes driver=cdc_ncm driverversion=5.15.15-200.fc35.x86_64 duplex=half firmware=CDC NCM link=no multicast=yes port=twisted pair

lsmod | grep wifi

iwlwifi 372736 1 iwlmvm cfg80211 1015808 4 wl,iwlmvm,iwlwifi,mac80211

dmesg | grep wifi

[ 4.995714] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002) [ 5.001945] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-66.ucode failed with error -2 [ 5.001972] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-65.ucode failed with error -2 [ 5.001995] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-64.ucode failed with error -2 [ 5.050916] iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver [ 5.050932] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37 [ 5.051186] iwlwifi 0000:00:14.3: loaded firmware version 63.c04f3485.0 QuZ-a0-hr-b0-63.ucode op_mode iwlmvm [ 5.241536] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x354 [ 5.363348] iwlwifi 0000:00:14.3: Detected RF HR B5, rfid=0x10a100 [ 5.429996] iwlwifi 0000:00:14.3: base HW address: 4c:77:cb:0b:ac:ca [ 5.447832] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0 [ 10.942032] iwlwifi 0000:00:14.3: Got NSS = 8 - trimming to 2 [ 2846.343381] iwlwifi 0000:00:14.3: Got NSS = 8 - trimming to 2 [ 7160.163670] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.

This update has been submitted for stable by jforbes.

4 months ago
User Icon besser82 commented & provided feedback 4 months ago
karma

Works great on Lenovo T480! LGTM! =)

User Icon atim provided feedback 4 months ago
karma
User Icon mrunge commented & provided feedback 4 months ago
karma

no issues noted, works for me.

This update has been pushed to stable.

4 months ago

Please login to add feedback.

Metadata
Type
security
Severity
medium
Karma
21
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
4 months ago
in testing
4 months ago
in stable
4 months ago
BZ#2004949 CVE-2021-3773 kernel: lack of port sanity checking in natd and netfilter leads to exploit of OpenVPN clients
0
0
BZ#2006005 CVE-2021-3773 kernel: lack of port sanity checking in natd and netfilter leads to exploit of OpenVPN clients [fedora-all]
0
0
BZ#2027071 Rebooting kernel 5.15.4 fails to initialize certain Intel bluetooth devices
0
1

Automated Test Results

Test Cases

0 13 Test Case kernel regression