LLVM14 Update


Fixes a bug in annocheck that falsely reports that AArch64 binaries do not have a .note.gnu.property section

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2022-c43760a865

This update's test gating status has been changed to 'waiting'.

4 months ago

This update has obsoleted annobin-10.59-1.fc36, and has inherited its bugs and notes.

4 months ago
User Icon mystro256 commented & provided feedback 4 months ago

Thanks Tom for pulling in rocm-device-libs

This update has been submitted for testing by bodhi.

4 months ago

This update has been pushed to testing.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago
User Icon pwalter commented & provided feedback 4 months ago
karma

Works

tstellar edited this update.

New build(s):

  • llvm-test-suite-14.0.0-1.fc36

Karma has been reset.

4 months ago

This update has been submitted for testing by tstellar.

4 months ago
User Icon thunderbirdtr commented & provided feedback 4 months ago

qt-creator needs to be added into here as well.

 Problem 3: package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed
  - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64
  - cannot install the best update candidate for package qt-creator-7.0.0-2.fc36.x86_64
  - cannot install the best update candidate for package clang-libs-13.0.1-1.fc36.x86_64
 Problem 4: package qt-creator-data-7.0.0-2.fc36.noarch requires qt-creator = 7.0.0-2.fc36, but none of the providers can be installed
  - package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed
  - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64
  - package clang-14.0.0-1.fc36.x86_64 requires libclang-cpp.so.14()(64bit), but none of the providers can be installed
  - package clang-14.0.0-1.fc36.x86_64 requires clang-libs(x86-64) = 14.0.0-1.fc36, but none of the providers can be installed
  - cannot install the best update candidate for package qt-creator-data-7.0.0-2.fc36.noarch
  - cannot install the best update candidate for package clang-13.0.1-1.fc36.x86_64
 Problem 5: problem with installed package qt-creator-7.0.0-2.fc36.x86_64
  - package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed
  - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64
  - package clang-devel-14.0.0-1.fc36.x86_64 requires libclang-cpp.so.14()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package clang-devel-13.0.1-1.fc36.x86_64
 Problem 6: problem with installed package qt-creator-data-7.0.0-2.fc36.noarch
  - package qt-creator-data-7.0.0-2.fc36.noarch requires qt-creator = 7.0.0-2.fc36, but none of the providers can be installed
  - package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed
  - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64
  - clang-libs-14.0.0-1.fc36.i686 has inferior architecture
  - cannot install the best update candidate for package clang-libs-13.0.1-1.fc36.i686

This update has been pushed to testing.

4 months ago
User Icon atim provided feedback 4 months ago
karma
User Icon frantisekz commented & provided feedback 4 months ago
karma

Works well!

User Icon imabug commented & provided feedback 4 months ago
karma

Gave me these errors when upgrading

Problem 1: package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed
 - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64
 - cannot install the best update candidate for package qt-creator-7.0.0-2.fc36.x86_64
 - cannot install the best update candidate for package clang-libs-13.0.1-1.fc36.x86_64
Problem 2: package qt-creator-data-7.0.0-2.fc36.noarch requires qt-creator = 7.0.0-2.fc36, but none of the providers can be installed
 - package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed
 - package clang-libs-13.0.1-1.fc36.x86_64 requires clang-resource-filesystem(x86-64) = 13.0.1, but none of the providers can be installed
 - cannot install both clang-resource-filesystem-14.0.0-1.fc36.x86_64 and clang-resource-filesystem-13.0.1-1.fc36.x86_64
 - cannot install the best update candidate for package qt-creator-data-7.0.0-2.fc36.noarch
 - cannot install the best update candidate for package clang-resource-filesystem-13.0.1-1.fc36.x86_64

Problem 3: problem with installed package qt-creator-7.0.0-2.fc36.x86_64 - package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64 - package clang-tools-extra-14.0.0-1.fc36.x86_64 requires libclang-cpp.so.14()(64bit), but none of the providers can be installed - package clang-tools-extra-14.0.0-1.fc36.x86_64 requires clang-libs(x86-64) = 14.0.0-1.fc36, but none of the providers can be installed - cannot install the best update candidate for package clang-tools-extra-13.0.1-1.fc36.x86_64 Problem 4: package clang-libs-13.0.1-1.fc36.x86_64 requires clang-resource-filesystem(x86-64) = 13.0.1, but none of the providers can be installed - problem with installed package clang-libs-13.0.1-1.fc36.x86_64 - cannot install both clang-resource-filesystem-14.0.0-1.fc36.x86_64 and clang-resource-filesystem-13.0.1-1.fc36.x86_64 - clang-resource-filesystem-14.0.0-1.fc36.i686 has inferior architecture - package libomp-devel-14.0.0-2.fc36.x86_64 requires clang-resource-filesystem = 14.0.0, but none of the providers can be installed - cannot install the best update candidate for package libomp-devel-13.0.1-1.fc36.x86_64 - problem with installed package qt-creator-data-7.0.0-2.fc36.noarch - package qt-creator-data-7.0.0-2.fc36.noarch requires qt-creator = 7.0.0-2.fc36, but none of the providers can be installed - package qt-creator-7.0.0-2.fc36.x86_64 requires clang-libs(x86-64) = 13.0.1, but none of the providers can be installed - cannot install both clang-libs-14.0.0-1.fc36.x86_64 and clang-libs-13.0.1-1.fc36.x86_64

frantisekz edited this update.

New build(s):

  • qt-creator-7.0.0-3.fc36

Karma has been reset.

4 months ago

This update has been submitted for testing by frantisekz.

4 months ago

This update's test gating status has been changed to 'passed'.

4 months ago
User Icon tstellar commented & provided feedback 4 months ago

Hi all, thanks for testing. A new qt-creator build has been added to the update can you re-test and see if the issue has been fixed?

User Icon jistone commented & provided feedback 4 months ago

zig is linked to liblld*.so.13:

 Problem 1: package zig-0.9.1-1.fc36.x86_64 requires liblldCOFF.so.13()(64bit), but none of the providers can be installed
  - package zig-0.9.1-1.fc36.x86_64 requires liblldELF.so.13()(64bit), but none of the providers can be installed
  - package zig-0.9.1-1.fc36.x86_64 requires liblldWasm.so.13()(64bit), but none of the providers can be installed
  - cannot install both lld-libs-14.0.0-2.fc36.x86_64 and lld-libs-13.0.1-1.fc36.x86_64
  - cannot install the best update candidate for package zig-0.9.1-1.fc36.x86_64
  - cannot install the best update candidate for package lld-libs-13.0.1-1.fc36.x86_64
 Problem 2: problem with installed package zig-0.9.1-1.fc36.x86_64
  - package zig-0.9.1-1.fc36.x86_64 requires liblldCOFF.so.13()(64bit), but none of the providers can be installed
  - package zig-0.9.1-1.fc36.x86_64 requires liblldELF.so.13()(64bit), but none of the providers can be installed
  - package zig-0.9.1-1.fc36.x86_64 requires liblldWasm.so.13()(64bit), but none of the providers can be installed
  - cannot install both lld-libs-14.0.0-2.fc36.x86_64 and lld-libs-13.0.1-1.fc36.x86_64
  - package lld-14.0.0-2.fc36.x86_64 requires liblldCOFF.so.14()(64bit), but none of the providers can be installed
  - package lld-14.0.0-2.fc36.x86_64 requires liblldCommon.so.14()(64bit), but none of the providers can be installed
  - package lld-14.0.0-2.fc36.x86_64 requires liblldELF.so.14()(64bit), but none of the providers can be installed
  - package lld-14.0.0-2.fc36.x86_64 requires liblldMachO.so.14()(64bit), but none of the providers can be installed
  - package lld-14.0.0-2.fc36.x86_64 requires liblldMinGW.so.14()(64bit), but none of the providers can be installed
  - package lld-14.0.0-2.fc36.x86_64 requires liblldWasm.so.14()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package lld-13.0.1-1.fc36.x86_64

frantisekz edited this update.

4 months ago
karma

tstellar edited this update.

4 months ago

This update has been pushed to testing.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago

frantisekz edited this update.

4 months ago

This update's test gating status has been changed to 'waiting'.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago

mattia edited this update.

New build(s):

  • lld13-13.0.1-1.fc36

Karma has been reset.

4 months ago

This update has been submitted for testing by mattia.

4 months ago

This update's test gating status has been changed to 'passed'.

4 months ago

This update has been pushed to testing.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago
User Icon jistone provided feedback 4 months ago
karma
BZ#2072077 Get LLVM 14 to F36
karma
BZ#2072077 Get LLVM 14 to F36
User Icon lbrabec commented & provided feedback 4 months ago
karma

didn't break anything

karma
User Icon lruzicka commented & provided feedback 4 months ago
karma

Seems to be working.

frantisekz edited this update.

4 months ago

This update's test gating status has been changed to 'waiting'.

4 months ago

This update's test gating status has been changed to 'failed'.

4 months ago
User Icon decathorpe commented & provided feedback 4 months ago
karma

Looks good to me.

BZ#2072077 Get LLVM 14 to F36

This update's test gating status has been changed to 'waiting'.

4 months ago

This update's test gating status has been changed to 'passed'.

4 months ago

This update has been submitted for stable by frantisekz.

4 months ago

This update has been submitted for stable by frantisekz.

4 months ago
User Icon andilinux commented & provided feedback 4 months ago
karma

works

This update has been pushed to stable.

4 months ago

Please login to add feedback.

BZ#2068657 aarch64 binary has .note.gnu.property but reports FAIL: property-note test because .note.gnu.property section not found
0
0
BZ#2072077 Get LLVM 14 to F36
0
3

Automated Test Results