Qt 5.15.6 update.


Rebuild for clang 15

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2022-d8cd3b01b7

This update's test gating status has been changed to 'waiting'.

a week ago

This update has obsoleted qt5-qttools-5.15.5-3.fc37, and has inherited its bugs and notes.

a week ago

This update has been submitted for testing by bodhi.

a week ago

QGnomePlatform seems to have a noticeable but simple to resolve issue with Qt5 patched for CSD shadows at the moment. The title bar does not extend to the edge of the window, seemingly due to not accounting for the additional margin added by the shadows. This patch resolves it:

--- a/src/decoration/qgnomeplatformdecoration.cpp
+++ b/src/decoration/qgnomeplatformdecoration.cpp
@@ -620,7 +620,7 @@ bool QGnomePlatformDecoration::handleTouch(QWaylandInputDevice *inputDevice,

 QRect QGnomePlatformDecoration::windowContentGeometry() const
 {
-#if QT_VERSION >= 0x060000
+#if DECORATION_SHADOWS_SUPPORT
     return waylandWindow()->windowContentGeometry() + margins(ShadowsOnly);
 #else
     return waylandWindow()->windowContentGeometry();

Thank you. I will fix that.

jgrulich edited this update.

New build(s):

  • qgnomeplatform-0.9.0-2.fc37

Removed build(s):

  • qgnomeplatform-0.9.0-1.fc37

Karma has been reset.

a week ago

This update's test gating status has been changed to 'failed'.

a week ago

adamwill edited this update.

New build(s):

  • qt5-qtwebview-5.15.6-1.fc37

Karma has been reset.

a week ago

This update's test gating status has been changed to 'passed'.

a week ago

This update has been pushed to testing.

a week ago
User Icon phantomx provided feedback a week ago
karma
User Icon mtasaka commented & provided feedback a week ago
karma
 Problem: problem with installed package kuserfeedback-console-1.2.0-5.fc37.x86_64
  - cannot install the best update candidate for package kuserfeedback-console-1.2.0-5.fc37.x86_64
  - package kuserfeedback-console-1.2.0-5.fc37.x86_64 requires libQt5Charts.so.5()(64bit), but none of the providers can be installed
  - package kuserfeedback-console-1.2.0-5.fc37.x86_64 requires libQt5Charts.so.5(Qt_5)(64bit), but none of the providers can be installed
  - package kuserfeedback-console-1.2.0-5.fc37.x86_64 requires libQt5Charts.so.5(Qt_5_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package qt5-qtcharts-5.15.5-2.fc37.x86_64
  - package kuserfeedback-console-1.2.0-5.fc37.x86_64 requires qt5-qtcharts(x86-64) = 5.15.5, but none of the providers can be installed
  - cannot install both qt5-qtcharts-5.15.6-1.fc37.x86_64 and qt5-qtcharts-5.15.5-2.fc37.x86_64
  - cannot install both qt5-qtcharts-5.15.5-2.fc37.x86_64 and qt5-qtcharts-5.15.6-1.fc37.x86_64

 Problem: problem with installed package libfm-qt-1.1.0-3.fc37.x86_64
  - cannot install the best update candidate for package libfm-qt-1.1.0-3.fc37.x86_64
  - package libfm-qt-1.1.0-3.fc37.x86_64 requires libQt5Core.so.5()(64bit), but none of the providers can be installed
  - package libfm-qt-1.1.0-3.fc37.x86_64 requires libQt5Core.so.5(Qt_5)(64bit), but none of the providers can be installed
  - package libfm-qt-1.1.0-3.fc37.x86_64 requires libQt5Core.so.5(Qt_5.15)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package qt5-qtbase-5.15.5-4.fc37.x86_64
  - package libfm-qt-1.1.0-3.fc37.x86_64 requires qt5-qtbase(x86-64) = 5.15.5, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.15.6-1.fc37.x86_64 and qt5-qtbase-5.15.5-4.fc37.x86_64
  - cannot install both qt5-qtbase-5.15.5-4.fc37.x86_64 and qt5-qtbase-5.15.6-1.fc37.x86_64

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

a week ago

More two pkgs:

gammaray-qt5-0:2.11.3-4.fc37.x86_64             qt5-qtbase(x86-64) = 5.15.5
mscore-0:3.6.2-10.fc37.x86_64           qt5-qtquickcontrols(x86-64) = 5.15.5
User Icon mhayden commented & provided feedback a week ago
karma

Looking good so far.

jgrulich edited this update.

New build(s):

  • mscore-3.6.2-11.fc37
  • gammaray-2.11.3-5.fc37
  • kuserfeedback-1.2.0-6.fc37
  • libfm-qt-1.1.0-4.fc37

Karma has been reset.

a week ago

This update has been submitted for testing by jgrulich.

a week ago
User Icon jjames commented & provided feedback a week ago
karma

The mscore change completely removes dependencies on qt5-qtquickcontrols and qt5-qtquickcontrols2, rather than just removing the version from the dependency. The mscore package really does need those. Can you put the dependencies back, please, just without the version requirement?

Ups, sorry, I was trying to be fast and messed up. Fix is on the way. Thank you for double-checking.

jgrulich edited this update.

New build(s):

  • mscore-3.6.2-12.fc37
  • kuserfeedback-1.2.0-7.fc37

Removed build(s):

  • kuserfeedback-1.2.0-6.fc37
  • mscore-3.6.2-11.fc37

Karma has been reset.

a week ago
User Icon phantomx provided feedback a week ago
karma

xdg-desktop-portal-kde crashed when run by sddm during boot with Qt 5.15.6 as reported at https://bugzilla.redhat.com/show_bug.cgi?id=2129479

This update has been pushed to testing.

a week ago
User Icon chr77 commented & provided feedback a week ago
karma

Works for me. No regressions noted compared to previous version.

This update can be pushed to stable now if the maintainer wishes

a week ago
User Icon smithp commented & provided feedback a week ago
karma

+1

User Icon frantisekz commented & provided feedback a week ago
karma

Seems to work well

User Icon remyabel commented & provided feedback a week ago
karma

Works for me.

This update has been submitted for stable by pwalter.

a week ago

This update has been pushed to stable.

a week ago
User Icon tseewald commented & provided feedback 4 days ago
karma

Getting a white SDDM screen at first login (x11) due to xdg-desktop-portal-kde crashing. Looks like this has already been reported: https://bugzilla.redhat.com/show_bug.cgi?id=2129479

xdg-desktop-por[1568]: cannot open display: Parent is QGuiApplication(0x7fff72521370), parent's thread is QThread(0x558a4fae1e80), current thread is QThread(0x558a4fcb0d60)
sddm-greeter[1545]: QObject: Cannot create children for a parent that is in a different thread. (Parent is QGuiApplication(0x7fff72521370), parent's thread is QThread(0x558a4fae1e80), current thread is QThread(0x558a4fcb0d60)
sddm-greeter[1545]: QObject: Cannot create children for a parent that is in a different thread. (Parent is QGuiApplication(0x7fff72521370), parent's thread is QThread(0x558a4fae1e80), current thread is QThread(0x558a4fcb0d60)
sddm-greeter[1545]: QObject: Cannot create children for a parent that is in a different thread. (Parent is QGuiApplication(0x7fff72521370), parent's thread is QThread(0x558a4fae1e80), current thread is QThread(0x558a4fcb0d60)
sddm-greeter[1545]: QObject: Cannot create children for a parent that is in a different thread. (Parent is QGuiApplication(0x7fff72521370), parent's thread is QThread(0x558a4fae1e80), current thread is QThread(0x558a4fcb0d60)
sddm-greeter[1545]: QObject: Cannot create children for a parent that is in a different thread. (Parent is QGuiApplication(0x7fff72521370), parent's thread is QThread(0x558a4fae1e80), current thread is QThread(0x558a4fcb0d60)
sddm-greeter[1545]: QObject::installEventFilter(): Cannot filter events for objects in a different thread.
audit[1582]: ANOM_ABEND auid=988 uid=988 gid=986 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=1582 comm="xdg-desktop-por" exe="/usr/libexec/xdg-desktop-portal-kde" sig=6 res=1
xdg-desktop-portal-kde[1582]: qt.qpa.xcb: could not connect to display
xdg-desktop-portal-kde[1582]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
xdg-desktop-portal-kde[1582]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

                                                          Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

@tseewald I've seen the white SDDM background problem, but it was due to the Breeze Fedora SDDM theme background being set to a file which no longer existed instead of the xdg-desktop-portal-kde crashes with Qt 5.15.6 I reported at https://bugzilla.redhat.com/show_bug.cgi?id=2129479 I fixed the white SDDM background in System Settings > Startup and Shutdown > Login Screen (SDDM) > Change Background icon > Load from file and selected a background from /usr/share/wallpapers/F37/contents/images/ with the resolution of my screen. Selecting the Breeze theme in the Login Screen (SDDM) page also fixed this problem for me in the past.


Please login to add feedback.

Metadata
Type
bugfix
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
a week ago
in testing
a week ago
in stable
a week ago
modified
a week ago

Automated Test Results