obsolete

FEDORA-2022-fa47fb789c created by jakub 6 months ago for Fedora 36

Automatic update for gcc-12.0.1-0.1.fc36.

Changelog
* Tue Jan 18 2022 Jakub Jelinek <jakub@redhat.com> 12.0.1-0.1
- update from trunk
  - PRs c++/104031, c/63272, fortran/83079, fortran/87711, fortran/97896,
    libstdc++/103650, libstdc++/104080, middle-end/101292, target/103124,
    target/103973, target/104005, testsuite/104035, testsuite/104037,
    tree-optimization/80532, tree-optimization/101941,
    tree-optimization/104064

This update was automatically created

6 months ago

This update's test gating status has been changed to 'waiting'.

6 months ago

We want gcc-12.0.1-0.1.1.fc36 or even better gcc-12.0.1-0.2.fc36, rather than this build.

User Icon mcermak provided feedback 6 months ago
karma

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

6 months ago

This update's test gating status has been changed to 'failed'.

6 months ago

It would be great if PR libstdc++/104099 could also be picked up, as that one is causing a build failure of KiCad in Rawhide as shown here:

https://copr.fedorainfracloud.org/coprs/g/kicad/kicad/build/3196619/

This update has been obsoleted by gcc-12.0.1-0.2.fc36.

6 months ago

PR104099 is actually fixed in 12-0.1-0.2.fc36, I just forgot to mention it in the %changelog (created snapshot, then noticed the PR was fixed and merged again from release branch to cherry pick that fix, but didn't update %changelog for it).

That is excellent news, Jakub. Thanks!

I'll run a test build and comment on the gcc-12.0.1-0.2.fc36 page.

Note, the PR104099 change just buys the basic_json using packages some time, as nothing changed for C++23 which requires the behavior that gcc previously had for older standards as an extension. So at latest when g++ switches to -std=gnu++23 by default (right now the default is still -std=gnu++17), it will not work again.

Understood. KiCad explicitly selects -std=gnu++17 in its cmake configuration, so it shouldn't be affected by a change to -std=gnu++23 as the default.


Please login to add feedback.

Metadata
Type
unspecified
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
6 months ago
in testing
6 months ago

Automated Test Results